[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / py-peewee

File: [cvs.NetBSD.org] / pkgsrc / databases / py-peewee / Makefile (download)

Revision 1.14, Wed Oct 26 14:28:16 2016 UTC (7 years, 5 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.13: +2 -2 lines

Update databases/py-peewee to 2.8.5.

2.8.5

- Starting docs on sqliteq
- Use parentheses for compound select with MySQL.
- Remove "clean_prefetch_subquery" as I'm not sure why it exists in the
  first place.

2.8.4

- New playhouse extension module for working with SQLite in
  multi-threaded / concurrent environments. The new module is called
  playhouse.sqliteq and it works by serializing queries using a dedicated
  worker thread (or greenlet). The performance is quite good, hopefully
  this proves useful to someone besides myself! You can learn more by
  reading the sqliteq documentation.
- #1061 - @akrs patched a bug in TimestampField which affected the
  accuracy of sub-second timestamps (for resolution > 1).
- #1071, small python 3 fix.
- #1072, allow DeferredRelation to be used multiple times if there are
  multiple references to a given deferred model.
- #1073, fixed regression in the speedups module that caused SQL
  functions to always coerce return values, regardless of the coerce
  flag.
- #1083, another Python 3 issue - this time regarding the use of
  exc.message.

# $NetBSD: Makefile,v 1.14 2016/10/26 14:28:16 fhajny Exp $

DISTNAME=	peewee-2.8.5
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	databases
MASTER_SITES=	${MASTER_SITE_GITHUB:=coleifer/}

MAINTAINER=	filip@joyent.com
HOMEPAGE=	http://www.peewee-orm.com/
COMMENT=	Small, expressive ORM for PostgreSQL, MySQL and SQLite
LICENSE=	mit

GITHUB_PROJECT=	peewee

USE_LANGUAGES=	c
USE_TOOLS+=	bash

MESSAGE_SUBST+=	PYPKGPREFIX=${PYPKGPREFIX}

REPLACE_BASH+=		playhouse/berkeley_build.sh
REPLACE_PYTHON+=	pwiz.py

PYDISTUTILSPKG=		yes

.include "../../devel/py-cython/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"