Up to [cvs.NetBSD.org] / pkgsrc / databases / py-cassandra-driver
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.29 / (download) - annotate - [select for diffs], Wed Nov 15 09:24:57 2023 UTC (3 weeks ago) by wiz
Branch: MAIN
CVS Tags: HEAD
Changes since 1.28: +4 -4
lines
Diff to previous 1.28 (colored)
py-cassandra-driver: update to 3.28.0. 3.28.0 ====== June 5, 2023 Features -------- * Add support for vector type (PYTHON-1352) * Cryptography module is now an optional dependency (PYTHON-1351) Bug Fixes --------- * Store IV along with encrypted text when using column-level encryption (PYTHON-1350) * Create session-specific protocol handlers to contain session-specific CLE policies (PYTHON-1356) Others ------ * Use Cython for smoke builds (PYTHON-1343) * Don't fail when inserting UDTs with prepared queries with some missing fields (PR 1151) * Convert print statement to function in docs (PR 1157) * Update comment for retry policy (DOC-3278) * Added error handling blog reference (DOC-2813) 3.27.0 ====== May 1, 2023 Features -------- * Add support for client-side encryption (PYTHON-1341) 3.26.0 ====== March 13, 2023 Features -------- * Add support for execution profiles in execute_concurrent (PR 1122) Bug Fixes --------- * Handle empty non-final result pages (PR 1110) * Do not re-use stream IDs for in-flight requests (PR 1114) * Asyncore race condition cause logging exception on shutdown (PYTHON-1266) Others ------ * Fix deprecation warning in query tracing (PR 1103) * Remove mutable default values from some tests (PR 1116) * Remove dependency on unittest2 (PYTHON-1289) * Fix deprecation warnings for asyncio.coroutine annotation in asyncioreactor (PYTHON-1290) * Fix typos in source files (PR 1126) * HostFilterPolicyInitTest fix for Python 3.11 (PR 1131) * Fix for DontPrepareOnIgnoredHostsTest (PYTHON-1287) * tests.integration.simulacron.test_connection failures (PYTHON-1304) * tests.integration.standard.test_single_interface.py appears to be failing for C* 4.0 (PYTHON-1329) * Authentication tests appear to be failing fraudulently (PYTHON-1328) * PreparedStatementTests.test_fail_if_different_query_id_on_reprepare() failing unexpectedly (PTYHON-1327) * Refactor deprecated unittest aliases for Python 3.11 compatibility (PR 1112) Deprecations ------------ * This release removes support for Python 2.7.x as well as Python 3.5.x and 3.6.x 3.25.0 ====== March 18, 2021 Features -------- * Ensure the driver can connect when invalid peer hosts are in system.peers (PYTHON-1260) * Implement protocol v5 checksumming (PYTHON-1258) * Fix the default cqlengine connection mechanism to work with Astra (PYTHON-1265) Bug Fixes --------- * Asyncore race condition cause logging exception on shutdown (PYTHON-1266) * Update list of reserved keywords (PYTHON-1269) Others ------ * Drop Python 3.4 support (PYTHON-1220) * Update security documentation and examples to use PROTOCOL_TLS (PYTHON-1264) 3.24.0 ====== June 18, 2020 Features -------- * Make geomet an optional dependency at runtime (PYTHON-1237) * Add use_default_tempdir cloud config options (PYTHON-1245) * Tcp flow control for libevreactor (PYTHON-1248) Bug Fixes --------- * Unable to connect to a cloud cluster using Ubuntu 20.04 (PYTHON-1238) * PlainTextAuthProvider fails with unicode chars and Python3 (PYTHON-1241) * [GRAPH] Graph execution profiles consistency level are not set to LOCAL_QUORUM with a cloud cluster (PYTHON-1240) * [GRAPH] Can't write data in a Boolean field using the Fluent API (PYTHON-1239) * [GRAPH] Fix elementMap() result deserialization (PYTHON-1233) Others ------ * Bump geomet dependency version to 0.2 (PYTHON-1243) * Bump gremlinpython dependency version to 3.4.6 (PYTHON-1212) * Improve fluent graph documentation for core graphs (PYTHON-1244) 3.23.0 ====== April 6, 2020 Features -------- * Transient Replication Support (PYTHON-1207) * Support system.peers_v2 and port discovery for C* 4.0 (PYTHON-700) Bug Fixes --------- * Asyncore logging exception on shutdown (PYTHON-1228) 3.22.0 ====== February 26, 2020 Features -------- * Add all() function to the ResultSet API (PYTHON-1203) * Parse new schema metadata in NGDG and generate table edges CQL syntax (PYTHON-996) * Add GraphSON3 support (PYTHON-788) * Use GraphSON3 as default for Native graphs (PYTHON-1004) * Add Tuple and UDT types for native graph (PYTHON-1005) * Add Duration type for native graph (PYTHON-1000) * Add gx:ByteBuffer graphson type support for Blob field (PYTHON-1027) * Enable Paging Through DSE Driver for Gremlin Traversals (PYTHON-1045) * Provide numerical wrappers to ensure proper graphson schema definition (PYTHON-1051) * Resolve the row_factory automatically for native graphs (PYTHON-1056) * Add g:TraversalMetrics/g:Metrics graph deserializers (PYTHON-1057) * Add g:BulkSet graph deserializers (PYTHON-1060) * Update Graph Engine names and the way to create a Classic/Native Graph (PYTHON-1090) * Update Native to Core Graph Engine * Add graphson3 and native graph support (PYTHON-1039) * Enable Paging Through DSE Driver for Gremlin Traversals (PYTHON-1045) * Expose filter predicates for cql collections (PYTHON-1019) * Add g:TraversalMetrics/Metrics deserializers (PYTHON-1057) * Make graph metadata handling more robust (PYTHON-1204) Bug Fixes --------- * Make sure to only query the native_transport_address column with DSE (PYTHON-1205) 3.21.0 ====== January 15, 2020 Features -------- * Unified driver: merge core and DSE drivers into a single package (PYTHON-1130) * Add Python 3.8 support (PYTHON-1189) * Allow passing ssl context for Twisted (PYTHON-1161) * Ssl context and cloud support for Eventlet (PYTHON-1162) * Cloud Twisted support (PYTHON-1163) * Add additional_write_policy and read_repair to system schema parsing (PYTHON-1048) * Flexible version parsing (PYTHON-1174) * Support NULL in collection deserializer (PYTHON-1123) * [GRAPH] Ability to execute Fluent Graph queries asynchronously (PYTHON-1129) Bug Fixes --------- * Handle prepared id mismatch when repreparing on the fly (PYTHON-1124) * re-raising the CQLEngineException will fail on Python 3 (PYTHON-1166) * asyncio message chunks can be processed discontinuously (PYTHON-1185) * Reconnect attempts persist after downed node removed from peers (PYTHON-1181) * Connection fails to validate ssl certificate hostname when SSLContext.check_hostname is set (PYTHON-1186) * ResponseFuture._set_result crashes on connection error when used with PrepareMessage (PYTHON-1187) * Insights fail to serialize the startup message when the SSL Context is from PyOpenSSL (PYTHON-1192) Others ------ * The driver has a new dependency: geomet. It comes from the dse-driver unification and is used to support DSE geo types. * Remove *read_repair_chance table options (PYTHON-1140) * Avoid warnings about unspecified load balancing policy when connecting to a cloud cluster (PYTHON-1177) * Add new DSE CQL keywords (PYTHON-1122) * Publish binary wheel distributions (PYTHON-1013) Deprecations ------------ * DSELoadBalancingPolicy will be removed in the next major, consider using the DefaultLoadBalancingPolicy. Merged from dse-driver: Features -------- * Insights integration (PYTHON-1047) * Graph execution profiles should preserve their graph_source when graph_options is overridden (PYTHON-1021) * Add NodeSync metadata (PYTHON-799) * Add new NodeSync failure values (PYTHON-934) * DETERMINISTIC and MONOTONIC Clauses for Functions and Aggregates (PYTHON-955) * GraphOptions should show a warning for unknown parameters (PYTHON-819) * DSE protocol version 2 and continous paging backpressure (PYTHON-798) * GraphSON2 Serialization/Deserialization Support (PYTHON-775) * Add graph-results payload option for GraphSON format (PYTHON-773) * Create an AuthProvider for the DSE transitional mode (PYTHON-831) * Implement serializers for the Graph String API (PYTHON-778) * Provide deserializers for GraphSON types (PYTHON-782) * Add Graph DurationType support (PYTHON-607) * Support DSE DateRange type (PYTHON-668) * RLAC CQL output for materialized views (PYTHON-682) * Add Geom Types wkt deserializer * DSE Graph Client timeouts in custom payload (PYTHON-589) * Make DSEGSSAPIAuthProvider accept principal name (PYTHON-574) * Add config profiles to DSE graph execution (PYTHON-570) * DSE Driver version checking (PYTHON-568) * Distinct default timeout for graph queries (PYTHON-477) * Graph result parsing for known types (PYTHON-479,487) * Distinct read/write CL for graph execution (PYTHON-509) * Target graph analytics query to spark master when available (PYTHON-510) Bug Fixes --------- * Continuous paging sessions raise RuntimeError when results are not entirely consumed (PYTHON-1054) * GraphSON Property deserializer should return a dict instead of a set (PYTHON-1033) * ResponseFuture.has_more_pages may hold the wrong value (PYTHON-946) * DETERMINISTIC clause in AGGREGATE misplaced in CQL generation (PYTHON-963) * graph module import cause a DLL issue on Windows due to its cythonizing failure (PYTHON-900) * Update date serialization to isoformat in graph (PYTHON-805) * DateRange Parse Error (PYTHON-729) * MontonicTimestampGenerator.__init__ ignores class defaults (PYTHON-728) * metadata.get_host returning None unexpectedly (PYTHON-709) * Sockets associated with sessions not getting cleaned up on session.shutdown() (PYTHON-673) * Resolve FQDN from ip address and use that as host passed to SASLClient (PYTHON-566) * Geospatial type implementations don't handle 'EMPTY' values. (PYTHON-481) * Correctly handle other types in geo type equality (PYTHON-508) Other ----- * Add tests around cqlengine and continuous paging (PYTHON-872) * Add an abstract GraphStatement to handle different graph statements (PYTHON-789) * Write documentation examples for DSE 2.0 features (PYTHON-732) * DSE_V1 protocol should not include all of protocol v5 (PYTHON-694) 3.20.2 ====== November 19, 2019 Bug Fixes --------- * Fix import error for old python installation without SSLContext (PYTHON-1183) 3.20.1 ====== November 6, 2019 Bug Fixes --------- * ValueError: too many values to unpack (expected 2)" when there are two dashes in server version number (PYTHON-1172) 3.20.0 ====== October 28, 2019 Features -------- * DataStax Astra Support (PYTHON-1074) * Use 4.0 schema parser in 4 alpha and snapshot builds (PYTHON-1158) Bug Fixes --------- * Connection setup methods prevent using ExecutionProfile in cqlengine (PYTHON-1009) * Driver deadlock if all connections dropped by heartbeat whilst request in flight and request times out (PYTHON-1044) * Exception when use pk__token__gt filter In python 3.7 (PYTHON-1121) 3.19.0 ====== August 26, 2019 Features -------- * Add Python 3.7 support (PYTHON-1016) * Future-proof Mapping imports (PYTHON-1023) * Include param values in cqlengine logging (PYTHON-1105) * NTS Token Replica Map Generation is slow (PYTHON-622) Bug Fixes --------- * as_cql_query UDF/UDA parameters incorrectly includes "frozen" if arguments are collections (PYTHON-1031) * cqlengine does not currently support combining TTL and TIMESTAMP on INSERT (PYTHON-1093) * Fix incorrect metadata for compact counter tables (PYTHON-1100) * Call ConnectionException with correct kwargs (PYTHON-1117) * Can't connect to clusters built from source because version parsing doesn't handle 'x.y-SNAPSHOT' (PYTHON-1118) * Discovered node doesn´t honor the configured Cluster port on connection (PYTHON-1127) * Exception when use pk__token__gt filter In python 3.7 (PYTHON-1121) Other ----- * Remove invalid warning in set_session when we initialize a default connection (PYTHON-1104) * Set the proper default ExecutionProfile.row_factory value (PYTHON-1119) 3.18.0 ====== May 27, 2019 Features -------- * Abstract Host Connection information (PYTHON-1079) * Improve version parsing to support a non-integer 4th component (PYTHON-1091) * Expose on_request_error method in the RetryPolicy (PYTHON-1064) * Add jitter to ExponentialReconnectionPolicy (PYTHON-1065) Bug Fixes --------- * Fix error when preparing queries with beta protocol v5 (PYTHON-1081) * Accept legacy empty strings as column names (PYTHON-1082) * Let util.SortedSet handle uncomparable elements (PYTHON-1087) 3.17.1 ====== May 2, 2019 Bug Fixes --------- * Socket errors EAGAIN/EWOULDBLOCK are not handled properly and cause timeouts (PYTHON-1089) 3.17.0 ====== February 19, 2019 Features -------- * Send driver name and version in startup message (PYTHON-1068) * Add Cluster ssl_context option to enable SSL (PYTHON-995) * Allow encrypted private keys for 2-way SSL cluster connections (PYTHON-995) * Introduce new method ConsistencyLevel.is_serial (PYTHON-1067) * Add Session.get_execution_profile (PYTHON-932) * Add host kwarg to Session.execute/execute_async APIs to send a query to a specific node (PYTHON-993) Bug Fixes --------- * NoHostAvailable when all hosts are up and connectable (PYTHON-891) * Serial consistency level is not used (PYTHON-1007) Other ----- * Fail faster on incorrect lz4 import (PYTHON-1042) * Bump Cython dependency version to 0.29 (PYTHON-1036) * Expand Driver SSL Documentation (PYTHON-740) Deprecations ------------ * Using Cluster.ssl_options to enable SSL is deprecated and will be removed in the next major release, use ssl_context. * DowngradingConsistencyRetryPolicy is deprecated and will be removed in the next major release. (PYTHON-937) 3.16.0 ====== November 12, 2018 Bug Fixes --------- * Improve and fix socket error-catching code in nonblocking-socket reactors (PYTHON-1024) * Non-ASCII characters in schema break CQL string generation (PYTHON-1008) * Fix OSS driver's virtual table support against DSE 6.0.X and future server releases (PYTHON-1020) * ResultSet.one() fails if the row_factory is using a generator (PYTHON-1026) * Log profile name on attempt to create existing profile (PYTHON-944) * Cluster instantiation fails if any contact points' hostname resolution fails (PYTHON-895) Other ----- * Fix tests when RF is not maintained if we decomission a node (PYTHON-1017) * Fix wrong use of ResultSet indexing (PYTHON-1015)
Revision 1.28 / (download) - annotate - [select for diffs], Tue Oct 26 10:09:49 2021 UTC (2 years, 1 month ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.27: +2 -2
lines
Diff to previous 1.27 (colored)
databases: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes The following distfiles could not be fetched (some may be only fetched conditionally): ./databases/cstore/distinfo D6.data.ros.gz ./databases/cstore/distinfo cstore0.2.tar.gz ./databases/cstore/distinfo data4.tar.gz
Revision 1.27 / (download) - annotate - [select for diffs], Thu Oct 7 13:35:36 2021 UTC (2 years, 1 month ago) by nia
Branch: MAIN
Changes since 1.26: +1 -2
lines
Diff to previous 1.26 (colored)
databases: Remove SHA1 distfile hashes
Revision 1.26 / (download) - annotate - [select for diffs], Mon Sep 10 12:18:09 2018 UTC (5 years, 2 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3
Changes since 1.25: +5 -5
lines
Diff to previous 1.25 (colored)
databases/py-cassandra-driver: Update to 3.15.1. - C* 4.0 schema-parsing logic breaks running against DSE 6.0.X
Revision 1.25 / (download) - annotate - [select for diffs], Tue Sep 4 13:15:04 2018 UTC (5 years, 3 months ago) by fhajny
Branch: MAIN
Changes since 1.24: +5 -5
lines
Diff to previous 1.24 (colored)
databases/py-cassandra-driver: Update to 3.15.0 Features -------- - Parse Virtual Keyspace Metadata Bug Fixes --------- - Tokenmap.get_replicas returns the wrong value if token coincides with the end of the range - Python Driver fails with "more than 255 arguments" python exception when > 255 columns specified in query response - Hang in integration.standard.test_cluster.ClusterTests.test_set_keyspace_twice - Asyncore reactors should use a global variable instead of a class variable for the event loop Other ----- - Use global variable for libev loops so it can be subclassed - Update SchemaParser for V4 - Bump Cython dependency version to 0.28
Revision 1.24 / (download) - annotate - [select for diffs], Wed Apr 18 07:30:53 2018 UTC (5 years, 7 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Changes since 1.23: +5 -5
lines
Diff to previous 1.23 (colored)
databases/py-cassandra-driver: Update to 3.14.0. 3.14.0 ====== Features -------- - Add one() function to the ResultSet API - Create an utility function to fetch concurrently many keys from the same replica - Allow filter queries with fields that have an index managed outside of cqlengine - Twisted SSL Support - Support IS NOT NULL operator in cqlengine Other ----- - Fix Broken Links in Docs - Reevaluate MONKEY_PATCH_LOOP in test codebase - Remove CASS_SERVER_VERSION and replace it for CASSANDRA_VERSION in tests - Refactor CASSANDRA_VERSION to a some kind of version object - Log warning when driver configures an authenticator, but server does not request authentication - Warn users when using the deprecated Session.default_consistency_level - Add DSE smoke test to OSS driver tests - Document long compilation times and workarounds - Improve error for batch WriteTimeouts - Deprecate ResultSet indexing 3.13.0 ====== Features -------- - cqlengine: LIKE filter operator - Support cassandra.query.BatchType with cqlengine BatchQuery Bug Fixes --------- - AttributeError: 'NoneType' object has no attribute 'add_timer' - Support retry_policy in PreparedStatement - __del__ method in Session is throwing an exception - LZ4 import issue with recent versions - ResponseFuture._connection can be None when returning request_id - ResultSet.was_applied doesn't support batch with LWT statements Other ----- - cqlengine: avoid warning when unregistering connection on shutdown - Fix DeprecationWarning of log.warn - Fix example_mapper.py for python3 - Possible deadlock on cassandra.concurrent.execute_concurrent - Add some known deprecated warnings for 4.x - Remove copyright dates from copyright notices - Remove "Experimental" tag from execution profiles documentation - request_timer metrics descriptions are slightly incorrect - Remove "Experimental" tag from cqlengine connections documentation - Set in documentation default consistency for operations is LOCAL_ONE
Revision 1.23 / (download) - annotate - [select for diffs], Thu Nov 16 14:49:12 2017 UTC (6 years ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4
Changes since 1.22: +5 -5
lines
Diff to previous 1.22 (colored)
Update databases/py-cassandra-driver to 3.12.0. Features - Send keyspace in QUERY, PREPARE, and BATCH messages - Add IPv4Address/IPv6Address support for inet types - WriteType.CDC and VIEW missing - Warn on Cluster init if contact points are specified but LBP isn't - Include hash of result set metadata in prepared stmt id - Add NO_COMPACT startup option - Add new exception type for CDC Bug Fixes - Both _set_final_exception/result called for the same ResponseFuture - Use of DCAwareRoundRobinPolicy raises NoHostAvailable exception - Not create two sessions by default in CQLEngine - Bug when subclassing AyncoreConnection - Error at cleanup when closing the asyncore connections - Fix sites where sessions can change during iteration - cqlengine: allow min_length=0 for Ascii and Text column types - Rare exception when "sys.exit(0)" after query timeouts - Dont set the session keyspace when preparing statements - Use of DCAwareRoundRobinPolicy raises NoHostAvailable exception Other - Remove DeprecationWarning when using WhiteListRoundRobinPolicy - Bump Cython dependency version to 0.27
Revision 1.22 / (download) - annotate - [select for diffs], Wed Aug 2 15:32:48 2017 UTC (6 years, 4 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Changes since 1.21: +5 -6
lines
Diff to previous 1.21 (colored)
Update databases/py-cassandra-driver to 3.11.0. Features -------- - Add idle_heartbeat_timeout cluster option to tune how long to wait for heartbeat responses. - Add HostFilterPolicy Bug Fixes --------- - is_idempotent flag is not propagated from PreparedStatement to BoundStatement - Fix asyncore hang on exit - Driver takes several minutes to remove a bad host from session - Installation doesn't always fall back to no cython in Windows - Avoid to replace a connection that is supposed to shutdown - request_ids may not be returned to the pool - Fix murmur3 on big-endian systems - Ensure unused connections are closed if a Session is deleted by the GC - Fix .values_list by using db names internally (cqlengine) Other ----- - Bump Cython dependency version to 0.25.2 - Fix DeprecationWarning when using lz4 - Deprecate WhiteListRoundRobinPolicy - Improve upgrade guide for materializing pages - Documentation for time/date specifies timestamp inupt as microseconds - Point to DSA Slack, not IRC, in docs index
Revision 1.21 / (download) - annotate - [select for diffs], Wed Jun 14 14:19:02 2017 UTC (6 years, 5 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2
Changes since 1.20: +6 -5
lines
Diff to previous 1.20 (colored)
Update databases/py-cassandra-driver to 3.10.0 Features - Add Duration type to cqlengine - Community PR review: Raise error on primary key update only if its value changed - get_query_trace() contract is ambiguous Bug Fixes - Queries using speculative execution policy timeout prematurely - Fix map where results are not consumed - Driver fails to encode Duration's with large values - UDT values are not updated correctly in CQLEngine - UDT types are not validated in CQLEngine - to_python is not implemented for types columns.Type and columns.Date in CQLEngine - Clients spin infinitely trying to connect to a host that is drained - Resulset.get_query_trace returns empty trace sometimes - Memory grows and doesn't get removed - Fix RuntimeError caused by change dict size during iteration - fix ExponentialReconnectionPolicy may throw OverflowError problem - Avoid using nonexistent prepared statement in ResponseFuture Other - Update README - Test python versions 3.5 and 3.6 - Docs Warning About Prepare "select *" - Increase Coverage in CqlEngine Test Suite - Example SSL connection code does not verify server certificates
Revision 1.20 / (download) - annotate - [select for diffs], Tue Apr 18 15:31:36 2017 UTC (6 years, 7 months ago) by fhajny
Branch: MAIN
Changes since 1.19: +5 -5
lines
Diff to previous 1.19 (colored)
Update databases/py-cassandra-driver to 3.9.0. 3.9.0 Features - cqlengine: remove elements by key from a map Bug Fixes - improve error handling when connecting to non-existent keyspace - Sockets associated with sessions not getting cleaned up on session.shutdown() - rare flake on integration.standard.test_cluster.ClusterTests.test_clone_shared_lbp - MontonicTimestampGenerator.__init__ ignores class defaults - race where callback or errback for request may not be called - cqlengine: model.update() should not update columns with a default value that hasn't changed - cqlengine: field value manager's explicit flag is True when queried back from cassandra Other - Connection not closed in example_mapper - Remove mention of pre-2.0 C* versions from OSS 3.0+ docs 3.8.1 Bug Fixes - implement __le__/__ge__/__ne__ on some custom types - Fix bug in eventlet and gevent reactors that could cause hangs - Fix DecimalType regression
Revision 1.19 / (download) - annotate - [select for diffs], Mon Feb 27 08:41:48 2017 UTC (6 years, 9 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.18: +5 -6
lines
Diff to previous 1.18 (colored)
Update databases/py-cassandra-driver to 3.8.0. Features - Quote index names in metadata CQL generation (PYTHON-616) - On column deserialization failure, keep error message consistent between python and cython (PYTHON-631) - TokenAwarePolicy always sends requests to the same replica for a given key (PYTHON-643) - Added cql types to result set (PYTHON-648) - Add __len__ to BatchStatement (PYTHON-650) - Duration Type for Cassandra (PYTHON-655) - Send flags with PREPARE message in v5 (PYTHON-684) Bug Fixes - Potential Timing issue if application exits prior to session pool initialization (PYTHON-636) - "Host X.X.X.X has been marked down" without any exceptions (PYTHON-640) - NoHostAvailable or OperationTimedOut when using execute_concurrent with a generator that inserts into more than one table (PYTHON-642) - ResponseFuture creates Timers and don't cancel them even when result is received which leads to memory leaks (PYTHON-644) - Driver cannot connect to Cassandra version > 3 (PYTHON-646) - Unable to import model using UserType without setuping connection since 3.7 (PYTHON-649) - Don't prepare queries on ignored hosts on_up (PYTHON-669) - Sockets associated with sessions not getting cleaned up on session.shutdown() (PYTHON-673) - Make client timestamps strictly monotonic (PYTHON-676) - cassandra.cqlengine.connection.register_connection broken when hosts=None (PYTHON-692) Other - Create a cqlengine doc section explaining None semantics (PYTHON-623) - Resolve warnings in documentation generation (PYTHON-645) - Cython dependency (PYTHON-686) - Drop Support for Python 2.6 (PYTHON-690)
Revision 1.18 / (download) - annotate - [select for diffs], Thu Feb 16 10:43:12 2017 UTC (6 years, 9 months ago) by fhajny
Branch: MAIN
Changes since 1.17: +2 -1
lines
Diff to previous 1.17 (colored)
Add support for Cython>0.24 using an override mechanism in trunk.
Revision 1.17 / (download) - annotate - [select for diffs], Fri Nov 4 11:00:53 2016 UTC (7 years, 1 month ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4
Changes since 1.16: +5 -5
lines
Diff to previous 1.16 (colored)
Update databases/py-cassandra-driver to 3.7.1. - Cython upgrade has broken stable version of cassandra-driver
Revision 1.16 / (download) - annotate - [select for diffs], Mon Sep 19 11:56:10 2016 UTC (7 years, 2 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base,
pkgsrc-2016Q3
Changes since 1.15: +5 -5
lines
Diff to previous 1.15 (colored)
Update databases/py-cassandra-driver to 3.7.0. Features - Add v5 protocol failure map - Don't return from initial connect on first error - Indicate failed column when deserialization fails - Let Cluster.refresh_nodes force a token map rebuild - Refresh UDTs after "keyspace updated" event with v1/v2 protocol - EC2 Address Resolver - Speculative query retries - Expose paging state in API - Don't mark host down while one connection is active - Query request size information - Avoid quadratic ring processing with invalid replication factors - Improve Connection/Pool creation concurrency on startup - Add beta version native protocol flag - cqlengine: Connections: support of multiple keyspaces and sessions Bug Fixes - Race when adding a pool while setting keyspace - Update results_metadata when prepared statement is reprepared - CQL Export for Thrift Tables - cqlengine: default value not applied to UserDefinedType - cqlengine: columns are no longer hashable - cqlengine: remove clustering keys from where clause when deleting only static columns
Revision 1.15 / (download) - annotate - [select for diffs], Tue Aug 9 09:01:21 2016 UTC (7 years, 3 months ago) by fhajny
Branch: MAIN
Changes since 1.14: +5 -5
lines
Diff to previous 1.14 (colored)
Update databases/py-cassandra-driver to 3.6.0. Features - Handle null values in NumpyProtocolHandler (PYTHON-553) - Collect greplin scales stats per cluster (PYTHON-561) - Update mock unit test dependency requirement (PYTHON-591) - Handle Missing CompositeType metadata following C* upgrade (PYTHON-562) - Improve Host.is_up state for HostDistance.IGNORED hosts (PYTHON-551) - Utilize v2 protocol's ability to skip result set metadata for prepared statement execution (PYTHON-71) - Return from Cluster.connect() when first contact point connection(pool) is opened (PYTHON-105) - cqlengine: Add ContextQuery to allow cqlengine models to switch the keyspace context easily (PYTHON-598) - Standardize Validation between Ascii and Text types in Cqlengine (PYTHON-609) Bug Fixes - Fix geventreactor with SSL support (PYTHON-600) - Don't downgrade protocol version if explicitly set (PYTHON-537) - Nonexistent contact point tries to connect indefinitely (PYTHON-549) - Execute_concurrent can exceed max recursion depth in failure mode (PYTHON-585) - Libev loop shutdown race (PYTHON-578) - Include aliases in DCT type string (PYTHON-579) - cqlengine: Comparison operators for Columns (PYTHON-595) - cqlengine: disentangle default_time_to_live table option from model query default TTL (PYTHON-538) - cqlengine: pk__token column name issue with the equality operator (PYTHON-584) - cqlengine: Fix "__in" filtering operator converts True to string "True" automatically (PYTHON-596) - cqlengine: Avoid LWTExceptions when updating columns that are part of the condition (PYTHON-580) - cqlengine: Cannot execute a query when the filter contains all columns (PYTHON-599) - cqlengine: routing key computation issue when a primary key column is overriden by model inheritance (PYTHON-576)
Revision 1.14 / (download) - annotate - [select for diffs], Wed Jul 6 15:01:27 2016 UTC (7 years, 5 months ago) by fhajny
Branch: MAIN
Changes since 1.13: +5 -5
lines
Diff to previous 1.13 (colored)
Update databases/py-cassandra-driver to 3.5.0. Features - Optional Execution Profiles for the core driver (PYTHON-569) - API to get the host metadata associated with the control connection node (PYTHON-583) - Expose CDC option in table metadata CQL (PYTHON-593) Bug Fixes - Clean up Asyncore socket map when fork is detected (PYTHON-577) - cqlengine: QuerySet only() is not respected when there are deferred fields (PYTHON-560)
Revision 1.13 / (download) - annotate - [select for diffs], Mon Jun 6 14:45:03 2016 UTC (7 years, 6 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Changes since 1.12: +5 -5
lines
Diff to previous 1.12 (colored)
Update databases/py-cassandra-driver to 3.4.1. 3.4.1 Bug Fixes - Gevent connection closes on IO timeout - "dictionary changed size during iteration" with Python 3 3.4.0 Features - Include DSE version and workload in Host data - Add a context manager to Cluster and Session - Better Error Message for Unsupported Protocol Version - Make the error message explicitly state when an error comes from the server - Short Circuit meta refresh on topo change if NEW_NODE already exists - Show warning when the wrong config is passed to SimpleStatement - Return namedtuple result pairs from execute_concurrent - BatchStatement should enforce batch size limit in a better way - Validate min/max request thresholds for connection pool scaling - Handle or warn about multiple hosts with the same rpc_address - Write docs around working with datetime and timezones Bug Fixes - High CPU utilization when using asyncore event loop - Fix CQL Export for non-ASCII Identifiers - Make stress scripts Python 2.6 compatible - UnicodeDecodeError when unicode characters in key in BOP - WhiteListRoundRobinPolicy should resolve hosts - Cluster and Session do not GC after leaving scope - Don't wait for schema agreement on ignored nodes - Reprepare on_up with many clients causes node overload - None inserted into host map when control connection node is decommissioned - weakref.ref does not accept keyword arguments
Revision 1.12 / (download) - annotate - [select for diffs], Fri May 6 09:41:36 2016 UTC (7 years, 7 months ago) by fhajny
Branch: MAIN
Changes since 1.11: +5 -5
lines
Diff to previous 1.11 (colored)
Update databases/py-cassandra-driver to 3.3.0. Features - Add an AddressTranslator interface - New Retry Policy Decision - try next host - Don't mark host down on timeout - SSL hostname verification - Add C* version to metadata or cluster objects - Options to Disable Schema, Token Metadata Processing - Expose listen_address of node we get ring information from - Use A-record with multiple IPs for contact points - Custom consistency level for populating query traces - Normalize Server Exception Types - Propagate exception message when DDL schema agreement fails - Specialized exceptions for metadata refresh methods failure Bug Fixes - Resolve contact point hostnames to avoid duplicate hosts - GeventConnection stalls requests when read is a multiple of the input buffer size - named_tuple_factory breaks with duplicate "cleaned" col names - Connection leak if Cluster.shutdown() happens during reconnection - HostConnection.borrow_connection does not block when all request ids are used - Empty field not being handled by the NumpyProtocolHandler
Revision 1.11 / (download) - annotate - [select for diffs], Thu Apr 21 09:31:21 2016 UTC (7 years, 7 months ago) by fhajny
Branch: MAIN
Changes since 1.10: +5 -5
lines
Diff to previous 1.10 (colored)
Update databases/py-cassandra-driver to 3.2.2. - Fix counter save-after-no-update (PYTHON-547)
Revision 1.10 / (download) - annotate - [select for diffs], Tue Apr 19 12:41:48 2016 UTC (7 years, 7 months ago) by fhajny
Branch: MAIN
Changes since 1.9: +5 -5
lines
Diff to previous 1.9 (colored)
Update databases/py-cassandra-driver to 3.2.1. Fix dependencies. Changes in 3.2.1: - Introduced an update to allow deserializer compilation with recently released Cython 0.24
Revision 1.9 / (download) - annotate - [select for diffs], Wed Apr 13 12:07:05 2016 UTC (7 years, 7 months ago) by fhajny
Branch: MAIN
Changes since 1.8: +5 -5
lines
Diff to previous 1.8 (colored)
Update databases/py-cassandra-driver to 3.2.0. Features - cqlengine: Warn on sync_schema type mismatch - cqlengine: Automatically defer fields with the '=' operator (and immutable values) in select queries - cqlengine: support non-equal conditions for LWT - cqlengine: sync_table should validate the primary key composition - cqlengine: token-aware routing for mapper statements Bug Fixes - Deleting a column in a lightweight transaction raises a SyntaxException - cqlengine: make Token function works with named tables/columns - comparing models with datetime fields fail #79 - cython date deserializer integer math should be aligned with CPython - db_field is not always respected with UpdateStatement - Sync_table fails on column.Set with secondary index
Revision 1.8 / (download) - annotate - [select for diffs], Fri Apr 8 16:43:39 2016 UTC (7 years, 7 months ago) by fhajny
Branch: MAIN
Changes since 1.7: +5 -5
lines
Diff to previous 1.7 (colored)
Update databases/py-cassandra-driver to 3.1.1. - cqlengine: Fix performance issue related to additional "COUNT" queries (PYTHON-522)
Revision 1.7 / (download) - annotate - [select for diffs], Sat Mar 12 09:53:53 2016 UTC (7 years, 8 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base,
pkgsrc-2016Q1
Changes since 1.6: +5 -5
lines
Diff to previous 1.6 (colored)
Update databases/py-cassandra-driver to 3.1.0. Features - Pass name of server auth class to AuthProvider - Surface schema agreed flag for DDL statements - Automatically convert float and int to Decimal on serialization - Eventlet Reactor IO improvement - Make pure Python ProtocolHandler available even when Cython is present - Optional Cython deserializer for bytes as bytearray - Add Session.default_serial_consistency_level - cqlengine: Expose prior state information via cqlengine LWTException - cqlengine: Collection datatype "contains" operators support (Cassandra 2.1) - cqlengine: Add DISTINCT query operator - cqlengine: Tuple cqlengine api - cqlengine: Add support for UPDATE/DELETE ... IF EXISTS statements - cqlengine: Allow nested container types - cqlengine: Add ability to set query's fetch_size and limit - cqlengine: Internalize default keyspace from successive set_session - cqlengine: Warn when Model.create() on Counters Bug Fixes - Bus error (alignment issues) when running cython on some ARM platforms - Overflow when decoding large collections (cython) - Timer heap comparison issue with Python 3 - Cython deserializer date overflow at 2^31 - 1 - Decode error encountered when cython deserializing large map results - Don't require Cython for build if compiler or Python header not present - Unorderable types in task scheduling with Python 3 - cqlengine: Fix crash when updating a UDT column with a None value - cqlengine: Race condition in ..connection.execute with lazy_connect - cqlengine: doesn't support case sensitive column family names - cqlengine: UserDefinedType mandatory in create or update - cqlengine: db_field breaks UserType - cqlengine: UDT badly quoted - cqlengine: Use of db_field on primary key prevents querying except while tracing. - cqlengine: DateType.deserialize being called with one argument vs two - cqlengine: Querying without setting up connection now throws AttributeError and not CQLEngineException - cqlengine: BatchQuery multiple time executing execute statements. - cqlengine: Better error for management functions when no connection set - cqlengine: Handle None values for UDT attributes in cqlengine - cqlengine: Fix inserting None for model save - cqlengine: EQ doesn't map to a QueryOperator (setup race condition) - cqlengine: class.MultipleObjectsReturned has DoesNotExist as base class - cqlengine: Typo in cqlengine UserType __len__ breaks attribute assignment Other - cqlengine: a major improvement on queryset has been introduced. It is a lot more efficient to iterate large datasets: the rows are now fetched on demand using the driver pagination. - cqlengine: the queryset len() and count() behaviors have changed. It now executes a "SELECT COUNT(*)" of the query rather than returning the size of the internal result_cache (loaded rows). On large queryset, you might want to avoid using them due to the performance cost. Note that trying to access objects using list index/slicing with negative indices also requires a count to be executed.
Revision 1.6 / (download) - annotate - [select for diffs], Wed Nov 25 15:58:09 2015 UTC (8 years ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
Update databases/py-cassandra-driver to 3.0.0. 3.0.0 Features - Support datetime.date objects as a DateType - Add Cluster.update_view_metadata - QueryTrace option to populate partial trace sessions - Attach column names to ResultSet - Change default consistency level to LOCAL_ONE Bug Fixes - Properly SerDes nested collections when protocol_version < 3 - Evict UDTs from UserType cache on change - Make sure query strings are always encoded UTF-8 - Track previous value of columns at instantiation in CQLengine - UDT CQL encoding does not work for unicode values - NetworkTopologyStrategy#make_token_replica_map does not account for multiple racks in a DC - Cython integer overflow on decimal type deserialization - Query trace: if session hasn't been logged, query trace can throw exception 3.0.0rc1 Features - Process Modernized Schema Tables for Cassandra 3.0 - Remove deprecated features - Don't assign trace data to Statements - Normalize results return - Process Materialized View Metadata/Events - Remove blist as soft dependency - Change default consistency level to LOCAL_QUORUM - Normalize CQL query/export in metadata model Bug Fixes - Implementation of named arguments bind is non-pythonic - CQL encoding is incorrect for NaN and Infinity floats - Protocol downgrade issue with C* 2.0.x, 2.1.x, and python3, with non-default logging - ValueError when accessing usertype with non-alphanumeric field names - NumpyProtocolHandler does not play well with PagedResult 2.7.2 Bug Fixes - Resolve CQL export error for UDF with zero parameters - Remove futures dep. for Python 3
Revision 1.5 / (download) - annotate - [select for diffs], Tue Nov 3 01:56:26 2015 UTC (8 years, 1 month ago) by agc
Branch: MAIN
Changes since 1.4: +2 -1
lines
Diff to previous 1.4 (colored)
Add SHA512 digests for distfiles for databases category Problems found with existing distfiles: distfiles/D6.data.ros.gz distfiles/cstore0.2.tar.gz distfiles/data4.tar.gz distfiles/sphinx-2.2.7-release.tar.gz No changes made to the cstore or mariadb55-client distinfo files. Otherwise, existing SHA1 digests verified and found to be the same on the machine holding the existing distfiles (morden). All existing SHA1 digests retained for now as an audit trail.
Revision 1.4 / (download) - annotate - [select for diffs], Tue Sep 1 11:51:00 2015 UTC (8 years, 3 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3
Changes since 1.3: +4 -4
lines
Diff to previous 1.3 (colored)
Update databases/py-cassandra-driver to 2.7.1. 2.7.1 Bug Fixes - Explicitly include extension source files in Manifest 2.7.0 Cython is introduced, providing compiled extensions for core modules, and extensions for optimized results deserialization. Features - General Performance Improvements for Throughput - Improve synchronous request performance with Timers - Enable C Extensions for PyPy Runtime - Refactor SerDes functionality for pluggable interface - Cython SerDes Extension - Accept iterators/generators for execute_concurrent() - cythonize existing modules - Pure Python murmur3 implementation - Make driver tolerant of inconsistent metadata Bug Fixes - Drop Events out-of-order Cause KeyError on Processing - DowngradingConsistencyRetryPolicy doesn't check response count on write timeouts - Blocking connect does not use connect_timeout - Properly protect partition key in CQL export - Trigger error callbacks on timeout 2.6.0 Bug Fixes - Output proper CQL for compact tables with no clustering columns 2.6.0c2 Features - Automatic Protocol Version Downgrade - cqlengine Python 2.6 compatibility - Double-dollar string quote UDF body - Set models.DEFAULT_KEYSPACE when calling set_session Bug Fixes - Avoid stall while connecting to mixed version cluster - Make SSL work with AsyncoreConnection in python 2.6.9 - Fix Murmur3Token.from_key() on Windows - Fix cqlengine TimeUUID rounding error for Windows - Avoid invalid compaction options in CQL export for non-SizeTiered 2.6.0c1 This release adds support for Cassandra 2.2 features, including version 4 of the native protocol. Features - Default load balancing policy to TokenAware(DCAware) - Configuration option for connection timeout - Support User Defined Function and Aggregate metadata in C* 2.2 - Surface request client in QueryTrace for C* 2.2+ - Implement new request failure messages in protocol v4+ - Metadata model now maps index meta by index name - Support new types in C* 2.2: date, time, smallint, tinyint - cqle: add Double column type and remove Float overload - Use partition key column information in prepared response for protocol v4+ - Support message custom payloads in protocol v4+ - Deprecate refresh_schema and replace with functions for specific entities - Save trace id even when trace complete times out - Warn when registering client UDT class for protocol < v3 - Support client warnings returned with messages in protocol v4+ - Ability to distinguish between NULL and UNSET values in protocol v4+ - Expose CQL keywords in API Bug Fixes - IPv6 address support on Windows - Convert exceptions during automatic re-preparation to nice exceptions - cqle: Quote keywords properly in table management functions - Don't default to GeventConnection when gevent is loaded, but not monkey-patched - Pass dynamic host from SaslAuthProvider to SaslAuthenticator - Make protocol read_inet work for Windows - cqle: Correct encoding for nested types - Update list of CQL keywords used quoting identifiers - Make ConstantReconnectionPolicy work with infinite retries - Accept UUIDs with uppercase hex as valid in cqlengine
Revision 1.3 / (download) - annotate - [select for diffs], Tue Jun 9 11:07:13 2015 UTC (8 years, 5 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base,
pkgsrc-2015Q2
Changes since 1.2: +4 -4
lines
Diff to previous 1.2 (colored)
Update databases/py-cassandra-driver to 2.5.1. - Fix thread safety in DC-aware load balancing policy (PYTHON-297) - Fix race condition in node/token rebuild (PYTHON-298) - Set and send serial consistency parameter (PYTHON-299)
Revision 1.2 / (download) - annotate - [select for diffs], Mon Apr 13 12:44:07 2015 UTC (8 years, 7 months ago) by fhajny
Branch: MAIN
Changes since 1.1: +4 -4
lines
Diff to previous 1.1 (colored)
Update py-cassandra-driver to 2.5.0 2.5.0 - Integrated cqlengine object mapping package - Utility functions for converting timeuuids and datetime (PYTHON-99) - Schema metadata fetch window randomized, config options added (PYTHON-202) - Support for new Date and Time Cassandra types (PYTHON-190) - Fix index target for collection indexes (full(), keys()) (PYTHON-222) - Thread exception during GIL cleanup (PYTHON-229) - Workaround for rounding anomaly in datetime.utcfromtime (Python 3.4) (PYTHON-230) - Normalize text serialization for lookup in OrderedMap (PYTHON-231) - Support reading CompositeType data (PYTHON-234) - Preserve float precision in CQL encoding (PYTHON-243) 2.1.4 - SaslAuthenticator for Kerberos support (PYTHON-109) - Heartbeat for network device keepalive and detecting failures on idle connections (PYTHON-197) - Support nested, frozen collections for Cassandra 2.1.3+ (PYTHON-186) - Schema agreement wait bypass config, new call for synchronous schema refresh (PYTHON-205) - Add eventlet connection support (PYTHON-194) - Schema meta fix for complex thrift tables (PYTHON-191) - Support for 'unknown' replica placement strategies in schema meta (PYTHON-192) - Resolve stream ID leak on set_keyspace (PYTHON-195) - Remove implicit timestamp scaling on serialization of numeric timestamps (PYTHON-204) - Resolve stream id collision when using SASL auth (PYTHON-210) - Correct unhexlify usage for user defined type meta in Python3 (PYTHON-208)
Revision 1.1 / (download) - annotate - [select for diffs], Fri Jan 16 17:12:23 2015 UTC (8 years, 10 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base,
pkgsrc-2015Q1
Import cassandra_driver as py-cassandra-driver. Python client driver for Apache Cassandra. This driver works exclusively with the Cassandra Query Language v3 (CQL3) and Cassandra's native protocol. Cassandra versions 1.2 through 2.1 are supported.