The NetBSD Project

CVS log for pkgsrc/databases/py-asyncpg/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / py-asyncpg

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.25: download - view: text, markup, annotated - select for diffs
Sun Oct 20 20:12:01 2024 UTC (6 weeks, 3 days ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +4 -4 lines
py-asyncpg: updated to 0.30.0

0.30.0

Improvements

Implement GSSAPI authentication
Implement SSPI authentication
Add initial typings
Allow building with Cython 3
docs: fix connection pool close call
Add support for the sslnegotiation parameter
Test and build on Python 3.13
Support PostgreSQL 17
Add fetchmany to execute many and return rows
Add connect kwarg to Pool to better support GCP's CloudSQL
Allow customizing connection state reset

Fixes

s/quote/quote_plus/ in the note about DSN part quoting
Use asyncio.run() instead of run_until_complete()
Require async_timeout for python < 3.11
Allow testing with uvloop on Python 3.12
Mark pool-wrapped connection coroutine methods as coroutines
handle None parameters in copy_from_query, returning NULL
fix: return the pool from async_init_ if it's already initialized
Replace obsolete, unsafe Py_TRASHCAN_SAFE_BEGIN/END

Revision 1.24: download - view: text, markup, annotated - select for diffs
Mon Nov 6 11:02:55 2023 UTC (12 months, 4 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +4 -5 lines
py-asyncpg: updated to 0.29.0

v0.29.0

Improvements

Python 3.12 and PostgreSQL 16 support
Add support for tuple-format custom codecs on composite types
Support target_session_attrs in URL format, add tests
Infinity numeric support
Add support for the WHERE clause in copy_to methods
Add query logging callbacks and context manager

Fixes

When prepared statements are disabled, avoid relying on them harder
Handle environments with HOME set to a not-a-directory
Fix handling of non-ASCII passwords
Disable JIT while doing type introspection
Remove connection parameter caching in Pool
Switch to Python 3.12-style wait_for
Update automatic PostGIS type conversion for Shapely 2.0
Use the timeout context manager in the connection path
Small fix for documentation on using SSL in Connection
Use cleanup_ctx in pool usage doc
Close cursor portals once the iterator is exhausted
Cut BaseProtocol circular reference on close.
Allow passing hosts as tuples to connect() (in addition to lists)

Revision 1.23: download - view: text, markup, annotated - select for diffs
Sat Jul 8 07:04:32 2023 UTC (16 months, 4 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +4 -4 lines
py-asyncpg: updated to 0.28.0

0.28.0
Do not try to cleanup statements
Add Pool.is_closing() method
Fix test_tls_version for LibreSSL
Handle environments without home dir
fix: salt and iterations parsing for scram
Add support for target_session_attrs
Add support for READ UNCOMMITTED
Update benchmarks, add psycopg3

Revision 1.22: download - view: text, markup, annotated - select for diffs
Tue May 9 08:27:10 2023 UTC (18 months, 4 weeks ago) by tm
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -1 lines
py-asyncpg: fix illumos / solaris build

Provide patch file to support py-asyncpg on illumos.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Tue Nov 8 11:43:59 2022 UTC (2 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +4 -4 lines
py-asyncpg: updated to 0.27.0

v0.27.0

Support Python 3.11 and PostgreSQL 15. This release also drops support
for Python 3.6.

Changes

Add arm64 mac and linux wheels
Add Python 3.11 to the test matrix
Exclude .venv from flake8
Upgrade to flake8 5.0.4 (from 3.9.2)
Show an example of a custom Record class
Use the exact type name in Record.repr
Drop Python 3.6 support
Test on Python 3.11 and PostgreSQL 15, fix workflow deprecations

Revision 1.20: download - view: text, markup, annotated - select for diffs
Fri Jul 8 07:26:09 2022 UTC (2 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +4 -4 lines
py-asyncpg: updated to 0.26.0

v0.26.0

Changes

Add support to use awaitable object in password function.
Support direct TLS connections (i.e. no STARTTLS)

Fixes

Fix invalid pyproject.toml
Add record_class parameter Pool.fetch and Pool.fetchrow
Domain basetypes are introspected
Properly handle exceptions raised while handling server auth messages

Revision 1.19: download - view: text, markup, annotated - select for diffs
Wed Nov 17 09:04:41 2021 UTC (3 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +4 -4 lines
py-asyncpg: updated to 0.25.0

v0.25.0

Changes

Improve SSL option compatibility in URIs
Add Pool methods to determine its min, max, current and idle size
Make it possible to specify a statement name in Connection.prepare()
Implement support for multirange types

Fixes

Make sure timeout callbacks always get cleaned up
Update __all__ statements to a simpler form that is better supported by typecheckers
Fix test_timetz_encoding on Python 3.10
Fix a bunch of ResourceWarnings in the test suite
Fix SSLContext deprecation warnings
Fix the description of the database argument to connect()
Fix parsing of IPv6 addresses in the connection URI
Improve diagnostics of invalid executemany() input

Revision 1.18: download - view: text, markup, annotated - select for diffs
Tue Oct 26 10:09:49 2021 UTC (3 years, 1 month ago) by nia
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
databases: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

The following distfiles could not be fetched (some may be only fetched
conditionally):

./databases/cstore/distinfo D6.data.ros.gz
./databases/cstore/distinfo cstore0.2.tar.gz
./databases/cstore/distinfo data4.tar.gz

Revision 1.17: download - view: text, markup, annotated - select for diffs
Thu Oct 7 13:35:36 2021 UTC (3 years, 1 month ago) by nia
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +1 -2 lines
databases: Remove SHA1 distfile hashes

Revision 1.16: download - view: text, markup, annotated - select for diffs
Tue Aug 10 09:19:52 2021 UTC (3 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +5 -5 lines
py-asyncpg: updated to 0.24.0

v0.24.0

Changes

Drop support for Python 3.5
Add support for Python 3.10
Add support for asynchronous iterables to copy_records_to_table()
Add support for coroutine functions as listener callbacks
Add support for sslcert, sslkey and sslrootcert parameters to DSN
Add copy_ wrappers to Pool
Add issubset and issuperset methods to the Range type

Fixes

Break connection internal circular reference
Make Server Version Extraction More Flexible

Revision 1.15: download - view: text, markup, annotated - select for diffs
Wed May 19 09:50:12 2021 UTC (3 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +5 -5 lines
py-asyncpg: updated to 0.23.0

v0.23.0

Fixes

Avoid TypeError in Transaction.__repr__
Feed memoryview to writelines()
Add sslmode=allow support and fix =prefer retry
Loosen message test in test_invalid_input
Support readonly and deferrable for non-serializable transactions
Fix asyncpg with Py_DEBUG mode
Fix docs/Makefile and docs/_static/theme_overrides.css missing from PyPI package

Revision 1.14: download - view: text, markup, annotated - select for diffs
Wed Feb 10 08:26:31 2021 UTC (3 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +5 -5 lines
py-asyncpg: updated to 0.22.0

v0.22.0

A new asyncpg release is here.

Notable additions include Python 3.9 support, support for recently added
PostgreSQL types like jsonpath, and last but not least, vastly
improved executemany() performance. Importantly, executemany() is
also now atomic, which means that either all iterations succeed, or
none at all, whereas previously partial results would have remained in
place, unless executemany() was called in a transaction.

There is also the usual assortment of improvements and bugfixes, see the
details below.

This is the last release of asyncpg that supports Python 3.5, which has
reached EOL last September.

Improvements

Vastly speedup executemany by batching protocol messages
Allow using custom Record class
Add Python 3.9 support
Prefer SSL connections by default
Add codecs for a bunch of new builtin types
Expose Pool as asyncpg.Pool
Avoid unnecessary overhead during connection reset

Revision 1.13: download - view: text, markup, annotated - select for diffs
Mon Aug 10 06:11:17 2020 UTC (4 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +5 -5 lines
py-asyncpg: updated to 0.21.0

asyncpg v0.21.0

Improvements

Add support for password functions (useful for RDS IAM auth)
Add support for connection termination listeners
Update CI matrix, aarch64 builds

Fixes

Fix possible uninitalized pointer access on unexpected array
message data (CVE-2020-17446)
Fix Connection class _copy_in private method
Bump pgproto to fix compilation issues
Improve pool documentation examples
Update usage.rst
Fix links in connection documentation
Fix usage documentation for hstore
Fix compiler warnings

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sat Feb 1 20:36:47 2020 UTC (4 years, 10 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +5 -5 lines
py-asyncpg: updated to 0.20.1

v0.20.1
Bug Fixes
* Add back ensure future for connector
* Fix errors in numeric binary decoder

Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri Nov 22 09:32:37 2019 UTC (5 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +5 -5 lines
py-asyncpg: updated to 0.20.0

asyncpg v0.20.0

Improvements
Support Python 3.8
Support PgBouncer by sending only a single SYNC message per query

Bug Fixes
Handle IP values with prefix in "inet" type as ipaddress.IPvXInterface
Close transport if connection times out
Use faster UUID codecs; make UUID decoding/encoding/operations 2-7x faster
Use loop.start_tls() to upgrade connections to SSL

Build
Bump Cython to 0.29.14

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu Oct 10 07:58:41 2019 UTC (5 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +5 -5 lines
py-asyncpg: updated to 0.19.0

asyncpg v0.19.0

Improvements
Add support for SCRAM-SHA-256 authentication.
Add PostgreSQL 12 support

Bug Fixes
Remove preexec_fn hack from test cluster management
Fix DeprecationWarning in the docstring of copy_from_query()
Allow specifying the target version when generating the release log
Check for .flake8 after importing flake8
Include .flake8 in PyPI tarball
fix timezone type label in docs
Fix _StatementCache.clear() PS memory leak
fix for warning_callback not yet defined
Fix assertion fail on copy_records_to_table
Do not look for a port in a Unix socket domain path
Unquote connection string components properly
Remove superfluous transaction from a cursor example

Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu Jan 3 10:57:07 2019 UTC (5 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +5 -5 lines
py-asyncpg: updated to 0.18.3

v0.18.3:
* Fix bswap on *BSD
* Make sure idle never-acquired pool connections are closed due to inactivity

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sun Nov 11 22:00:58 2018 UTC (6 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +5 -5 lines
py-asyncpg: updated to 0.18.2

asyncpg v0.18.2

Bug Fixes
* Revert "Stop treating ReadyForQuery as a universal result indicator"
  to fix stability regression.
* Correctly ignore all incoming messages after the Terminate message
* Properly cleanup connections closed by remote

Revision 1.7: download - view: text, markup, annotated - select for diffs
Fri Nov 2 11:51:38 2018 UTC (6 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +5 -5 lines
py-asyncpg: updated to 0.18.1

asyncpg v0.18.1:
Fix DSN parsing regression

asyncpg v0.18.0:
Improvements
Implement Record.get()
Internal asyncpg errors are now consistently raised as InternalClientError
Allow mappings as composite type input
Add BitString.to_int() and BitString.from_int()
Allow 'sslmode' in DSNs
Add support for specifying multiple host addresses when connecting
Low-level protocol implementation has been tweaked and
optimized for slightly better performance in certain scenarios
Queries with cached statements now generate fewer TCP packets
Allow aliasing builtin types by name in set_builtin_type_codec()
Factor out generic PostgreSQL protocol helpers into a separate package
Fix tests and enable CI for PostgreSQL 11

Bug Fixes
Handle and ignore permission errors when attempting to read .pgpass
Fix decoding of fractional timestamps before Postgres epoch

Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Jul 11 09:00:17 2018 UTC (6 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +5 -5 lines
py-asyncpg: updated to 0.17.0

asyncpg v0.17.0:

Improvements
Official support for Python 3.7.

Bug Fixes
Fix garbage collection of connections and emit a ResourceWarning
if an unclosed connection is garbage collected.

Raise a clear error if there's a race in pool intialization.

Channel names in Connection.add_listener() and
Connection.remove_listener() are now quoted properly.

Fixed endianness detection on *BSD systems.

Fixed handling of large type OIDs.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Jun 12 10:30:39 2018 UTC (6 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +5 -5 lines
py-asyncpg: updated to 0.16.0

asyncpg v0.16.0:

Behavior Changes
----------------
Pool.close() now waits until all acquired connections are released.
Hence, the below code will now hang indefinitely:
    conn = await pool.acquire()
    await pool.close()
Asyncpg will log a warning if pool.close() takes over 60 seconds to
complete. It is advisable to use asyncio.wait_for() to set a timeout.

Improvements
------------
Add support for reading passwords from .pgpass
Add Connection.is_in_transaction()
Added codec for built-in type tid
Allow setting custom codecs on domains and enumerated types
Allow passing datetime.date instances as timestamp input
Implement support for pool connection rotation

Bug Fixes
---------
Prohibit non-iterable containers to be passed as array input
Decode numeric zeros with correct scale
Fix handling of OIDs >= 2**31
Make Pool.close() wait until all checked out connections are released
Fix type codec cache races
Raise a consistent exception on input encoding errors

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Feb 22 09:24:16 2018 UTC (6 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +5 -5 lines
py-asyncpg: updated to 0.15.0

asyncpg v0.15.0

Behavior Changes
asyncpg no longer uses the common statement cache for explicit
prepared statements, so Connection.prepare() always returns a
new prepared statement

Bug Fixes
Initialize statement codecs immediately after Prepare
Fix server version parsing when it contains trailing data

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Dec 30 10:31:29 2017 UTC (6 years, 11 months ago) by adam
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -5 lines
py-asyncpg: updated to 0.14.0

v0.14.0:
Backwards Incompatible Changes:
asyncpg now reports the server version as x.0.y for PostgreSQL 10.0 and later.
This is in alignment with how upstream is interpreting the "minor" version
component now.

Improvements:
Support timeouts in Connection.close() and Pool.release()
Invalidate type cache on schema changes affecting statement result.
A new Connection.reload_schema_state() method.
Add CrateDB detection

Bug Fixes:
Make prepared statement uid generator global
Document pgbouncer-related prepared statement breakage
Fix unaligned access issues in host-network byte I/O on ARM
Fix issues with timetz type I/O
Consistently use postgres/postgres as database/user pair in tests
Fix Range.__hash__()
Guard transaction methods against underlying connection release

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sun Oct 22 07:32:05 2017 UTC (7 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +5 -5 lines
py-asyncpg: update to 0.13.0

v0.13.0
Backwards Incompatible Changes
------------------------------
Drop support for PostgreSQL 9.1
Remove the deprecated "binary" parameter from Connection.set_type_codec()

New Features
------------
Add support for PostgreSQL 10

Bug Fixes
---------
Document that single fetches can return None
Fix type introspection being very slow on large databases
Fix copy tests on PostgreSQL < 9.4
Fix DeprecationWarning in tests
Fix intermittent authentication failures against PostgreSQL 10 servers
Do not attempt to connect to Unix sockets on Windows when host is not set
Guard against incorrect use of resources associated with a connection
Warn when there are active listeners on a connection that is released
Add a test for cursors on a standby replica.
Clarify the argument/parameter count mismatch exception
Fix TypeError on get_attributes when result has no columns
protocol: Use try-finally explicitly every time we create a waiter
Call correct parent constructor in InterfaceWarning.__init__
Allow grabbing the version information programmatically.
Use the general statement cache for type introspection
Fix issues with inet type I/O
Handle inactive connection closes while stored in the pool

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Jul 31 12:12:59 2017 UTC (7 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
asyncpg is a database interface library designed specifically for PostgreSQL
and Python/asyncio. asyncpg is an efficient, clean implementation of
PostgreSQL server binary protocol for use with Python's asyncio framework.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>