[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql95

Annotation of pkgsrc/databases/postgresql95/Makefile.common, Revision 1.11

1.11    ! wiz         1: # $NetBSD: Makefile.common,v 1.10 2017/08/13 19:25:17 adam Exp $
1.1       tnn         2: #
                      3: # This Makefile fragment is included by all PostgreSQL packages built from
                      4: # the main sources of the PostgreSQL distribution except jdbc-postgresql.
                      5: #
                      6: # The PostgreSQL package naming scheme, aside from the obvious piecewise
                      7: # packages, is as follows:
                      8: #      <lang>-postgresql       client-side interface to PostgreSQL
                      9: #      postgresql-<lang>       server-side module for PostgreSQL backend
                     10: #
                     11: # used by databases/postgresql95-client/Makefile
1.4       fhajny     12: # used by databases/postgresql95-contrib/Makefile
1.1       tnn        13: # used by databases/postgresql95-docs/Makefile
                     14: # used by databases/postgresql95-plperl/Makefile
                     15: # used by databases/postgresql95-plpython/Makefile
                     16: # used by databases/postgresql95-pltcl/Makefile
                     17: # used by databases/postgresql95-server/Makefile
                     18:
1.10      adam       19: DISTNAME=      postgresql-9.5.8
1.1       tnn        20: CATEGORIES=    databases
                     21: MASTER_SITES=  ${MASTER_SITE_PGSQL:=source/v${PKGVERSION_NOREV}/}
                     22: EXTRACT_SUFX=  .tar.bz2
                     23:
                     24: MAINTAINER?=   adam@NetBSD.org
1.11    ! wiz        25: HOMEPAGE=      https://www.postgresql.org/
1.1       tnn        26: LICENSE=       postgresql-license
                     27:
                     28: CONFLICTS+=    postgresql-[0-9]*
                     29: CONFLICTS+=    postgresql[0-8][0-9]-[0-9]*
                     30: CONFLICTS+=    postgresql9[012346-9]-[0-9]*
                     31:
                     32: .if !empty(PKGNAME:M*-*-*)
                     33: module=                ${PKGNAME:C/-[0-9].*$//:C/^.*-//}
                     34: CONFLICTS+=    postgresql[0-8][0-9]-${module}-[0-9]*
                     35: CONFLICTS+=    postgresql9[012346-9]-${module}-[0-9]*
                     36: .endif
                     37:
                     38: DISTINFO_FILE?=                ${.CURDIR}/../../databases/postgresql95/distinfo
                     39: COMMON_FILESDIR?=      ${.CURDIR}/../../databases/postgresql95/files
                     40: PATCHDIR?=             ${.CURDIR}/../../databases/postgresql95/patches
                     41:
                     42: USE_PKGLOCALEDIR=      yes
                     43: USE_TOOLS+=            bison gmake lex msgfmt
                     44: PKG_SYSCONFSUBDIR=     postgresql
                     45:
                     46: .include "../../mk/bsd.prefs.mk"
                     47:
                     48: PG_TEMPLATE.SunOS=     solaris
                     49: PG_TEMPLATE.IRIX=      irix5
                     50: PG_TEMPLATE.MirBSD=    openbsd
                     51: .if !defined(PG_TEMPLATE.${OPSYS})
                     52: PG_TEMPLATE.${OPSYS}=  ${LOWER_OPSYS}
                     53: .endif
                     54:
                     55: PG_DATA_DIR=           ${PREFIX}/share/postgresql
                     56: PG_DOC_DIR=            ${PREFIX}/share/doc/postgresql
                     57: PG_LOCALE_DIR=         ${PREFIX}/${PKGLOCALEDIR}/locale
                     58: PG_ETC_DIR=            ${PKG_SYSCONFDIR}
                     59:
                     60: GNU_CONFIGURE=         yes
                     61: CONFIGURE_ARGS+=       --sysconfdir=${PG_ETC_DIR}
                     62: CONFIGURE_ARGS+=       --datadir=${PG_DATA_DIR}
                     63: CONFIGURE_ARGS+=       --docdir=${PG_DOC_DIR}
                     64: CONFIGURE_ARGS+=       --localedir=${PG_LOCALE_DIR}
                     65: CONFIGURE_ARGS+=       --with-template=${PG_TEMPLATE.${OPSYS}}
                     66:
                     67: CONFIGURE_ARGS+=       --enable-nls
                     68: CONFIGURE_ARGS+=       --with-readline
                     69: CONFIGURE_ARGS+=       --without-perl
                     70: CONFIGURE_ARGS+=       --without-python
                     71: CONFIGURE_ARGS+=       --without-tcl
                     72: CONFIGURE_ARGS+=       --without-zlib
                     73:
                     74: # sys/ucred.h shouldn't be included on Solaris, causes conflicts between
                     75: # procfs and largefile.
                     76: .if ${OPSYS} == "SunOS"
                     77: CONFIGURE_ENV+=                ac_cv_header_sys_ucred_h=no
                     78: .endif
                     79:
                     80: # configure fails on OpenBSD and MirBSD if thread safety is enabled.
                     81: .if ${OPSYS} == "OpenBSD" || ${OPSYS} == "MirBSD"
                     82: CONFIGURE_ARGS+=       --disable-thread-safety
                     83: .endif
                     84:
                     85: # PGSQL_BLCKSZ is the size in bytes of a PostgreSQL disk page or block.
                     86: # This also limits the size of a tuple.  The valid values are powers
                     87: # of 2 up to 32768, and the default size is 8196.  Please don't change
                     88: # this value unless you know what you are doing.
                     89: BUILD_DEFS+=   PGSQL_BLCKSZ
                     90: .if defined(PGSQL_BLCKSZ)
                     91: CONFIGURE_ARGS+=       --with-blocksize=${PGSQL_BLCKSZ}
                     92: .endif
                     93:
                     94: # PostgreSQL explicitly forbids any use of -ffast-math
                     95: BUILDLINK_TRANSFORM+=  rm:-ffast-math
                     96:
                     97: # USE_LIBLTDL is "yes" or "no" depending on whether we're using libltdl
                     98: # to provide "dlopen" functionality for the PostgreSQL backend.
                     99: .if ${OPSYS} == "Interix"
                    100: USE_LIBLTDL?=          yes
                    101: .endif
                    102: USE_LIBLTDL?=          no
                    103:
                    104: .include "../../devel/gettext-lib/buildlink3.mk"
                    105: LIBS.SunOS+=           -lintl
                    106: # XXX work around core dumps with the native libedit
                    107: USE_GNU_READLINE=      yes
                    108: .include "../../devel/readline/buildlink3.mk"
                    109:
                    110: .if !defined(META_PACKAGE)
                    111: post-extract:
                    112: .  if !empty(USE_LIBLTDL:M[yY][eE][sS])
                    113:        cp -f ${COMMON_FILESDIR}/dynloader-ltdl.h \
                    114:                ${WRKSRC}/src/backend/port/dynloader/${PG_TEMPLATE.${OPSYS}:Q}.h
                    115:        ${ECHO} "static int dummy = 0;" \
                    116:                > ${WRKSRC}/src/backend/port/dynloader/${PG_TEMPLATE.${OPSYS}:Q}.c
                    117: .  endif
                    118:        touch ${WRKSRC}/src/template/dragonfly
                    119:        cp ${WRKSRC}/src/backend/port/dynloader/freebsd.c \
                    120:                ${WRKSRC}/src/backend/port/dynloader/dragonfly.c
                    121:        cp ${WRKSRC}/src/backend/port/dynloader/freebsd.h \
                    122:                ${WRKSRC}/src/backend/port/dynloader/dragonfly.h
                    123:        cp ${WRKSRC}/src/include/port/freebsd.h \
                    124:                ${WRKSRC}/src/include/port/dragonfly.h
                    125:        cp ${WRKSRC}/src/makefiles/Makefile.freebsd \
                    126:                ${WRKSRC}/src/makefiles/Makefile.dragonfly
                    127: .endif
                    128:
                    129: .include "../../databases/postgresql95/options.mk"

CVSweb <webmaster@jp.NetBSD.org>