[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql93

Annotation of pkgsrc/databases/postgresql93/Makefile.common, Revision 1.31

1.30      adam        1: # $NetBSD: Makefile.common,v 1.29 2017/11/13 09:33:31 adam Exp $
1.9       wiz         2: #
                      3: # This Makefile fragment is included by all PostgreSQL packages built from
                      4: # the main sources of the PostgreSQL distribution except jdbc-postgresql.
                      5: #
                      6: # The PostgreSQL package naming scheme, aside from the obvious piecewise
                      7: # packages, is as follows:
                      8: #      <lang>-postgresql       client-side interface to PostgreSQL
                      9: #      postgresql-<lang>       server-side module for PostgreSQL backend
1.1       adam       10: #
                     11: # used by databases/postgresql93-client/Makefile
1.19      fhajny     12: # used by databases/postgresql93-contrib/Makefile
1.1       adam       13: # used by databases/postgresql93-docs/Makefile
                     14: # used by databases/postgresql93-plperl/Makefile
                     15: # used by databases/postgresql93-plpython/Makefile
                     16: # used by databases/postgresql93-pltcl/Makefile
                     17: # used by databases/postgresql93-server/Makefile
                     18:
1.29      adam       19: DISTNAME=      postgresql-9.3.20
1.1       adam       20: CATEGORIES=    databases
                     21: MASTER_SITES=  ${MASTER_SITE_PGSQL:=source/v${PKGVERSION_NOREV}/}
                     22: EXTRACT_SUFX=  .tar.bz2
                     23:
                     24: MAINTAINER?=   adam@NetBSD.org
1.26      wiz        25: HOMEPAGE=      https://www.postgresql.org/
1.1       adam       26: LICENSE=       postgresql-license
                     27:
                     28: CONFLICTS+=    postgresql-[0-9]*
                     29: CONFLICTS+=    postgresql[0-8][0-9]-[0-9]*
                     30: CONFLICTS+=    postgresql9[0124-9]-[0-9]*
                     31:
                     32: .if !empty(PKGNAME:M*-*-*)
                     33: module=                ${PKGNAME:C/-[0-9].*$//:C/^.*-//}
                     34: CONFLICTS+=    postgresql[0-8][0-9]-${module}-[0-9]*
1.8       wiz        35: CONFLICTS+=    postgresql9[0124-9]-${module}-[0-9]*
1.1       adam       36: .endif
                     37:
                     38: DISTINFO_FILE?=                ${.CURDIR}/../../databases/postgresql93/distinfo
                     39: COMMON_FILESDIR?=      ${.CURDIR}/../../databases/postgresql93/files
                     40: PATCHDIR?=             ${.CURDIR}/../../databases/postgresql93/patches
                     41:
                     42: USE_PKGLOCALEDIR=      yes
                     43: USE_TOOLS+=            bison gmake lex msgfmt
                     44: PKG_SYSCONFSUBDIR=     postgresql
                     45:
                     46: .include "../../mk/bsd.prefs.mk"
                     47:
                     48: PG_TEMPLATE.SunOS=     solaris
                     49: PG_TEMPLATE.IRIX=      irix5
1.3       bsiegert   50: PG_TEMPLATE.MirBSD=    openbsd
1.1       adam       51: .if !defined(PG_TEMPLATE.${OPSYS})
                     52: PG_TEMPLATE.${OPSYS}=  ${LOWER_OPSYS}
                     53: .endif
                     54:
                     55: PG_DATA_DIR=           ${PREFIX}/share/postgresql
                     56: PG_DOC_DIR=            ${PREFIX}/share/doc/postgresql
                     57: PG_LOCALE_DIR=         ${PREFIX}/${PKGLOCALEDIR}/locale
                     58: PG_ETC_DIR=            ${PKG_SYSCONFDIR}
                     59:
                     60: GNU_CONFIGURE=         yes
                     61: CONFIGURE_ARGS+=       --sysconfdir=${PG_ETC_DIR}
                     62: CONFIGURE_ARGS+=       --datadir=${PG_DATA_DIR}
                     63: CONFIGURE_ARGS+=       --docdir=${PG_DOC_DIR}
                     64: CONFIGURE_ARGS+=       --localedir=${PG_LOCALE_DIR}
                     65: CONFIGURE_ARGS+=       --with-template=${PG_TEMPLATE.${OPSYS}}
                     66:
                     67: CONFIGURE_ARGS+=       --enable-nls
1.29      adam       68: CONFIGURE_ARGS+=       --with-libxml
                     69: CONFIGURE_ARGS+=       --with-readline
1.1       adam       70: CONFIGURE_ARGS+=       --without-perl
                     71: CONFIGURE_ARGS+=       --without-python
                     72: CONFIGURE_ARGS+=       --without-tcl
                     73:
                     74: # sys/ucred.h shouldn't be included on Solaris, causes conflicts between
                     75: # procfs and largefile.
1.16      jperkin    76: CONFIGURE_ENV.SunOS+=  ac_cv_header_sys_ucred_h=no
1.1       adam       77:
1.28      fhajny     78: # pkgsrc silently filters the --as-needed linker arg, but that makes
                     79: # it leak into the pgxs Makefiles and compromises manual building
                     80: # against PostgreSQL files installed. Disable it here to prevent
                     81: # that from happening.
                     82: .if ${OPSYS} == "SunOS" || ${OPSYS} == "Darwin"
                     83: CONFIGURE_ENV+=                pgac_cv_prog_cc_ldflags__Wl___as_needed=no
                     84: .endif
                     85:
1.3       bsiegert   86: # configure fails on OpenBSD and MirBSD if thread safety is enabled.
1.29      adam       87: CONFIGURE_ARGS.MirBSD+=        --disable-thread-safety
                     88: CONFIGURE_ARGS.OpenBSD+=--disable-thread-safety
1.3       bsiegert   89:
1.1       adam       90: # PGSQL_BLCKSZ is the size in bytes of a PostgreSQL disk page or block.
                     91: # This also limits the size of a tuple.  The valid values are powers
                     92: # of 2 up to 32768, and the default size is 8196.  Please don't change
                     93: # this value unless you know what you are doing.
                     94: BUILD_DEFS+=   PGSQL_BLCKSZ
                     95: .if defined(PGSQL_BLCKSZ)
                     96: CONFIGURE_ARGS+=       --with-blocksize=${PGSQL_BLCKSZ}
                     97: .endif
                     98:
                     99: # PostgreSQL explicitly forbids any use of -ffast-math
                    100: BUILDLINK_TRANSFORM+=  rm:-ffast-math
                    101:
                    102: # USE_LIBLTDL is "yes" or "no" depending on whether we're using libltdl
                    103: # to provide "dlopen" functionality for the PostgreSQL backend.
                    104: .if ${OPSYS} == "Interix"
                    105: USE_LIBLTDL?=          yes
                    106: .endif
                    107: USE_LIBLTDL?=          no
                    108:
                    109: .include "../../devel/gettext-lib/buildlink3.mk"
                    110: LIBS.SunOS+=           -lintl
1.29      adam      111: .include "../../devel/zlib/buildlink3.mk"
                    112: .include "../../textproc/libxml2/buildlink3.mk"
                    113:
                    114: .include "../../mk/readline.buildlink3.mk"
                    115: .if ${READLINE_TYPE} == "editline"
                    116: CONFIGURE_ARGS+=       --with-libedit-preferred
                    117: .endif
1.1       adam      118:
                    119: .if !defined(META_PACKAGE)
                    120: post-extract:
                    121: .  if !empty(USE_LIBLTDL:M[yY][eE][sS])
                    122:        cp -f ${COMMON_FILESDIR}/dynloader-ltdl.h \
                    123:                ${WRKSRC}/src/backend/port/dynloader/${PG_TEMPLATE.${OPSYS}:Q}.h
                    124:        ${ECHO} "static int dummy = 0;" \
                    125:                > ${WRKSRC}/src/backend/port/dynloader/${PG_TEMPLATE.${OPSYS}:Q}.c
                    126: .  endif
                    127:        touch ${WRKSRC}/src/template/dragonfly
                    128:        cp ${WRKSRC}/src/backend/port/dynloader/freebsd.c \
                    129:                ${WRKSRC}/src/backend/port/dynloader/dragonfly.c
                    130:        cp ${WRKSRC}/src/backend/port/dynloader/freebsd.h \
                    131:                ${WRKSRC}/src/backend/port/dynloader/dragonfly.h
                    132:        cp ${WRKSRC}/src/include/port/freebsd.h \
                    133:                ${WRKSRC}/src/include/port/dragonfly.h
                    134:        cp ${WRKSRC}/src/makefiles/Makefile.freebsd \
                    135:                ${WRKSRC}/src/makefiles/Makefile.dragonfly
                    136: .endif
                    137:
                    138: .include "../../databases/postgresql93/options.mk"

CVSweb <webmaster@jp.NetBSD.org>