The NetBSD Project

CVS log for pkgsrc/databases/postgresql91/Attic/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql91

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.32, Wed May 24 19:51:12 2017 UTC (6 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.31: +1 -1 lines
FILE REMOVED

Removed databases/postgresql91

Revision 1.31 / (download) - annotate - [select for diffs], Sat Oct 29 19:41:53 2016 UTC (7 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.30: +5 -5 lines
Diff to previous 1.30 (colored)

The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 9.6.1, 9.5.5, 9.4.10, 9.3.15, 9.2.19, and 9.1.24. This is also the last update for the PostgreSQL 9.1 series as it is now end-of-life. This release fixes two issues that can cause data corruption, which are described in more detail below. It also patches a number of other bugs reported over the last three months. The project urges users to apply this update at the next possible downtime.

Revision 1.30 / (download) - annotate - [select for diffs], Tue Aug 23 06:28:15 2016 UTC (7 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.29: +5 -9 lines
Diff to previous 1.29 (colored)

The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 9.5.4, 9.4.9, 9.3.14, 9.2.18 and 9.1.23. This release fixes two security issues. It also patches a number of other bugs reported over the last three months. Users who rely on security isolation between database users should update as soon as possible. Other users should plan to update at the next convenient downtime.

Security Issues
---------------
Two security holes have been closed by this release:

CVE-2016-5423: certain nested CASE expressions can cause the server to crash.
CVE-2016-5424: database and role names with embedded special characters can allow code injection during administrative operations like pg_dumpall.
The fix for the second issue also adds an option, -reuse-previous, to psql's \connect command. pg_dumpall will also refuse to handle database and role names containing line breaks after the update. For more information on these issues and how they affect backwards-compatibility, see the Release Notes.

Bug Fixes and Improvements
--------------------------
This update also fixes a number of bugs reported in the last few months. Some of these issues affect only version 9.5, but many affect all supported versions:

Fix misbehaviors of IS NULL/IS NOT NULL with composite values
Fix three areas where INSERT ... ON CONFLICT failed to work properly with other SQL features.
Make INET and CIDR data types properly reject bad IPv6 values
Prevent crash in "point ## lseg" operator for NaN input
Avoid possible crash in pg_get_expr()
Fix several one-byte buffer over-reads in to_number()
Don't needlessly plan query if WITH NO DATA is specified
Avoid crash-unsafe state in expensive heap_update() paths
Fix hint bit update during WAL replay of row locking operations
Avoid unnecessary "could not serialize access" with FOR KEY SHARE
Avoid crash in postgres -C when the specified variable is a null string
Fix two issues with logical decoding and subtransactions
Ensure that backends see up-to-date statistics for shared catalogs
Prevent possible failure when vacuuming multixact IDs in an upgraded database
When a manual ANALYZE specifies columns, don't reset changes_since_analyze
Fix ANALYZE's overestimation of n_distinct for columns with nulls
Fix bug in b-tree mark/restore processing
Fix building of large (bigger than shared_buffers) hash indexes
Prevent infinite loop in GiST index build with NaN values
Fix possible crash during a nearest-neighbor indexscan
Fix "PANIC: failed to add BRIN tuple" error
Prevent possible crash during background worker shutdown
Many fixes for issues in parallel pg_dump and pg_restore
Make pg_basebackup accept -Z 0 as no compression
Make regression tests safe for Danish and Welsh locales

Revision 1.29 / (download) - annotate - [select for diffs], Mon May 23 14:27:34 2016 UTC (7 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.28: +6 -6 lines
Diff to previous 1.28 (colored)

This release fixes a number of issues reported by users over the last two months. Most database administrators should plan to upgrade at the next available downtime, unless they have been affected directly by the fixed issues.

Revision 1.28 / (download) - annotate - [select for diffs], Sat Apr 9 12:51:44 2016 UTC (7 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.27: +5 -5 lines
Diff to previous 1.27 (colored)

The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 9.5.2, 9.4.7, 9.3.12, 9.2.16, and 9.1.21. This release fixes two security issues and one index corruption issue in version 9.5. It also contains a variety of bug fixes for earlier versions. Users of PostgreSQL 9.5.0 or 9.5.1 should update as soon as possible.

This release closes security hole CVE-2016-2193, where a query plan might get reused for more than one ROLE in the same session. This could cause the wrong set of Row Level Security (RLS) policies to be used for the query.

The update also fixes CVE-2016-3065, a server crash bug triggered by using pageinspect with BRIN index pages. Since an attacker might be able to expose a few bytes of server memory, this crash is being treated as a security issue.

Revision 1.26.2.1 / (download) - annotate - [select for diffs], Sat Feb 27 16:33:30 2016 UTC (7 years, 9 months ago) by bsiegert
Branch: pkgsrc-2015Q4
Changes since 1.26: +5 -5 lines
Diff to previous 1.26 (colored) next main 1.27 (colored)

Pullup ticket #4932 - requested by tnn
databases/postgresql91: security fix

Revisions pulled up:
- databases/postgresql91-client/PLIST                           1.5
- databases/postgresql91-docs/PLIST                             1.22
- databases/postgresql91/Makefile                               1.11
- databases/postgresql91/Makefile.common                        1.28
- databases/postgresql91/distinfo                               1.27

---
   Module Name:	pkgsrc
   Committed By:	tnn
   Date:		Thu Feb 25 01:06:31 UTC 2016

   Modified Files:
   	pkgsrc/databases/postgresql91: Makefile.common distinfo
   	pkgsrc/databases/postgresql91-client: PLIST
   	pkgsrc/databases/postgresql91-docs: PLIST

   Log Message:
   Update to PostgreSQL 9.1.20 (2016-02-11)

   This release fixes two security issues, as well as several bugs found
   over the last four months.

   CVE-2016-0773 Unicode regular expression buffer overflow
   CVE-2016-0766 PL/Java privilege escalation

---
   Module Name:	pkgsrc
   Committed By:	tnn
   Date:		Thu Feb 25 01:45:06 UTC 2016

   Modified Files:
   	pkgsrc/databases/postgresql91: Makefile

   Log Message:
   drop PKGREVISION after update

Revision 1.27 / (download) - annotate - [select for diffs], Thu Feb 25 01:06:31 2016 UTC (7 years, 9 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.26: +5 -5 lines
Diff to previous 1.26 (colored)

Update to PostgreSQL 9.1.20 (2016-02-11)

This release fixes two security issues, as well as several bugs found
over the last four months.

CVE-2016-0773 Unicode regular expression buffer overflow
CVE-2016-0766 PL/Java privilege escalation

Revision 1.26 / (download) - annotate - [select for diffs], Tue Nov 3 01:56:26 2015 UTC (8 years, 1 month ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base
Branch point for: pkgsrc-2015Q4
Changes since 1.25: +2 -1 lines
Diff to previous 1.25 (colored)

Add SHA512 digests for distfiles for databases category

Problems found with existing distfiles:
	distfiles/D6.data.ros.gz
	distfiles/cstore0.2.tar.gz
	distfiles/data4.tar.gz
	distfiles/sphinx-2.2.7-release.tar.gz
No changes made to the cstore or mariadb55-client distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.25 / (download) - annotate - [select for diffs], Sun Oct 11 11:24:58 2015 UTC (8 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.24: +4 -4 lines
Diff to previous 1.24 (colored)

Changes 9.1.19:
Two security issues have been fixed in this release which affect users of specific PostgreSQL features:

CVE-2015-5289: json or jsonb input values constructed from arbitrary user input can crash the PostgreSQL server and cause a denial of service.

CVE-2015-5288: The crypt() function included with the optional pgCrypto extension could be exploited to read a few additional bytes of memory. No working exploit for this issue has been developed.

Revision 1.24 / (download) - annotate - [select for diffs], Thu Jun 18 14:46:14 2015 UTC (8 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.23: +4 -4 lines
Diff to previous 1.23 (colored)

Changes:
This release primarily fixes issues not successfully fixed in prior releases. It should be applied as soon as possible all users of major versions 9.3 and 9.4. Other users should apply at the next available downtime.

Crash Recovery Fixes:
Earlier update releases attempted to fix an issue in PostgreSQL 9.3 and 9.4 with "multixact wraparound", but failed to account for issues doing multixact cleanup during crash recovery. This could cause servers to be unable to restart after a crash. As such, all users of 9.3 and 9.4 should apply this update as soon as possible.

Revision 1.23 / (download) - annotate - [select for diffs], Mon Jun 8 12:52:07 2015 UTC (8 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.22: +4 -4 lines
Diff to previous 1.22 (colored)

Changes:
* File Permissions Fix
* Have pg_get_functiondef() show the LEAKPROOF property
* Make pushJsonbValue() function push jbvBinary type
* Allow building with threaded Python on OpenBSD

Revision 1.22 / (download) - annotate - [select for diffs], Wed May 27 13:27:27 2015 UTC (8 years, 6 months ago) by adam
Branch: MAIN
Changes since 1.21: +4 -4 lines
Diff to previous 1.21 (colored)

The PostgreSQL Global Development Group has released an update with multiple functionality and security fixes to all supported versions of the PostgreSQL database system, which includes minor versions 9.4.2, 9.3.7, 9.2.11, 9.1.16, and 9.0.20. The update contains a critical fix for a potential data corruption issue in PostgreSQL 9.3 and 9.4; users of those versions should update their servers at the next possible opportunity.

Revision 1.21 / (download) - annotate - [select for diffs], Sat Feb 14 12:06:49 2015 UTC (8 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.20: +4 -4 lines
Diff to previous 1.20 (colored)

Changes 9.1.15:
Security Fixes
* CVE-2015-0241 Buffer overruns in "to_char" functions.
* CVE-2015-0242 Buffer overrun in replacement printf family of functions.
* CVE-2015-0243 Memory errors in functions in the pgcrypto extension.
* CVE-2015-0244 An error in extended protocol message reading.
* CVE-2014-8161 Constraint violation errors can cause display of values in columns which the user would not normally have rights to see.

JSON and JSONB Unicode Escapes

Other Fixes and Improvements
* Cope with the non-ASCII Norwegian Windows locale name.
* Avoid data corruption when databases are moved to new tablespaces and back again.
* Ensure that UNLOGGED tables are correctly copied during ALTER DATABASE operations.
* Avoid deadlocks when locking recently modified rows.
* Fix two SELECT FOR UPDATE query issues.
* Prevent false negative for shortest-first regular expression matches.
* Fix false positives and negatives in tsquery contains operator.
* Fix namespace handling in xpath().
* Prevent row-producing functions from creating empty column names.
* Make autovacuum use per-table cost_limit and cost_delay settings.
* When autovacuum=off, limit autovacuum work to wraparound prevention only.
* Multiple fixes for logical decoding in 9.4.
* Fix transient errors on hot standby queries due to page replacement.
* Prevent duplicate WAL file archiving at end of recovery or standby promotion.
* Prevent deadlock in parallel restore of schema-only dump.

Revision 1.20 / (download) - annotate - [select for diffs], Fri Jan 23 15:06:01 2015 UTC (8 years, 10 months ago) by joerg
Branch: MAIN
Changes since 1.19: +3 -1 lines
Diff to previous 1.19 (colored)

Apply strtoi fix for NetBSD/current to all PostgreSQL versions.

Revision 1.19 / (download) - annotate - [select for diffs], Fri Jul 25 22:14:56 2014 UTC (9 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.18: +4 -5 lines
Diff to previous 1.18 (colored)

The PostgreSQL Global Development Group has released an update to all supported version of the database system, including versions 9.3.5, 9.2.9, 9.1.14, 9.0.18, and 8.4.22. This minor release fixes a number of issues discovered and reported by users over the last four months, including some data corruption issues, and is the last update of version 8.4. Users of version 9.3 will want to update at the earliest opportunity; users of version 8.4 will want to schedule an upgrade to a supported PostgreSQL version.

Revision 1.18 / (download) - annotate - [select for diffs], Thu Mar 27 20:57:54 2014 UTC (9 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.17: +4 -4 lines
Diff to previous 1.17 (colored)

This minor release fixes a data corruption issue with replication and crash recovery in version 9.3, as well as several other minor issues in all versions. All users of version 9.3 are urged to update their installations at the next possible downtime. Users of older versions should update at their convenience.

The data corruption issue in PostgreSQL 9.3 affects binary replication standbys, servers being recovered from point-in-time-recovery backup, and standalone servers which recover from a system crash. The bug causes unrecoverable index corruption during recovery due to incorrect replay of row locking operations. This can then cause query results to be inconsistent depending on whether or not an index is used, and eventually lead to primary key violations and similar issues. For this reason, users are encouraged to replace each of their standby databases with a new base backup after applying the update.

Other PostgreSQL 9.3-only fixes in this update include:

Make sure that statistics files for dropped databases get deleted
Allow materialized views to be referenced in UPDATE and DELETE queries
Add read-only data_checksum parameter
Prevent erroneous operator push-down in postgres_fdw

This release resolves some other issues in all versions of PostgreSQL, including:
Fix timing consistency issue with NOTIFY
Allow regular expression execution to be cancelled
Improve performance of index checks for newly added rows
Prevent premature walsender disconnection
Prevent memory errors on newer Windows versions
Update timezone files

Revision 1.17 / (download) - annotate - [select for diffs], Sun Feb 23 11:25:52 2014 UTC (9 years, 9 months ago) by adam
Branch: MAIN
Changes since 1.16: +4 -4 lines
Diff to previous 1.16 (colored)

Changes:
This update fixes CVE-2014-0060, in which PostgreSQL did not properly enforce the WITH ADMIN OPTION permission for ROLE management.
This update also fixes some issues which affect binary replication and row locking, and can cause recoverable data corruption in some cases.
In addition to the above, the following issues are fixed in this release:

Fix WAL logging of visibility map change
Make sure that GIN indexes log all insertions
Get pause_at_recovery_target to pause at correct time
Ensure walreceiver sends hot-standby feedback messages on time
Prevent timeout interrupts from taking control away from mainline code
Eliminate several race conditions
Fix some broken HINTs in error messages
Prevent server lockup on SSL connection loss
Fix two Unicode handling issues
Prevent crash on certain subselect syntax
Prevent crash on select from zero column table
Fix two bugs with LATERAL
Fix issue with UNION ALL, partitioning, and updates
Ensure that ANALYZE understands domains over ranges
Eliminate permissions check when using default tablespace
Fix memory leakage in JSON functions
Allow extensions with event triggers
Distinguish numbers correctly in JSON output
Fix permissions for pg_start_backup() and pg_stop_backup()
Accept SHIFT_JIS as locale name
Fix .* expansion for SQL function variables
Prevent infinite loop on some COPY connection failures
Several fixes for client issues on Windows
Enable building PostgreSQL with Visual Studio 2013
Update time zone files for recent changes

Revision 1.16 / (download) - annotate - [select for diffs], Tue Dec 10 22:32:56 2013 UTC (9 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.15: +5 -4 lines
Diff to previous 1.15 (colored)

The PostgreSQL Global Development Group has released a critical update to all supported versions of the PostgreSQL database system, which includes minor versions 9.3.2, 9.2.6, 9.1.11, 9.0.15, and 8.4.19. This update fixes three serious data-loss bugs affecting replication and database maintenance. All users are urged to update their installations at the earliest opportunity.

The replication issue affects some users of PostgreSQL binary replication, and can cause minor data loss between the master and the standby. While not all users are affected, it is difficult to predict when the bug will occur, so we urge all users of replication and continuous backup (PITR) to update immediately. Additionally, users who had replication running under PostgreSQL minor versions 9.3.0, 9.3.1, 9.2.5, 9.1.10, or 9.0.14 should plan to take a fresh base backup of each standby after update, in order to ensure no prior data corruption already exists.

This release also fixes two timing issues with VACUUM, which can cause old, overwritten or deleted rows to re-appear at a later date under some circumstances. Users with very high transaction rates, particularly those who experience "transaction ID wraparound" every few weeks or less, are the most at risk for this issue. Those users should set vacuum_freeze_table_age to 0, and run a database-wide VACUUM after the update. The second of the two VACUUM issues affects only 9.3, making it expecially important for 9.3 users to update.

Revision 1.15 / (download) - annotate - [select for diffs], Sat Oct 12 20:39:43 2013 UTC (10 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.14: +4 -4 lines
Diff to previous 1.14 (colored)

Changes
Guarantee transmission of all WAL files before replica failover
Prevent downcasing of non-ASCII identifiers
Fix several minor memory leaks
Correct overcommit behavior when using more than 24GB of work memory
Improve planner cost estimates for choosing generic plans
Fix estimates of NULL rows in boolean columns
Make UNION ALL and inheritance query plans recheck parameterized paths
Correct pg_dump bugs for foreign tables, views, and extensions
Prevent a parallel pg_restore failure on certain indexes
Make REINDEX revalidate constraints
Prevent two deadlock issues in SP-GIST and REINDEX CONCURRENTLY
Prevent GiST index lookup crash
Fix several regular expression failures
Allow ALTER DEFAULT PRIVILEGES to work on all schemas
Loosen restrictions on keywords
Allow various spellings of infinity
Expand ability to compare rows to records and arrays
Prevent psql client crash on bad PSQLRC file
Add spinlock support for ARM64

Revision 1.13.2.1 / (download) - annotate - [select for diffs], Tue Apr 9 10:33:32 2013 UTC (10 years, 7 months ago) by tron
Branch: pkgsrc-2013Q1
Changes since 1.13: +4 -4 lines
Diff to previous 1.13 (colored) next main 1.14 (colored)

Pullup ticket #4112 - requested by fhajny
databases/postgresql84: security update
databases/postgresql84-client: security update
databases/postgresql84-server: security update
databases/postgresql90: security update
databases/postgresql90-client: security update
databases/postgresql90-docs: security update
databases/postgresql90-server: security update
databases/postgresql91: security update
databases/postgresql91-client: security update
databases/postgresql91-docs: security update
databases/postgresql91-server: security update
databases/postgresql92: security update
databases/postgresql92-client: security update
databases/postgresql92-docs: security update
databases/postgresql92-server: security update

Revisions pulled up:
- databases/Makefile                                            1.428
- databases/postgresql84-client/PLIST                           1.19
- databases/postgresql84-server/PLIST                           1.15
- databases/postgresql84/Makefile.common                        1.26
- databases/postgresql84/distinfo                               1.25
- databases/postgresql90-docs/PLIST                             1.15
- databases/postgresql90-server/PLIST                           1.12
- databases/postgresql90/Makefile.common                        1.24
- databases/postgresql90/distinfo                               1.17
- databases/postgresql91-docs/PLIST                             1.11
- databases/postgresql91-server/PLIST                           1.7
- databases/postgresql91/Makefile.common                        1.14
- databases/postgresql91/distinfo                               1.14
- databases/postgresql92-client/PLIST                           1.4
- databases/postgresql92-docs/PLIST                             1.4
- databases/postgresql92-server/PLIST                           1.3
- databases/postgresql92/Makefile.common                        1.5
- databases/postgresql92/distinfo                               1.4
- databases/postgresql92/patches/patch-contrib_dblink_dblink.c  1.2

---
   Module Name:	pkgsrc
   Committed By:	adam
   Date:		Thu Apr  4 21:08:38 UTC 2013

   Modified Files:
   	pkgsrc/databases: Makefile
   	pkgsrc/databases/postgresql84: Makefile.common distinfo
   	pkgsrc/databases/postgresql84-client: PLIST
   	pkgsrc/databases/postgresql84-server: PLIST
   	pkgsrc/databases/postgresql90: Makefile.common distinfo
   	pkgsrc/databases/postgresql90-docs: PLIST
   	pkgsrc/databases/postgresql90-server: PLIST
   	pkgsrc/databases/postgresql91: Makefile.common distinfo
   	pkgsrc/databases/postgresql91-docs: PLIST
   	pkgsrc/databases/postgresql91-server: PLIST
   	pkgsrc/databases/postgresql92: Makefile.common distinfo
   	pkgsrc/databases/postgresql92-client: PLIST
   	pkgsrc/databases/postgresql92-docs: PLIST
   	pkgsrc/databases/postgresql92-server: PLIST
   	pkgsrc/databases/postgresql92/patches: patch-contrib_dblink_dblink.c
   	pkgsrc/mk: pgsql.buildlink3.mk
   Removed Files:
   	pkgsrc/databases/jdbc-postgresql83: DESCR Makefile PLIST distinfo
   	pkgsrc/databases/postgresql83: DESCR Makefile Makefile.common PLIST
   	    distinfo options.mk
   	pkgsrc/databases/postgresql83-client: DESCR Makefile PLIST
   	    buildlink3.mk
   	pkgsrc/databases/postgresql83-plperl: DESCR MESSAGE Makefile PLIST
   	pkgsrc/databases/postgresql83-plpython: DESCR MESSAGE Makefile PLIST
   	pkgsrc/databases/postgresql83-pltcl: DESCR MESSAGE Makefile PLIST
   	pkgsrc/databases/postgresql83-server: DEINSTALL DESCR MESSAGE Makefile
   	    PLIST
   	pkgsrc/databases/postgresql83-server/files: pgsql.sh
   	pkgsrc/databases/postgresql83-uuid: Makefile
   	pkgsrc/databases/postgresql83/files: GNUmakefile.libpq dynloader-ltdl.h
   	pkgsrc/databases/postgresql83/patches: patch-aa patch-ab patch-ac
   	    patch-ad patch-af patch-ag patch-ah patch-ai patch-ba
   	    patch-src_interfaces_ecpg_ecpglib_Makefile
   	    patch-src_makefiles_Makefile.solaris patch-src_pl_plperl_plperl.h
   	    patch-src_pl_plpgsql_src_Makefile

   Log Message:
   The PostgreSQL Global Development Group has released a security update to all current versions of the PostgreSQL database system, including versions 9.2.4, 9.1.9, 9.0.13, and 8.4.17. This update fixes a high-exposure security vulnerability in versions 9.0 and later. All users of the affected versions are strongly urged to apply the update immediately.

   A major security issue fixed in this release, CVE-2013-1899, makes it possible for a connection request containing a database name that begins with "-" to be crafted that can damage or destroy files within a server's data directory. Anyone with access to the port the PostgreSQL server listens on can initiate this request.

   Two lesser security fixes are also included in this release: CVE-2013-1900, wherein random numbers generated by contrib/pgcrypto functions may be easy for another database user to guess, and CVE-2013-1901, which mistakenly allows an unprivileged user to run commands that could interfere with in-progress backups. Finally, this release fixes two security issues with the graphical installers for Linux and Mac OS X: insecure passing of superuser passwords to a script, CVE-2013-1903 and the use of predictable filenames in /tmp CVE-2013-1902.

Revision 1.14 / (download) - annotate - [select for diffs], Thu Apr 4 21:08:35 2013 UTC (10 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.13: +4 -4 lines
Diff to previous 1.13 (colored)

The PostgreSQL Global Development Group has released a security update to all current versions of the PostgreSQL database system, including versions 9.2.4, 9.1.9, 9.0.13, and 8.4.17. This update fixes a high-exposure security vulnerability in versions 9.0 and later. All users of the affected versions are strongly urged to apply the update immediately.

A major security issue fixed in this release, CVE-2013-1899, makes it possible for a connection request containing a database name that begins with "-" to be crafted that can damage or destroy files within a server's data directory. Anyone with access to the port the PostgreSQL server listens on can initiate this request.

Two lesser security fixes are also included in this release: CVE-2013-1900, wherein random numbers generated by contrib/pgcrypto functions may be easy for another database user to guess, and CVE-2013-1901, which mistakenly allows an unprivileged user to run commands that could interfere with in-progress backups. Finally, this release fixes two security issues with the graphical installers for Linux and Mac OS X: insecure passing of superuser passwords to a script, CVE-2013-1903 and the use of predictable filenames in /tmp CVE-2013-1902.

Revision 1.13 / (download) - annotate - [select for diffs], Sat Feb 9 11:19:14 2013 UTC (10 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base
Branch point for: pkgsrc-2013Q1
Changes since 1.12: +4 -4 lines
Diff to previous 1.12 (colored)

The PostgreSQL Global Development Group has released a security update to all current versions of the PostgreSQL database system, including versions 9.2.3, 9.1.8, 9.0.12, 8.4.16, and 8.3.23. This update fixes a denial-of-service (DOS) vulnerability. All users should update their PostgreSQL installations as soon as possible.

The security issue fixed in this release, CVE-2013-0255, allows a previously authenticated user to crash the server by calling an internal function with invalid arguments. This issue was discovered by independent security researcher Sumit Soni this week and reported via Secunia SVCRP, and we are grateful for their efforts in making PostgreSQL more secure.

Today's update also fixes a performance regression which caused a decrease in throughput when using dynamic queries in stored procedures in version 9.2. Applications which use PL/pgSQL's EXECUTE are strongly affected by this regression and should be updated. Additionally, we have fixed intermittent crashes caused by CREATE/DROP INDEX CONCURRENTLY, and multiple minor issues with replication.

This release is expected to be the final update for version 8.3, which is now End-of-Life (EOL). Users of version 8.3 should plan to upgrade to a later version of PostgreSQL immediately. For more information, see our Versioning Policy.

This update release also contains fixes for many minor issues discovered and patched by the PostgreSQL community in the last two months, including:

* Prevent unnecessary table scans during vacuuming
* Prevent spurious cached plan error in PL/pgSQL
* Allow sub-SELECTs to be subscripted
* Prevent DROP OWNED from dropping databases or tablespaces
* Make ECPG use translated messages
* Allow PL/Python to use multi-table trigger functions (again) in 9.1 and 9.2
* Fix several activity log management issues on Windows
* Prevent autovacuum file truncation from being cancelled by deadlock_timeout
* Make extensions build with the .exe suffix automatically on Windows
* Fix concurrency issues with CREATE/DROP DATABASE
* Reject out-of-range values in to_date() conversion function
* Revert cost estimation for large indexes back to pre-9.2 behavior
* Make pg_basebackup tolerate timeline switches
* Cleanup leftover temp table entries during crash recovery
* Prevent infinite loop when COPY inserts a large tuple into a table with a large fillfactor
* Prevent integer overflow in dynahash creation
* Make pg_upgrade work with INVALID indexes
* Fix bugs in TYPE privileges
* Allow Contrib installchecks to run in their own databases
* Many documentation updates
* Add new timezone "FET".

Revision 1.12 / (download) - annotate - [select for diffs], Fri Dec 7 21:19:50 2012 UTC (10 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.11: +4 -4 lines
Diff to previous 1.11 (colored)

This release fixes a significant page ordering issue with Hot Standby which could cause index corruption on the standby under some circumstances. In addition, this update patches timing issues with checkpoint and transaction ID wraparound which could cause data corruption in some cases. Today's update also fixes multiple issues with CREATE INDEX CONCURRENTLY and DROP INDEX CONCURRENTLY, which can cause those commands to fail or produce corrupt indexes. Users who use this feature may want to REINDEX or recreate affected indexes (see below).

This update release also contains fixes for many minor issues discovered and patched by the PostgreSQL community in the last month, including several fixes which are specific to version 9.2. These include:

* Prevent psql crash due to incorrectly encoded input data
* Fix pg_regress gmake build issues
* Make sure correct directory is created for extensions
* Fix some issues with buffer locks and VACUUM
* Multiple fixes and improvements for pg_upgrade
* Fix bugs with end-of-recovery when failing over to a standby
* Avoid bogus "out-of-sequence timeline ID" errors in standby-mode
* Don't launch new child processes during shutdown
* Improve the ability of JOINs to use partial indexes
* Fix assorted integer overflow errors
* Eliminate memory leaks in record_out() and record_send()
* Skip searching for subtransaction logs at COMMIT
* Fix WaitLatch() timing issues
* Fix handling of inherited check constraints in ALTER COLUMN TYPE
* Make ALTER EXTENSION SET SCHEMA behave as documented
* Have SEQUENCE SET statements in the "data" section of sectional dumps
* Prevent parser from believing that VIEWs have system columns
* Fix --clean mode for pg_dump
* Prevent hash table corruption on out-of-memory
* Various query planner and executor fixes and improvements
* Multiple documentation updates
* DST updates for seven timezones

Revision 1.11 / (download) - annotate - [select for diffs], Sun Oct 7 22:15:26 2012 UTC (11 years, 1 month ago) by marino
Branch: MAIN
Changes since 1.10: +1 -4 lines
Diff to previous 1.10 (colored)

databases/postgresql(-client): Revert most of last commit

After discussing gcc47 build problems with postgresql developers, it
became apparent that the error was unique to DragonFly.  It turns out
that DragonFly was using an older offsetof macro instead of the builtin
version provided by GCC.

Fixing the offsetof macro on DragonFly allowed the pre-patched psgsql 91
to build without issue.  While the previous patches certainly don't hurt
anything, they are being removed to ease future maintenance.

The warning suppression fix is still valid, so the change to the pgsql
client makefile is being left in place.

Revision 1.10 / (download) - annotate - [select for diffs], Sun Oct 7 10:24:54 2012 UTC (11 years, 1 month ago) by marino
Branch: MAIN
Changes since 1.9: +4 -1 lines
Diff to previous 1.9 (colored)

databases/postgresql91(-client): Fix build for gcc46 and gcc47

Postgresql91 uses non-constant array sizes in record definitions which
gcc enforces starting with 4.6.  These index sizes are defined as macros
using functions such as offsetof.  These patches introduce enums where
the macros become constant expressions which gcc 4.6+ will accept.

GCC 4.7 also introduces the unused-but-set-variable warning which is
popping up all over the place in pgsql91, so silence these warnings -
they are harmless and get optimized out anyway.

No revbump because functionality won't change on binaries generated with
gcc4.5 and below.

Revision 1.9 / (download) - annotate - [select for diffs], Fri Oct 5 22:15:36 2012 UTC (11 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.8: +4 -4 lines
Diff to previous 1.8 (colored)

The PostgreSQL Global Development Group has released an update to all current versions of the PostgreSQL database system, including 9.2.1, 9.1.6, 9.0.10, 8.4.14 and 8.3.21. This update fixes critical issues for major versions 9.1 and 9.2, and users running those versions should apply it as soon as possible. Users of versions 8.3, 8.4 and 9.0 should plan to update at the next scheduled downtime.

The update fixes two potential data corruption issues present in the PostgreSQL 9.1 and 9.2 for any server which has crashed, been shutdown with "immediate", or was failed over to a standby. First, the PostgreSQL development team has discovered a chance of corruption of BTREE and GIN indexes for databases. Second, there is a significant chance of corruption of the visibility map. This update fixes both issues.

We strongly advise users of 9.1 and 9.2 to run VACUUM and/or index rebuilds after applying the update. Please see the 2012-09-24 Update wiki page for detailed instructions.

This update release also contains fixes for many minor issues discovered and patched by the PostgreSQL community in the last month, including many fixes for the newly released version 9.2. These include:

fix sorting issue with IN lists and indexes
fix planner failure when combining GROUP BY with window functions
improve selectivity of text searches using prefixes
prevent rescanning of WITH clauses from giving wrong answers
fix PL/Perl crashing issue
reduce bloat for multi-column GiST indexes
time zone data changes for Fiji
disallow Extensions from circular schema assignment
prevent crashes when default_transaction_isolation is set to "serializable"
several minor fixes to pg_upgrade

Revision 1.8 / (download) - annotate - [select for diffs], Thu Aug 23 16:30:34 2012 UTC (11 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.7: +4 -4 lines
Diff to previous 1.7 (colored)

Changes 9.1.5:
* Prevent access to external files/URLs via XML entity references
* Prevent access to external files/URLs via contrib/xml2's xslt_process()
* Prevent too-early recycling of btree index pages
* Fix crash-safety bug with newly-created-or-reset sequences
* Fix race condition in enum-type value comparisons
* Fix txid_current() to report the correct epoch when not in hot standby
* Prevent selection of unsuitable replication connections as the synchronous
  standby
* Fix bug in startup of Hot Standby when a master transaction has many
  subtransactions
* Ensure the backup_label file is fsync'd after pg_start_backup()
* Fix timeout handling in walsender processes
* Wake walsenders after each background flush by walwriter
* Fix LISTEN/NOTIFY to cope better with I/O problems, such as out of disk space
* Only allow autovacuum to be auto-canceled by a directly blocked process
* Improve logging of autovacuum cancels
* Fix WITH attached to a nested set operation (UNION/INTERSECT/EXCEPT)

Revision 1.7 / (download) - annotate - [select for diffs], Mon Jul 16 21:17:12 2012 UTC (11 years, 4 months ago) by asau
Branch: MAIN
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Force common shared library version scheme on FreeBSD to avoid PLIST divergence.

Revision 1.5.4.1 / (download) - annotate - [select for diffs], Tue Jul 3 23:23:09 2012 UTC (11 years, 5 months ago) by tron
Branch: pkgsrc-2012Q2
Changes since 1.5: +4 -4 lines
Diff to previous 1.5 (colored) next main 1.6 (colored)

Pullup ticket #3844 - requested by morr
databases/postgresql91: security update
databases/postgresql91-adminpack: security update
databases/postgresql91-client: security update
databases/postgresql91-datatypes: security update
databases/postgresql91-dblink: security update
databases/postgresql91-docs: security update
databases/postgresql91-fuzzystrmatch: security update
databases/postgresql91-monitoring: security update
databases/postgresql91-pgcrypto: security update
databases/postgresql91-plperl: security update
databases/postgresql91-plpython: security update
databases/postgresql91-pltcl: security update
databases/postgresql91-replicationtools: security update
databases/postgresql91-server: security update
databases/postgresql91-upgrade: security update

Revisions pulled up:
- databases/postgresql91-adminpack/Makefile                     1.3
- databases/postgresql91-client/Makefile                        1.7
- databases/postgresql91-datatypes/Makefile                     1.3
- databases/postgresql91-dblink/Makefile                        1.3
- databases/postgresql91-docs/Makefile                          1.3
- databases/postgresql91-docs/PLIST                             1.6
- databases/postgresql91-fuzzystrmatch/Makefile                 1.3
- databases/postgresql91-monitoring/Makefile                    1.3
- databases/postgresql91-pgcrypto/Makefile                      1.3
- databases/postgresql91-plperl/Makefile                        1.3
- databases/postgresql91-plpython/Makefile                      1.4
- databases/postgresql91-pltcl/Makefile                         1.3
- databases/postgresql91-replicationtools/Makefile              1.3
- databases/postgresql91-server/Makefile                        1.3
- databases/postgresql91-server/PLIST                           1.5
- databases/postgresql91-upgrade/Makefile                       1.3
- databases/postgresql91/Makefile                               1.3
- databases/postgresql91/Makefile.common                        1.7
- databases/postgresql91/distinfo                               1.6

---
   Module Name:	pkgsrc
   Committed By:	morr
   Date:		Sun Jul  1 19:49:26 UTC 2012

   Modified Files:
   	pkgsrc/databases/postgresql91: Makefile Makefile.common distinfo
   	pkgsrc/databases/postgresql91-adminpack: Makefile
   	pkgsrc/databases/postgresql91-client: Makefile
   	pkgsrc/databases/postgresql91-datatypes: Makefile
   	pkgsrc/databases/postgresql91-dblink: Makefile
   	pkgsrc/databases/postgresql91-docs: Makefile PLIST
   	pkgsrc/databases/postgresql91-fuzzystrmatch: Makefile
   	pkgsrc/databases/postgresql91-monitoring: Makefile
   	pkgsrc/databases/postgresql91-pgcrypto: Makefile
   	pkgsrc/databases/postgresql91-plperl: Makefile
   	pkgsrc/databases/postgresql91-plpython: Makefile
   	pkgsrc/databases/postgresql91-pltcl: Makefile
   	pkgsrc/databases/postgresql91-replicationtools: Makefile
   	pkgsrc/databases/postgresql91-server: Makefile PLIST
   	pkgsrc/databases/postgresql91-upgrade: Makefile

   Log Message:
   Security update to version 9.1.4.

   Changes:

   * Fix incorrect password transformation in contrib/pgcrypto's DES crypt()
   function (Solar Designer)
   * Ignore SECURITY DEFINER and SET attributes for a procedural language's call
   handler (Tom Lane)
   * Make contrib/citext's upgrade script fix collations of citext arrays and
   domains over citext (Tom Lane)
   * Allow numeric timezone offsets in timestamp input to be up to 16 hours away
   from UTC (Tom Lane)
   * Fix timestamp conversion to cope when the given time is exactly the last DST
   transition time for the current timezone (Tom Lane)
   * Fix text to name and char to name casts to perform string truncation
   correctly in multibyte encodings (Karl Schnaitter)
   * Fix memory copying bug in to_tsquery() (Heikki Linnakangas)
   * Ensure txid_current() reports the correct epoch when executed in hot standby
   (Simon Riggs)
   * Fix planner's handling of outer PlaceHolderVars within subqueries (Tom Lane)
   * Fix planning of UNION ALL subqueries with output columns that are not simple
   variables (Tom Lane)
   * Fix slow session startup when pg_attribute is very large (Tom Lane)
   * Ensure sequential scans check for query cancel reasonably often (Merlin
   Moncure)
   * Ensure the Windows implementation of PGSemaphoreLock() clears
   ImmediateInterruptOK before returning (Tom Lane)
   * Show whole-row variables safely when printing views or rules (Abbas Butt, Tom
   Lane)
   * Fix COPY FROM to properly handle null marker strings that correspond to
   invalid encoding (Tom Lane)
   * Fix EXPLAIN VERBOSE for writable CTEs containing RETURNING clauses (Tom Lane)
   * Fix PREPARE TRANSACTION to work correctly in the presence of advisory locks
   (Tom Lane)
   * Fix truncation of unlogged tables (Robert Haas)
   * Ignore missing schemas during non-interactive assignments of search_path (Tom
   Lane)
   * Fix bugs with temporary or transient tables used in extension scripts (Tom
   Lane)
   * Ensure autovacuum worker processes perform stack depth checking properly
   (Heikki Linnakangas)
   * Fix logging collector to not lose log coherency under high load (Andrew
   Dunstan)
   * Fix logging collector to ensure it will restart file rotation after receiving
   SIGHUP (Tom Lane)
   * Fix "too many LWLocks taken" failure in GiST indexes (Heikki Linnakangas)
   * Fix WAL replay logic for GIN indexes to not fail if the index was
   subsequently dropped (Tom Lane)
   * Correctly detect SSI conflicts of prepared transactions after a crash (Dan
   Ports)
   * Avoid synchronous replication delay when committing a transaction that only
   modified temporary tables (Heikki Linnakangas)
   * Fix error handling in pg_basebackup (Thomas Ogrisegg, Fujii Masao)
   * Fix walsender to not go into a busy loop if connection is terminated (Fujii
   Masao)
   * Fix memory leak in PL/pgSQL's RETURN NEXT command (Joe Conway)
   * Fix PL/pgSQL's GET DIAGNOSTICS command when the target is the function's
   first variable (Tom Lane)
   * Ensure that PL/Perl package-qualifies the _TD variable (Alex Hunsaker)
   * Fix PL/Python functions returning composite types to accept a string for
   their result value (Jan Urbanski)
   * Fix potential access off the end of memory in psql's expanded display (\x)
   mode (Peter Eisentraut)
   * Fix several performance problems in pg_dump when the database contains many
   objects (Jeff Janes, Tom Lane)
   * Fix memory and file descriptor leaks in pg_restore when reading a
   directory-format archive (Peter Eisentraut)
   * Fix pg_upgrade for the case that a database stored in a non-default
   tablespace contains a table in the cluster's default tablespace (Bruce Momjian)
   * In ecpg, fix rare memory leaks and possible overwrite of one byte after the
   sqlca_t structure (Peter Eisentraut)
   * Fix contrib/dblink's dblink_exec() to not leak temporary database connections
   upon error (Tom Lane)
   * Fix contrib/dblink to report the correct connection name in error messages
   (Kyotaro Horiguchi)
   * Fix contrib/vacuumlo to use multiple transactions when dropping many large
   objects (Tim Lewis, Robert Haas, Tom Lane)
   * Update time zone data files to tzdata release 2012c for DST law changes in
   Antarctica, Armenia, Chile, Cuba, Falkland Islands, Gaza, Haiti, Hebron,
   Morocco, Syria, and Tokelau Islands;

Revision 1.6 / (download) - annotate - [select for diffs], Sun Jul 1 19:49:24 2012 UTC (11 years, 5 months ago) by morr
Branch: MAIN
Changes since 1.5: +4 -4 lines
Diff to previous 1.5 (colored)

Security update to version 9.1.4.

Changes:

* Fix incorrect password transformation in contrib/pgcrypto's DES crypt()
function (Solar Designer)
* Ignore SECURITY DEFINER and SET attributes for a procedural language's call
handler (Tom Lane)
* Make contrib/citext's upgrade script fix collations of citext arrays and
domains over citext (Tom Lane)
* Allow numeric timezone offsets in timestamp input to be up to 16 hours away
from UTC (Tom Lane)
* Fix timestamp conversion to cope when the given time is exactly the last DST
transition time for the current timezone (Tom Lane)
* Fix text to name and char to name casts to perform string truncation
correctly in multibyte encodings (Karl Schnaitter)
* Fix memory copying bug in to_tsquery() (Heikki Linnakangas)
* Ensure txid_current() reports the correct epoch when executed in hot standby
(Simon Riggs)
* Fix planner's handling of outer PlaceHolderVars within subqueries (Tom Lane)
* Fix planning of UNION ALL subqueries with output columns that are not simple
variables (Tom Lane)
* Fix slow session startup when pg_attribute is very large (Tom Lane)
* Ensure sequential scans check for query cancel reasonably often (Merlin
Moncure)
* Ensure the Windows implementation of PGSemaphoreLock() clears
ImmediateInterruptOK before returning (Tom Lane)
* Show whole-row variables safely when printing views or rules (Abbas Butt, Tom
Lane)
* Fix COPY FROM to properly handle null marker strings that correspond to
invalid encoding (Tom Lane)
* Fix EXPLAIN VERBOSE for writable CTEs containing RETURNING clauses (Tom Lane)
* Fix PREPARE TRANSACTION to work correctly in the presence of advisory locks
(Tom Lane)
* Fix truncation of unlogged tables (Robert Haas)
* Ignore missing schemas during non-interactive assignments of search_path (Tom
Lane)
* Fix bugs with temporary or transient tables used in extension scripts (Tom
Lane)
* Ensure autovacuum worker processes perform stack depth checking properly
(Heikki Linnakangas)
* Fix logging collector to not lose log coherency under high load (Andrew
Dunstan)
* Fix logging collector to ensure it will restart file rotation after receiving
SIGHUP (Tom Lane)
* Fix "too many LWLocks taken" failure in GiST indexes (Heikki Linnakangas)
* Fix WAL replay logic for GIN indexes to not fail if the index was
subsequently dropped (Tom Lane)
* Correctly detect SSI conflicts of prepared transactions after a crash (Dan
Ports)
* Avoid synchronous replication delay when committing a transaction that only
modified temporary tables (Heikki Linnakangas)
* Fix error handling in pg_basebackup (Thomas Ogrisegg, Fujii Masao)
* Fix walsender to not go into a busy loop if connection is terminated (Fujii
Masao)
* Fix memory leak in PL/pgSQL's RETURN NEXT command (Joe Conway)
* Fix PL/pgSQL's GET DIAGNOSTICS command when the target is the function's
first variable (Tom Lane)
* Ensure that PL/Perl package-qualifies the _TD variable (Alex Hunsaker)
* Fix PL/Python functions returning composite types to accept a string for
their result value (Jan Urbanski)
* Fix potential access off the end of memory in psql's expanded display (\x)
mode (Peter Eisentraut)
* Fix several performance problems in pg_dump when the database contains many
objects (Jeff Janes, Tom Lane)
* Fix memory and file descriptor leaks in pg_restore when reading a
directory-format archive (Peter Eisentraut)
* Fix pg_upgrade for the case that a database stored in a non-default
tablespace contains a table in the cluster's default tablespace (Bruce Momjian)
* In ecpg, fix rare memory leaks and possible overwrite of one byte after the
sqlca_t structure (Peter Eisentraut)
* Fix contrib/dblink's dblink_exec() to not leak temporary database connections
upon error (Tom Lane)
* Fix contrib/dblink to report the correct connection name in error messages
(Kyotaro Horiguchi)
* Fix contrib/vacuumlo to use multiple transactions when dropping many large
objects (Tim Lewis, Robert Haas, Tom Lane)
* Update time zone data files to tzdata release 2012c for DST law changes in
Antarctica, Armenia, Chile, Cuba, Falkland Islands, Gaza, Haiti, Hebron,
Morocco, Syria, and Tokelau Islands;

Revision 1.5 / (download) - annotate - [select for diffs], Sat Mar 3 14:01:12 2012 UTC (11 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Branch point for: pkgsrc-2012Q2
Changes since 1.4: +5 -5 lines
Diff to previous 1.4 (colored)

Changes:
* Fix btree index corruption from insertions concurrent with vacuuming
* Recover from errors occurring during WAL replay of DROP TABLESPACE
* Fix transient zeroing of shared buffers during WAL replay
* Fix postmaster to attempt restart after a hot-standby crash
* Fix corner case in SSI transaction cleanup
* Update per-column permissions, not only per-table permissions, when changing
  table owner
* Fix handling of data-modifying WITH subplans in READ COMMITTED rechecking
* Fix for "could not find plan for CTE" failures
* Fix unsupported node type error caused by COLLATE in an INSERT expression
* Avoid crashing when we have problems deleting table files post-commit
* Fix recently-introduced memory leak in processing of inet/cidr
* Fix GIN cost estimation to handle column IN (...) index conditions
* Fix I/O-conversion-related memory leaks in plpgsql
* Teach pg_upgrade to handle renaming of plpython's shared library (affecting
  upgrades to 9.1)

Revision 1.4 / (download) - annotate - [select for diffs], Tue Dec 6 20:37:33 2011 UTC (11 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

Changes 9.1.2:
* Fix bugs in information_schema.referential_constraints view
* Correct collations for citext columns and indexes
* Prevent possible crash when joining to a scalar function
* Prevent transitory data corruption of GIN indexes after a crash
* Prevent data corruption on TOAST columns when copying data
* Fix failures during hot standby startup
* Correct another "variable not found in subplan target list" bug
* Fix bug with sorting on aggregate expressions in windowing functions
* Multiple bug fixes for pg_upgrade
* Change Foreign Key creation order to better support self-referential keys
* Multiple bug fixes to CREATE EXTENSION
* Ensure that function return type and data returned from PL/perl agree
* Ensure that PL/perl strings are always UTF-8
* Assorted bug fixes for various Extensions
* Updates to the time zone database, particularly to CST6

Revision 1.3 / (download) - annotate - [select for diffs], Wed Oct 12 19:45:57 2011 UTC (12 years, 1 month ago) by hans
Branch: MAIN
Changes since 1.2: +3 -1 lines
Diff to previous 1.2 (colored)

Fix build on SunOS.

Revision 1.2 / (download) - annotate - [select for diffs], Tue Sep 27 11:04:49 2011 UTC (12 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Changes 9.1.1:
* Make pg_options_to_table return NULL for an option with no value
* Fix memory leak at end of a GiST index scan
* Fix explicit reference to pg_temp schema in "CREATE TEMPORARY TABLE"

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Thu Sep 15 08:27:38 2011 UTC (12 years, 2 months ago) by adam
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Version 9.1 delivers several features which users have been requesting for
years, removing roadblocks to deploying new or ported applications on
PostgreSQL. These include:
* Synchronous Replication: enable high-availability with consistency across
  multiple servers
* Per-Column Collations: support linguistically-correct sorting per database,
  table or column.
* Unlogged Tables: greatly improves performance for ephemeral data

Our community of contributors innovates with cutting-edge features. Version 9.1
includes several which are new to the database industry, such as:
* K-Nearest-Neighbor Indexing: index on "distance" for faster location and text
  search queries
* Serializable Snapshot Isolation: keeps concurrent transactions consistent
  without blocking, using "true serializability"
* Writeable Common Table Expressions: execute complex multi-stage data updates
  in a single query
* Security-Enhanced Postgres: deploy military-grade security and Mandatory
  Access Control

Revision 1.1 / (download) - annotate - [select for diffs], Thu Sep 15 08:27:38 2011 UTC (12 years, 2 months ago) by adam
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>