[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql91-datatypes

File: [cvs.NetBSD.org] / pkgsrc / databases / postgresql91-datatypes / Attic / Makefile (download)

Revision 1.10, Wed Feb 12 23:17:42 2014 UTC (10 years, 2 months ago) by tron
Branch: MAIN
Changes since 1.9: +2 -2 lines

Recursive PKGREVISION bump for OpenSSL API version bump.

# $NetBSD: Makefile,v 1.10 2014/02/12 23:17:42 tron Exp $

PKGNAME=	${DISTNAME:C/-/91-datatypes-/}
PKGREVISION=	2
COMMENT=	PostgreSQL data types support modules

DEPENDS+=	postgresql91-server>=${PKGVERSION_NOREV}:../../databases/postgresql91-server

.include "../../databases/postgresql91/Makefile.common"

PLIST_VARS+=		uuid

.if ${OPSYS} != "Darwin"
PLIST.uuid=		yes
CONFIGURE_ARGS+=	--with-ossp-uuid
# because global pg_config.h is included, we have to define this
CPPFLAGS+=		-DHAVE_UUID_H
BUILD_DIRS+=		contrib/uuid-ossp
.  include "../../devel/ossp-uuid/buildlink3.mk"
.endif

BUILD_DIRS+=		contrib/citext
BUILD_DIRS+=		contrib/hstore
BUILD_DIRS+=		contrib/intarray
BUILD_DIRS+=		contrib/isn
BUILD_DIRS+=		contrib/ltree
BUILD_DIRS+=		contrib/lo
BUILD_DIRS+=		contrib/unaccent
BUILD_MAKE_FLAGS=	PGXS=1

.include "../../databases/postgresql91-client/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"