[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql83-plperl

File: [cvs.NetBSD.org] / pkgsrc / databases / postgresql83-plperl / Attic / Makefile (download)

Revision 1.3, Sun Oct 19 19:17:46 2008 UTC (15 years, 6 months ago) by he
Branch: MAIN
Changes since 1.2: +2 -1 lines

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.8.8 -> 5.10.0.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=...").

# $NetBSD: Makefile,v 1.3 2008/10/19 19:17:46 he Exp $

PKGNAME=	postgresql83-plperl-${BASE_VERS}
COMMENT=	PL/Perl procedural language for the PostgreSQL backend
PKGREVISION=	1

PKG_DESTDIR_SUPPORT=	user-destdir

DEPENDS+=	postgresql83-server>=${BASE_VERS}:../../databases/postgresql83-server

.include "../../databases/postgresql83/Makefile.common"

PERL5_CONFIGURE=	no
CONFIGURE_ARGS+=	--with-perl

BUILD_DIRS=		src/pl/plperl
MAKE_FILE=		GNUmakefile
BUILD_MAKE_FLAGS=	PGXS=1

USE_TOOLS+=		perl
USE_LIBTOOL=		yes
PKG_LIBTOOL=		${PKG_SHLIBTOOL}

.include "../../databases/postgresql83-client/buildlink3.mk"
.include "../../lang/perl5/module.mk"

.include "../../mk/bsd.pkg.mk"