[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql83-client

Annotation of pkgsrc/databases/postgresql83-client/Makefile, Revision 1.25

1.25    ! hans        1: # $NetBSD: Makefile,v 1.24 2011/09/27 11:03:59 adam Exp $
1.1       adam        2:
1.19      adam        3: PKGNAME=       ${DISTNAME:C/-/83-client-/}
1.1       adam        4: COMMENT=       PostgreSQL database client programs
                      5:
                      6: PKG_DESTDIR_SUPPORT=   user-destdir
                      7:
                      8: .include "../../databases/postgresql83/Makefile.common"
                      9:
                     10: USE_TOOLS+=            gzip tar
                     11: CONFIGURE_ARGS+=       --with-openssl
                     12: CONFIGURE_ARGS+=       --with-readline
                     13: CONFIGURE_ARGS+=       --with-zlib
                     14:
                     15: # 1. The thread-safety test in ${WRSRC}/src/tools/thread does not pass on
                     16: # NetBSD earler than 4.0 or DragonFly.
                     17: # 2. configure with --enable-thread-safety fails on OpenBSD.
1.2       rmind      18: .if (${OPSYS} == "NetBSD" && !empty(OS_VERSION:M[0-3].*)) || \
                     19:     ${OPSYS} == "DragonFly" || ${OPSYS} == "OpenBSD"
1.1       adam       20: PGSQL_THREAD_SAFETY?=  no
                     21: .endif
                     22: PGSQL_THREAD_SAFETY?=  yes
                     23: BUILD_DEFS+=           PGSQL_THREAD_SAFETY
                     24:
                     25: .if !empty(PGSQL_THREAD_SAFETY:M[yY][eE][sS])
                     26: .  include "../../mk/pthread.buildlink3.mk"
                     27: .  if (${PTHREAD_TYPE} == "native")
                     28: CONFIGURE_ARGS+=       --enable-thread-safety
                     29: .  endif
                     30: .endif
                     31:
                     32: INSTALL_DIRS=  src/include
                     33: INSTALL_DIRS+= src/interfaces
                     34: INSTALL_DIRS+= src/bin
1.3       adam       35: INSTALL_DIRS+= src/port
1.1       adam       36: INSTALL_DIRS+= doc
                     37: BUILD_DIRS=    ${INSTALL_DIRS}
                     38: # Without this, the Darwin build fails (related to -bundle_loader).
                     39: BUILD_DIRS+=   src/backend
                     40:
1.19      adam       41: .for f in pg_service.conf psqlrc
                     42: CONF_FILES+=   ${PREFIX}/share/postgresql/${f}.sample ${PKG_SYSCONFDIR}/${f}
1.1       adam       43: .endfor
                     44:
                     45: # XXX work around core dumps with the native libedit
                     46: USE_GNU_READLINE=      yes
                     47:
                     48: .include "../../devel/readline/buildlink3.mk"
                     49: .include "../../devel/zlib/buildlink3.mk"
                     50: .include "../../security/openssl/buildlink3.mk"
                     51:
1.10      adam       52: SUBST_CLASSES+=                pgxs
                     53: SUBST_STAGE.pgxs=      post-build
                     54: SUBST_MESSAGE.pgxs=    Fixing workdir tools references in pgxs Makefile
                     55: SUBST_FILES.pgxs=      src/Makefile.global
1.25    ! hans       56: SUBST_SED.pgxs=                -e 's,${TOOLS_CMD.bison},${TOOLS_PATH.bison},'
        !            57: SUBST_SED.pgxs+=       -e 's,${TOOLS_CMD.lex},${TOOLS_PATH.lex},'
        !            58: SUBST_SED.pgxs+=       -e 's,${TOOLS_CMD.perl},${PERL5},'
1.20      brook      59: SUBST_SED.pgxs+=       -e 's,${WRKDIR}/.wrapper/bin/ld,${LD},'
1.10      adam       60: SUBST_SED.pgxs+=       -e 's,${WRKDIR}/.wrapper,${PREFIX},'
                     61: SUBST_SED.pgxs+=       -e 's,${WRKSRC},/dev/null,'
                     62:
1.19      adam       63: INSTALLATION_DIRS+=    lib/postgresql/pgxs
                     64: INSTALLATION_DIRS+=    lib/postgresql/pgxs/config
                     65: INSTALLATION_DIRS+=    lib/postgresql/pgxs/src
                     66: INSTALLATION_DIRS+=    lib/postgresql/pgxs/src/makefiles
                     67:
                     68: DEST_PGXS=     ${DESTDIR}${PREFIX}/lib/postgresql/pgxs
                     69: PGXS_FILES=    config/install-sh config/mkinstalldirs
                     70: PGXS_FILES+=   src/makefiles/pgxs.mk src/Makefile.global
                     71: PGXS_FILES+=   src/Makefile.port src/Makefile.shlib
                     72: PGXS_FILES+=   src/nls-global.mk
1.10      adam       73:
1.1       adam       74: # On Solaris, avoid conflicts between "${SSLBASE}/include/openssl/des.h"
                     75: # and "/usr/include/crypt.h" -- we want the definitions in the former.
                     76: .if ${OPSYS} == "SunOS"
                     77: post-wrapper:
                     78:        touch ${BUILDLINK_DIR}/include/crypt.h
                     79: .endif
                     80:
                     81: pre-build:
1.5       rillig     82:        ${RUN} ${_ULIMIT_CMD}                                           \
1.1       adam       83:        cd ${WRKSRC}/src/backend &&                                     \
1.5       rillig     84:        env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS}             \
1.1       adam       85:                ../../src/include/parser/parse.h                        \
                     86:                ../../src/include/utils/fmgroids.h
                     87:
                     88: post-install:
1.23      adam       89:        ${INSTALL_DATA} ${WRKSRC}/doc/FAQ* ${DESTDIR}${PREFIX}/share/doc/postgresql/
                     90: .for file in ${PGXS_FILES}
                     91:        ${INSTALL_DATA} ${WRKSRC}/${file} ${DEST_PGXS}/${file}
                     92: .endfor
1.1       adam       93:
                     94: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>