[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql82-client

Annotation of pkgsrc/databases/postgresql82-client/Makefile, Revision 1.7

1.7     ! rillig      1: # $NetBSD: Makefile,v 1.6 2009/01/20 19:43:56 sketch Exp $
1.1       adam        2:
                      3: PKGNAME=       postgresql82-client-${BASE_VERS}
                      4: COMMENT=       PostgreSQL database client programs
                      5:
                      6: PKG_DESTDIR_SUPPORT=   user-destdir
                      7:
                      8: .include "../../databases/postgresql82/Makefile.common"
                      9:
                     10: USE_TOOLS+=            gzip tar
                     11: USE_LIBTOOL=           yes
                     12: CONFIGURE_ARGS+=       --with-openssl
                     13: CONFIGURE_ARGS+=       --with-readline
                     14: CONFIGURE_ARGS+=       --with-zlib
                     15:
                     16: CONFLICTS+=    postgresql82-lib-[0-9]*
                     17: CONFLICTS+=    postgresql82-docs-[0-9]*
                     18:
                     19: # 1. The thread-safety test in ${WRSRC}/src/tools/thread does not pass on
1.2       rmind      20: # NetBSD earler than 4.0 or DragonFly.
1.1       adam       21: # 2. configure with --enable-thread-safety fails on OpenBSD.
                     22: #
1.2       rmind      23: .if (${OPSYS} == "NetBSD" && !empty(OS_VERSION:M[0-3].*)) || \
                     24:     ${OPSYS} == "DragonFly" || ${OPSYS} == "OpenBSD"
1.1       adam       25: PGSQL_THREAD_SAFETY?=  no
                     26: .endif
                     27: PGSQL_THREAD_SAFETY?=  yes
                     28: BUILD_DEFS+=           PGSQL_THREAD_SAFETY
                     29:
                     30: .if !empty(PGSQL_THREAD_SAFETY:M[yY][eE][sS])
                     31: .  include "../../mk/pthread.buildlink3.mk"
                     32: .  if (${PTHREAD_TYPE} == "native")
                     33: CONFIGURE_ARGS+=       --enable-thread-safety
                     34: .  endif
                     35: .endif
                     36:
1.6       sketch     37: LIBS.SunOS+=   -lintl
                     38:
1.1       adam       39: INSTALL_DIRS=  src/include
                     40: INSTALL_DIRS+= src/interfaces
1.5       adam       41: INSTALL_DIRS+= src/port
1.1       adam       42: INSTALL_DIRS+= src/bin
                     43: INSTALL_DIRS+= doc
                     44:
                     45: BUILD_DIRS=    ${INSTALL_DIRS}
                     46:
                     47: # Without this, the Darwin build fails (related to -bundle_loader).
                     48: BUILD_DIRS+=   src/backend
                     49:
                     50: PKG_OPTIONS_VAR=       PKG_OPTIONS.postgresql82-client
                     51: .include "../../databases/postgresql82/options.mk"
                     52:
                     53: .for _file_ in pg_service.conf psqlrc
                     54: CONF_FILES+=   ${PG_DATA_DIR}/${_file_}.sample ${PG_ETC_DIR}/${_file_}
                     55: .endfor
                     56: .if !empty(PG_SUBPREFIX)
                     57: PLIST_SUBST+=  PG_DIRRM_SUBPREFIX="@dirrm ${PG_SUBPREFIX}"
                     58: .else
                     59: PLIST_SUBST+=  PG_DIRRM_SUBPREFIX="@comment empty line"
                     60: .endif
                     61:
                     62: # XXX work around core dumps with the native libedit
                     63: USE_GNU_READLINE=      yes
                     64:
                     65: .include "../../devel/readline/buildlink3.mk"
                     66: .include "../../devel/zlib/buildlink3.mk"
                     67: .include "../../security/openssl/buildlink3.mk"
                     68:
                     69: # On Solaris, avoid conflicts between "${SSLBASE}/include/openssl/des.h"
                     70: # and "/usr/include/crypt.h" -- we want the definitions in the former.
                     71: #
                     72: .if ${OPSYS} == "SunOS"
                     73: post-wrapper:
                     74:        touch ${BUILDLINK_DIR}/include/crypt.h
                     75: .endif
                     76:
                     77: pre-build:
1.7     ! rillig     78:        ${RUN} ${_ULIMIT_CMD}                                           \
1.1       adam       79:        cd ${WRKSRC}/src/backend &&                                     \
1.7     ! rillig     80:        env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS}             \
1.1       adam       81:                ../../src/include/parser/parse.h                        \
                     82:                ../../src/include/utils/fmgroids.h
                     83:
                     84: post-install:
                     85:        cd ${WRKSRC}/doc; for file in                                   \
                     86:                FAQ* KNOWN_BUGS MISSING_FEATURES README.* TODO          \
                     87:                bug.template;                                           \
                     88:        do                                                              \
                     89:                ${INSTALL_DATA} $$file ${DESTDIR}${PG_DOC_DIR}/$$file;  \
                     90:         done
                     91:        cp -R ${WRKSRC}/doc/TODO.detail ${DESTDIR}${PG_DOC_DIR}
                     92:        chown -R ${DOCOWN}:${DOCGRP} ${DESTDIR}${PG_DOC_DIR}/TODO.detail
                     93:
                     94: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>