[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql81-server

Annotation of pkgsrc/databases/postgresql81-server/Makefile, Revision 1.7

1.7     ! adam        1: # $NetBSD: Makefile,v 1.6 2006/11/05 17:42:30 joerg Exp $
1.1       uebayasi    2:
                      3: PKGNAME=       postgresql81-server-${BASE_VERS}
                      4: COMMENT=       PostgreSQL database server programs
                      5:
1.6       joerg       6: PKG_DESTDIR_SUPPORT=   user-destdir
                      7:
1.1       uebayasi    8: # mips has no TAS implementation
                      9: NOT_FOR_PLATFORM=      *-*-mips
                     10:
1.2       martti     11: .include "../../databases/postgresql81/Makefile.common"
1.1       uebayasi   12:
                     13: # Use shlibtool (invoked as "$(LIBTOOL)") to build modules.
                     14: USE_LIBTOOL=           yes
                     15: PKG_LIBTOOL=           ${PKG_SHLIBTOOL}
                     16:
                     17: MESSAGE_SRC=           ${.CURDIR}/MESSAGE
                     18:
                     19: CONFIGURE_ARGS+=       --with-openssl
                     20:
1.7     ! adam       21: BUILD_DIRS=    src/backend
        !            22: BUILD_DIRS+=   src/backend/utils/mb/conversion_procs
        !            23: BUILD_DIRS+=   src/timezone
        !            24: BUILD_DIRS+=   src/pl
1.1       uebayasi   25:
                     26: # PostgreSQL has loadable server-side language modules.
                     27: #
                     28: # Explicitly set DLOPEN_REQUIRE_PTHREADS to "no" on NetBSD as NetBSD-2.x
                     29: # had problems with mixing dlopen() and pthreads, which blows up in
                     30: # PostgreSQL's backend (pkg/28729).  This works on older and newer
                     31: # versions of NetBSD as well since they don't have the bad interaction
                     32: # between dlopen() and pthreads.
                     33: #
                     34: .if ${OPSYS} == "NetBSD"
                     35: DLOPEN_REQUIRE_PTHREADS=       no
                     36: .endif
                     37: .include "../../mk/dlopen.buildlink3.mk"
                     38:
                     39: # If we're using libltdl to provide "dlopen" functionality, then add the
                     40: # dependency and make sure that we link against -lltdl.
                     41: #
                     42: .if !empty(USE_LIBLTDL:M[yY][eE][sS])
                     43: DL_LIBS+=      -lltdl
                     44: .  include "../../devel/libltdl/buildlink3.mk"
                     45: .endif
                     46:
                     47: PKG_OPTIONS_VAR=       PKG_OPTIONS.postgresql81-server
                     48: PKG_SUPPORTED_OPTIONS= pam
1.2       martti     49: .include "../../databases/postgresql81/options.mk"
1.1       uebayasi   50:
                     51: # PGUSER       username of the database administrator
                     52: # PGGROUP      group of the database administrator
                     53: # PGHOME       home directory of the database administrator and location of
                     54: #              the databases
                     55: #
                     56: PGUSER?=               pgsql
                     57: PGGROUP?=              pgsql
                     58: PGHOME?=               ${PREFIX}/${PGUSER}
                     59: FILES_SUBST+=          PGUSER=${PGUSER}
                     60: FILES_SUBST+=          PGGROUP=${PGGROUP}
                     61: FILES_SUBST+=          PGHOME=${PGHOME}
                     62: BUILD_DEFS+=           PGUSER PGGROUP PGHOME
                     63:
                     64: PKG_GROUPS=            ${PGGROUP}
1.4       jlam       65: PKG_USERS=             ${PGUSER}:${PGGROUP}
                     66: PKG_GECOS.${PGUSER}=   PostgreSQL database administrator
                     67: PKG_HOME.${PGUSER}=    ${PGHOME}
                     68: PKG_SHELL.${PGUSER}=   ${SH}
1.1       uebayasi   69:
                     70: RCD_SCRIPTS=           pgsql
                     71:
1.2       martti     72: .include "../../databases/postgresql81-client/buildlink3.mk"
1.1       uebayasi   73: .include "../../security/openssl/buildlink3.mk"
                     74:
                     75: # Avoid conflict between "${SSLBASE}/include/openssl/des.h" and
                     76: # "/usr/include/crypt.h" -- we want the definitions in the former.
                     77: #
                     78: post-wrapper:
                     79: .if ${OPSYS} == "SunOS"
1.5       adam       80:        touch ${BUILDLINK_DIR}/include/crypt.h
1.1       uebayasi   81: .endif
                     82:
                     83: pre-build:
                     84:        ${_PKG_SILENT}${_PKG_DEBUG}${_ULIMIT_CMD}                       \
                     85:        cd ${WRKSRC}/src/backend &&                                     \
1.5       adam       86:        env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS}     \
1.1       uebayasi   87:                ../../src/include/parser/parse.h                        \
                     88:                ../../src/include/utils/fmgroids.h
                     89:        ${_PKG_SILENT}${_PKG_DEBUG}${_ULIMIT_CMD}                       \
                     90:        cd ${WRKSRC}/src/port &&                                        \
1.5       adam       91:                env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS}
1.1       uebayasi   92:
                     93: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>