[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql81-server

Annotation of pkgsrc/databases/postgresql81-server/Makefile, Revision 1.11

1.11    ! rillig      1: # $NetBSD: Makefile,v 1.10 2008/06/20 08:27:58 adam Exp $
1.1       uebayasi    2:
                      3: PKGNAME=       postgresql81-server-${BASE_VERS}
                      4: COMMENT=       PostgreSQL database server programs
                      5:
1.6       joerg       6: PKG_DESTDIR_SUPPORT=   user-destdir
                      7:
1.1       uebayasi    8: # mips has no TAS implementation
                      9: NOT_FOR_PLATFORM=      *-*-mips
                     10:
1.2       martti     11: .include "../../databases/postgresql81/Makefile.common"
1.1       uebayasi   12:
                     13: # Use shlibtool (invoked as "$(LIBTOOL)") to build modules.
                     14: USE_LIBTOOL=           yes
                     15: PKG_LIBTOOL=           ${PKG_SHLIBTOOL}
                     16:
                     17: MESSAGE_SRC=           ${.CURDIR}/MESSAGE
                     18:
                     19: CONFIGURE_ARGS+=       --with-openssl
                     20:
1.7       adam       21: BUILD_DIRS=    src/backend
                     22: BUILD_DIRS+=   src/backend/utils/mb/conversion_procs
                     23: BUILD_DIRS+=   src/timezone
                     24: BUILD_DIRS+=   src/pl
1.1       uebayasi   25:
                     26: # PostgreSQL has loadable server-side language modules.
                     27: #
                     28: # Explicitly set DLOPEN_REQUIRE_PTHREADS to "no" on NetBSD as NetBSD-2.x
                     29: # had problems with mixing dlopen() and pthreads, which blows up in
                     30: # PostgreSQL's backend (pkg/28729).  This works on older and newer
                     31: # versions of NetBSD as well since they don't have the bad interaction
                     32: # between dlopen() and pthreads.
                     33: #
                     34: .if ${OPSYS} == "NetBSD"
                     35: DLOPEN_REQUIRE_PTHREADS=       no
                     36: .endif
                     37: .include "../../mk/dlopen.buildlink3.mk"
                     38:
                     39: # If we're using libltdl to provide "dlopen" functionality, then add the
                     40: # dependency and make sure that we link against -lltdl.
                     41: #
                     42: .if !empty(USE_LIBLTDL:M[yY][eE][sS])
                     43: DL_LIBS+=      -lltdl
                     44: .  include "../../devel/libltdl/buildlink3.mk"
                     45: .endif
                     46:
                     47: PKG_OPTIONS_VAR=       PKG_OPTIONS.postgresql81-server
                     48: PKG_SUPPORTED_OPTIONS= pam
1.2       martti     49: .include "../../databases/postgresql81/options.mk"
1.1       uebayasi   50:
                     51: # PGUSER       username of the database administrator
                     52: # PGGROUP      group of the database administrator
                     53: # PGHOME       home directory of the database administrator and location of
                     54: #              the databases
                     55: #
                     56: PGUSER?=               pgsql
                     57: PGGROUP?=              pgsql
                     58: PGHOME?=               ${PREFIX}/${PGUSER}
                     59: FILES_SUBST+=          PGUSER=${PGUSER}
                     60: FILES_SUBST+=          PGGROUP=${PGGROUP}
                     61: FILES_SUBST+=          PGHOME=${PGHOME}
1.8       jlam       62: BUILD_DEFS+=           PGHOME
                     63:
                     64: PKG_GROUPS_VARS+=      PGGROUP
                     65: PKG_USERS_VARS+=       PGUSER
1.1       uebayasi   66:
                     67: PKG_GROUPS=            ${PGGROUP}
1.4       jlam       68: PKG_USERS=             ${PGUSER}:${PGGROUP}
                     69: PKG_GECOS.${PGUSER}=   PostgreSQL database administrator
                     70: PKG_HOME.${PGUSER}=    ${PGHOME}
                     71: PKG_SHELL.${PGUSER}=   ${SH}
1.1       uebayasi   72:
                     73: RCD_SCRIPTS=           pgsql
                     74:
1.2       martti     75: .include "../../databases/postgresql81-client/buildlink3.mk"
1.1       uebayasi   76: .include "../../security/openssl/buildlink3.mk"
                     77:
                     78: # Avoid conflict between "${SSLBASE}/include/openssl/des.h" and
                     79: # "/usr/include/crypt.h" -- we want the definitions in the former.
                     80: #
                     81: post-wrapper:
                     82: .if ${OPSYS} == "SunOS"
1.5       adam       83:        touch ${BUILDLINK_DIR}/include/crypt.h
1.1       uebayasi   84: .endif
                     85:
                     86: pre-build:
1.11    ! rillig     87:        ${RUN} ${_ULIMIT_CMD}                                           \
1.1       uebayasi   88:        cd ${WRKSRC}/src/backend &&                                     \
1.11    ! rillig     89:        env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS}             \
1.1       uebayasi   90:                ../../src/include/parser/parse.h                        \
                     91:                ../../src/include/utils/fmgroids.h
1.11    ! rillig     92:        ${RUN} ${_ULIMIT_CMD}                                           \
1.1       uebayasi   93:        cd ${WRKSRC}/src/port &&                                        \
1.5       adam       94:                env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS}
1.1       uebayasi   95:
                     96: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>