[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql81-client

Annotation of pkgsrc/databases/postgresql81-client/Makefile, Revision 1.11

1.11    ! wiz         1: # $NetBSD: Makefile,v 1.10 2009/05/16 07:22:01 rillig Exp $
1.1       uebayasi    2:
                      3: PKGNAME=       postgresql81-client-${BASE_VERS}
1.11    ! wiz         4: PKGREVISION=   1
1.1       uebayasi    5: COMMENT=       PostgreSQL database client programs
                      6:
1.5       joerg       7: PKG_DESTDIR_SUPPORT=   user-destdir
                      8:
1.2       martti      9: .include "../../databases/postgresql81/Makefile.common"
1.1       uebayasi   10:
                     11: USE_TOOLS+=            gzip tar
                     12: USE_LIBTOOL=           yes
                     13: CONFIGURE_ARGS+=       --with-openssl
                     14: CONFIGURE_ARGS+=       --with-readline
                     15: CONFIGURE_ARGS+=       --with-zlib
                     16:
1.6       adam       17: CONFLICTS+=    postgresql81-lib-[0-9]*
                     18: CONFLICTS+=    postgresql81-docs-[0-9]*
1.1       uebayasi   19:
                     20: # 1. The thread-safety test in ${WRSRC}/src/tools/thread does not pass on
1.7       rmind      21: # NetBSD earler than 4.0 or DragonFly.
1.1       uebayasi   22: # 2. configure with --enable-thread-safety fails on OpenBSD.
                     23: #
1.7       rmind      24: .if (${OPSYS} == "NetBSD" && !empty(OS_VERSION:M[0-3].*)) || \
                     25:     ${OPSYS} == "DragonFly" || ${OPSYS} == "OpenBSD"
1.1       uebayasi   26: PGSQL_THREAD_SAFETY?=  no
                     27: .endif
                     28: PGSQL_THREAD_SAFETY?=  yes
                     29: BUILD_DEFS+=           PGSQL_THREAD_SAFETY
                     30:
                     31: .if !empty(PGSQL_THREAD_SAFETY:M[yY][eE][sS])
                     32: .  include "../../mk/pthread.buildlink3.mk"
                     33: .  if (${PTHREAD_TYPE} == "native")
                     34: CONFIGURE_ARGS+=       --enable-thread-safety
                     35: .  endif
                     36: .endif
                     37:
1.6       adam       38: INSTALL_DIRS=  src/include
                     39: INSTALL_DIRS+= src/interfaces
1.9       adam       40: INSTALL_DIRS+= src/port
1.6       adam       41: INSTALL_DIRS+= src/bin
                     42: INSTALL_DIRS+= doc
1.1       uebayasi   43:
                     44: BUILD_DIRS=    ${INSTALL_DIRS}
                     45:
                     46: # Without this, the Darwin build fails (related to -bundle_loader).
1.6       adam       47: BUILD_DIRS+=   src/backend
1.1       uebayasi   48:
                     49: PKG_OPTIONS_VAR=       PKG_OPTIONS.postgresql81-client
1.2       martti     50: .include "../../databases/postgresql81/options.mk"
1.1       uebayasi   51:
                     52: .for _file_ in pg_service.conf psqlrc
                     53: CONF_FILES+=   ${PG_DATA_DIR}/${_file_}.sample ${PG_ETC_DIR}/${_file_}
                     54: .endfor
                     55: .if !empty(PG_SUBPREFIX)
                     56: PLIST_SUBST+=  PG_DIRRM_SUBPREFIX="@dirrm ${PG_SUBPREFIX}"
                     57: .else
                     58: PLIST_SUBST+=  PG_DIRRM_SUBPREFIX="@comment empty line"
                     59: .endif
                     60:
                     61: # XXX work around core dumps with the native libedit
                     62: USE_GNU_READLINE=      yes
                     63:
                     64: .include "../../devel/readline/buildlink3.mk"
                     65: .include "../../devel/zlib/buildlink3.mk"
                     66: .include "../../security/openssl/buildlink3.mk"
                     67:
                     68: # On Solaris, avoid conflicts between "${SSLBASE}/include/openssl/des.h"
                     69: # and "/usr/include/crypt.h" -- we want the definitions in the former.
                     70: #
                     71: .if ${OPSYS} == "SunOS"
                     72: post-wrapper:
1.4       adam       73:        touch ${BUILDLINK_DIR}/include/crypt.h
1.1       uebayasi   74: .endif
                     75:
                     76: pre-build:
1.10      rillig     77:        ${RUN} ${_ULIMIT_CMD}                                           \
1.1       uebayasi   78:        cd ${WRKSRC}/src/backend &&                                     \
1.10      rillig     79:        env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS}             \
1.1       uebayasi   80:                ../../src/include/parser/parse.h                        \
                     81:                ../../src/include/utils/fmgroids.h
                     82:
                     83: post-install:
                     84:        cd ${WRKSRC}/doc; for file in                                   \
                     85:                FAQ* KNOWN_BUGS MISSING_FEATURES README.* TODO          \
                     86:                bug.template;                                           \
                     87:        do                                                              \
1.10      rillig     88:                ${INSTALL_DATA} $$file ${DESTDIR}${PG_DOC_DIR}/$$file;  \
1.1       uebayasi   89:         done
1.5       joerg      90:        cp -R ${WRKSRC}/doc/TODO.detail ${DESTDIR}${PG_DOC_DIR}
                     91:        chown -R ${DOCOWN}:${DOCGRP} ${DESTDIR}${PG_DOC_DIR}/TODO.detail
1.1       uebayasi   92:
                     93: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>