[BACK]Return to buildlink3.mk CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / postgresql-postgis2

File: [cvs.NetBSD.org] / pkgsrc / databases / postgresql-postgis2 / buildlink3.mk (download)

Revision 1.13, Sun Oct 4 00:08:38 2020 UTC (7 weeks, 6 days ago) by gdt
Branch: MAIN
Changes since 1.12: +3 -3 lines

postgis: Update to 3.0.2

pkgsrc changes: Adjust API_DEPENDS to 2.0.  I don't have a specific
reason, but the previous 1.4 is so ancient that accepting it defies
the Principle of Least Astonishment.

Note that regression tests crash, but in the same way as 3.0.1.
3.0.1, when committed, passed, and I believe this is about proj.

Upstream changes: Bug fixes

# $NetBSD: buildlink3.mk,v 1.13 2020/10/04 00:08:38 gdt Exp $

BUILDLINK_TREE+=	postgresql-postgis

.if !defined(POSTGRESQL_POSTGIS_BUILDLINK3_MK)
POSTGRESQL_POSTGIS_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.postgresql-postgis+=	postgresql${PGSQL_VERSION}-postgis>=2.0
BUILDLINK_ABI_DEPENDS.postgresql-postgis?=	postgresql${PGSQL_VERSION}-postgis>=2.5.3nb11
BUILDLINK_PKGSRCDIR.postgresql-postgis?=	../../databases/postgresql-postgis2

PGSQL_VERSIONS_ACCEPTED=	10 96 95

.include "../../geography/geos/buildlink3.mk"
.include "../../geography/proj/buildlink3.mk"
.include "../../mk/pgsql.buildlink3.mk"
.endif	# POSTGRESQL_POSTGIS_BUILDLINK3_MK

BUILDLINK_TREE+=	-postgresql-postgis