The NetBSD Project

CVS log for pkgsrc/databases/php-pdo_mysql/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / php-pdo_mysql

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.22 / (download) - annotate - [select for diffs], Fri Jul 2 15:21:35 2021 UTC (3 months, 2 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, HEAD
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

php-pdo_mysql: enable mysqlnd

Revision 1.21 / (download) - annotate - [select for diffs], Fri Jul 2 15:21:12 2021 UTC (3 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.20: +3 -18 lines
Diff to previous 1.20 (colored)

php-pdo_mysql: split options into options.mk

Revision 1.20 / (download) - annotate - [select for diffs], Wed Jun 23 20:33:09 2021 UTC (3 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.19: +2 -1 lines
Diff to previous 1.19 (colored)

Revbump for MySQL default change

Revision 1.19 / (download) - annotate - [select for diffs], Fri Jun 13 14:17:07 2014 UTC (7 years, 4 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.18: +13 -4 lines
Diff to previous 1.18 (colored)

Add optional support for mysqlnd (MySQL Native Driver). Removes the need to build against and link the mysql-client package.

Revision 1.18 / (download) - annotate - [select for diffs], Mon Apr 8 11:17:10 2013 UTC (8 years, 6 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.17: +1 -2 lines
Diff to previous 1.17 (colored)

Remove "Trailing empty lines." and/or "Trailing white-space."

Revision 1.17 / (download) - annotate - [select for diffs], Sat Mar 16 02:00:34 2013 UTC (8 years, 7 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.16: +1 -2 lines
Diff to previous 1.16 (colored)

Reset PKGREVISION by update of both php53 and php54.

Revision 1.16 / (download) - annotate - [select for diffs], Sat Mar 2 20:33:24 2013 UTC (8 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.15: +2 -1 lines
Diff to previous 1.15 (colored)

Bump PKGREVISION for mysql default change to 55.

Revision 1.15 / (download) - annotate - [select for diffs], Fri Oct 19 14:58:31 2012 UTC (8 years, 11 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.14: +1 -2 lines
Diff to previous 1.14 (colored)

Reset PKGREVISION by updating both php53 and php54.

Revision 1.14 / (download) - annotate - [select for diffs], Tue Oct 2 21:25:39 2012 UTC (9 years ago) by asau
Branch: MAIN
Changes since 1.13: +1 -2 lines
Diff to previous 1.13 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.13 / (download) - annotate - [select for diffs], Sat Sep 15 15:03:23 2012 UTC (9 years, 1 month ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.12: +2 -1 lines
Diff to previous 1.12 (colored)

Recursive bump from mysql51-client library changed to use openssl.

Revision 1.11.2.1 / (download) - annotate - [select for diffs], Thu Dec 23 10:10:55 2010 UTC (10 years, 9 months ago) by sbd
Branch: pkgsrc-2010Q3
Changes since 1.11: +1 -2 lines
Diff to previous 1.11 (colored) next main 1.12 (colored)

Pullup ticket #3312 - requested by taca
pkgsrc/lang/{php5,php53} security fixes

Revisions pulled up:
- pkgsrc/databases/php-mysql/Makefile		1.14
- pkgsrc/databases/php-mysqli/Makefile		1.3
- pkgsrc/databases/php-pdo_mysql/Makefile	1.12
- pkgsrc/lang/php5/Makefile			1.80, 1.81
- pkgsrc/lang/php5/Makefile.common		1.43, 1.44
- pkgsrc/lang/php5/distinfo			1.80, 1.81, 1.82
- pkgsrc/lang/php5/patches/patch-ak		1.8, deleted
- pkgsrc/lang/php5/patches/patch-bf		1.1, deleted
- pkgsrc/lang/php5/patches/patch-bg		1.1, deleted
- pkgsrc/lang/php53/Makefile			1.5, 1.6
- pkgsrc/lang/php53/Makefile.common		1.3
- pkgsrc/lang/php53/distinfo			1.7, 1.8
- pkgsrc/lang/php53/patches/patch-ab		1.3
- pkgsrc/lang/php53/patches/patch-am		1.1, deleted
- pkgsrc/lang/php53/patches/patch-an		1.1, deleted
- pkgsrc/lang/php53/patches/patch-ao		1.1, deleted
- pkgsrc/lang/php53/patches/patch-ap		1.1, deleted
- pkgsrc/lang/php53/patches/patch-aq		1.1, deleted
- pkgsrc/mail/php-imap/Makefile			1.21, 1.22
- pkgsrc/www/ap-php/Makefile			1.24
- pkgsrc/www/php-eaccelerator/Makefile		1.13

-------------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Thu Nov 25 03:43:50 UTC 2010

   Modified Files:
   	pkgsrc/lang/php53: Makefile distinfo
   Added Files:
   	pkgsrc/lang/php53/patches: patch-am patch-an patch-ao patch-ap patch-aq

   Log Message:
   - GC bug fix: http://svn.php.net/viewvc?view=revision&revision=303016
   - CVE-2010-3710 (a part of SA41724)
   	http://svn.php.net/viewvc?view=revision&revision=303779
   - CVE-2010-3870 (a part of SA41724)
   	http://svn.php.net/viewvc?view=revision&revision=304959
   - CVE-2010-4150 (php-imap)
   	http://svn.php.net/viewvc?view=revision&revision=305032
   - CVE-2010-4156 (SA42135)
   	http://svn.php.net/viewvc?view=revision&revision=305214

   Bump PKGREVISION.

-------------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Thu Nov 25 03:44:16 UTC 2010

   Modified Files:
   	pkgsrc/lang/php5: Makefile distinfo
   Added Files:
   	pkgsrc/lang/php5/patches: patch-ak patch-bf patch-bg

   Log Message:
   - CVE-2010-4150 (php-imap)
   	http://svn.php.net/viewvc?view=revision&revision=305032
   - CVE-2010-3710 (a part of SA41724)
   	http://svn.php.net/viewvc?view=revision&revision=303885
   - CVE-2010-3870 (a part of SA41724)
   	http://svn.php.net/viewvc?view=revision&revision=305055

   Bump PKGREVISION.

-------------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Thu Nov 25 03:45:19 UTC 2010

   Modified Files:
   	pkgsrc/mail/php-imap: Makefile

   Log Message:
   Bump REVISION since CVE-2010-4150 fix was added.

-------------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Mon Dec 13 13:15:46 UTC 2010

   Modified Files:
   	pkgsrc/lang/php5: Makefile Makefile.common distinfo
   Removed Files:
   	pkgsrc/lang/php5/patches: patch-ak patch-bf patch-bg

   Log Message:
   Update php5 package to 5.2.15 (PHP 5.2.15):

   The PHP development team would like to announce the immediate
   availability of PHP 5.2.15. This release marks the end of support for
   PHP 5.2. All users of PHP 5.2 are encouraged to upgrade to PHP 5.3.

   This release focuses on improving the security and stability of the
   PHP 5.2.x branch with a small number, of predominatly security fixes.

   Security Enhancements and Fixes in PHP 5.2.15:

   * Fixed extract() to do not overwrite $GLOBALS and $this when using
     EXTR_OVERWRITE.
   * Fixed crash in zip extract method (possible CWE-170).
   * Fixed a possible double free in imap extension.
   * Fixed possible flaw in open_basedir (CVE-2010-3436).
   * Fixed NULL pointer dereference in
     ZipArchive::getArchiveComment. (CVE-2010-3709).
   * Fixed bug #52929 (Segfault in filter_var with FILTER_VALIDATE_EMAIL with
     large amount of data).

   Key enhancements in PHP 5.2.15 include:

   * Fixed bug #47643 (array_diff() takes over 3000 times longer than php
     5.2.4).
   * Fixed bug #44248 (RFC2616 transgression while HTTPS request through proxy
     with SoapClient object).
   * To prepare for upgrading to PHP 5.3, now that PHP 5.2's support ended, a
     migration guide available on http://php.net/migration53, details the changes
     between PHP 5.2 and PHP 5.3.

   For a full list of changes in PHP 5.2.15 see the ChangeLog at
   http://www.php.net/ChangeLog-5.php#5.2.15.

-------------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Mon Dec 13 13:16:37 UTC 2010

   Modified Files:
   	pkgsrc/lang/php53: Makefile Makefile.common distinfo
   	pkgsrc/lang/php53/patches: patch-ab
   Removed Files:
   	pkgsrc/lang/php53/patches: patch-am patch-an patch-ao patch-ap patch-aq

   Log Message:
   Update lang/php53 package to 5.3.4 (PHP 5.3.4).

   The PHP development team is proud to announce the immediate release of PHP
   5.3.4. This is a maintenance release in the 5.3 series, which includes a large
   number of bug fixes.

   Security Enhancements and Fixes in PHP 5.3.4:

   * Fixed crash in zip extract method (possible CWE-170).
   * Paths with NULL in them (foo\0bar.txt) are now considered as invalid
     (CVE-2006-7243).
   * Fixed a possible double free in imap extension (Identified by Mateusz
     Kocielski). (CVE-2010-4150).
   * Fixed NULL pointer dereference in
     ZipArchive::getArchiveComment. (CVE-2010-3709).
   * Fixed possible flaw in open_basedir (CVE-2010-3436).
   * Fixed MOPS-2010-24, fix string validation. (CVE-2010-2950).
   * Fixed symbolic resolution support when the target is a DFS share.
   * Fixed bug #52929 (Segfault in filter_var with FILTER_VALIDATE_EMAIL with
     large amount of data) (CVE-2010-3710).

   Key Bug Fixes in PHP 5.3.4 include:

   * Added stat support for zip stream.
   * Added follow_location (enabled by default) option for the http stream
     support.
   * Added a 3rd parameter to get_html_translation_table. It now takes a charset
     hint, like htmlentities et al.
   * Implemented FR #52348, added new constant ZEND_MULTIBYTE to detect zend
     multibyte at runtime.
   * Multiple improvements to the FPM SAPI.
   * Over 100 other bug fixes.

   For users upgrading from PHP 5.2 there is a migration guide available here,
   detailing the changes between those releases and PHP 5.3.

   For a full list of changes in PHP 5.3.4, see the ChangeLog. For source
   downloads please visit our downloads page, Windows binaries can be found on
   windows.php.net/download/.

-------------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Mon Dec 13 13:18:20 UTC 2010

   Modified Files:
   	pkgsrc/databases/php-mysql: Makefile
   	pkgsrc/databases/php-mysqli: Makefile
   	pkgsrc/databases/php-pdo_mysql: Makefile
   	pkgsrc/mail/php-imap: Makefile
   	pkgsrc/www/ap-php: Makefile
   	pkgsrc/www/php-eaccelerator: Makefile

   Log Message:
   Reset PKGREVISION by update of base PHP version.

-------------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Thu Dec 16 14:20:45 UTC 2010

   Modified Files:
   	pkgsrc/lang/php5: Makefile.common distinfo

   Log Message:
   Update php5 pacakge to 5.2.16:

   PHP 5.2.16 Released!

   The PHP development team would like to announce the immediate availability of
   PHP 5.2.16. This release marks the end of support for PHP 5.2. All users of
   PHP 5.2 are encouraged to upgrade to PHP 5.3.

   This release focuses on addressing a regression in open_basedir implementation
   introduced in 5.2.15 in addition to fixing a crash inside PDO::pgsql on data
   retrieval when the server is down. All users who have upgraded to 5.2.15 and
   are utilizing open_basedir are strongly encouraged to upgrade to 5.2.16 or
   5.3.4.

   To prepare for upgrading to PHP 5.3, now that PHP 5.2's support ended, a
   migration guide available on http://php.net/migration53, details the changes
   between PHP 5.2 and PHP 5.3.

   For a full list of changes in PHP 5.2.16 see the ChangeLog at
   http://www.php.net/ChangeLog-5.php#5.2.16.

   ChangeLog:

   Version 5.2.16

   16-Dec-2010

   * Fixed bug #53517 (segfault in pgsql_stmt_execute() when postgres is
     down). (gyp at balabit dot hu)
   * Fixed bug #53516 (Regression in open_basedir handling). (Ilia)

Revision 1.12 / (download) - annotate - [select for diffs], Mon Dec 13 13:18:20 2010 UTC (10 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.11: +1 -2 lines
Diff to previous 1.11 (colored)

Reset PKGREVISION by update of base PHP version.

Revision 1.11 / (download) - annotate - [select for diffs], Thu Sep 30 10:49:15 2010 UTC (11 years ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2010Q3-base
Branch point for: pkgsrc-2010Q3
Changes since 1.10: +2 -1 lines
Diff to previous 1.10 (colored)

Bump PKGREVISION by default mysql version changed from 5.0 to 5.1.

Revision 1.10 / (download) - annotate - [select for diffs], Tue Mar 16 11:54:31 2010 UTC (11 years, 7 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.9: +1 -3 lines
Diff to previous 1.9 (colored)

Remove PHP_VERSIONS_ACCEPTED=5 from these pacakges since there is no php4 any more.

No functional change.

Revision 1.9 / (download) - annotate - [select for diffs], Wed Oct 7 05:00:58 2009 UTC (12 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.8: +1 -3 lines
Diff to previous 1.8 (colored)

Remove use of temporary workaround for version problem of php-pdo*
packages when they switched to use bundled files in php-5.2.9.

Now we don't need this workaround any more and code itself already
no operation.

No functional change.

Revision 1.8 / (download) - annotate - [select for diffs], Fri Mar 13 10:57:20 2009 UTC (12 years, 7 months ago) by sborrill
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.7: +13 -6 lines
Diff to previous 1.7 (colored)

The php_pdo* packages have not kept step with PHP changes. The PDO
components are now built into PHP rather than maintained separately in
PECL. The old PECL versions are unmaintained and haven't been altered
for 3 years. This is confusing as the package versions report themselves
to be 5.2.9.1.0.2, etc. but they are in fact based on the 5.1.x code-base.

Therefore, we need to switch to building the PDO modules like any other
PHP module.

A side-effect of this is that the PECL version number will get stripped
off the end meaning that the new version numbers are just 5.2.9 instead
of 5.2.9.1.0.2 (for example). Unfortunately, 5.2.9 is considered to be
older than 5.2.9.1.0.2 meaning that it will appear as though a downgrade
has taken place. Therefore, while we are still using PHP 5.2.9, add .99 on
the end (i.e. 5.2.9.99) so that the package appears newer. When PHP 5.2.10
is released this can be removed (the module.mk file explicitly cgecks for
5.2.9 before adding the .99 suffix so that it will not alter 5.2.10 if the
hack is forgotten. However, for the record, when 5.2.10 is released,
php-pdo/module.mk can be removed along with the references to it in each
php-pdo*/Makefile

Revision 1.7 / (download) - annotate - [select for diffs], Thu Mar 5 20:58:37 2009 UTC (12 years, 7 months ago) by joerg
Branch: MAIN
Changes since 1.6: +4 -1 lines
Diff to previous 1.6 (colored)

Don't abuse b3. It should not do things like include bsd.pkg.mk, so fix
up the packages that use it instead.

Revision 1.6 / (download) - annotate - [select for diffs], Thu Jun 12 02:14:19 2008 UTC (13 years, 4 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.5: +3 -1 lines
Diff to previous 1.5 (colored)

Add DESTDIR support.

Revision 1.5 / (download) - annotate - [select for diffs], Fri Jun 2 18:27:55 2006 UTC (15 years, 4 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.4: +1 -3 lines
Diff to previous 1.4 (colored)

Rename all PHP 4 packages to php4-*, all PHP 5 packages to php5-*,
all PEAR packages to php?-pear-* and all Apache packages to ap13-* or
ap2-* respectively. Add new variables to simplify the Makefile
handling. Add CONFLICTS on the old names. Reset revisions of bumped
packages. ap-php will now depend on the default Apache and PHP version.
All programs using it have an implicit option of the Apache version
as well.

OK from jlam@ and adrianp@.

Revision 1.4 / (download) - annotate - [select for diffs], Sun Feb 5 23:08:33 2006 UTC (15 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Jan 8 18:35:08 2006 UTC (15 years, 9 months ago) by xtraeme
Branch: MAIN
Changes since 1.2: +3 -1 lines
Diff to previous 1.2 (colored)

Bump PKGREVISION due to mysql.buildlink3.mk changes (default mysql
pkg has been changed to 5.x). Reminded by wiz... thanks.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Dec 3 17:24:28 2005 UTC (15 years, 10 months ago) by jdolecek
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.1: +5 -2 lines
Diff to previous 1.1 (colored)

Update the PHP PDO to latest available PECL versions (1.0/1.0.1/1.0.2).
Changes are bugfixes mostly.

Also rework php-pdo/module.mk somewhat, so that the base php-pdo package
can use it too.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sun Oct 9 13:11:18 2005 UTC (16 years ago) by jdolecek
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Add PDO (PHP Data Objects) extensions. These implement unified,
object-oriented interface to various databases. PDO comes bundled
with upcoming PHP 5.1, but can also be used with PHP 5.0 via PECL.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Oct 9 13:11:18 2005 UTC (16 years ago) by jdolecek
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>