[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / p5-DBD-SQLite

File: [cvs.NetBSD.org] / pkgsrc / databases / p5-DBD-SQLite / Makefile (download)

Revision 1.75, Thu Sep 12 23:59:55 2019 UTC (12 months, 2 weeks ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.74: +2 -3 lines

Update to 1.64

Upstream changes:
1.64 2019-08-12
    - Switched to a production version

1.63_05 2019-07-12
    - Upgraded SQLite to 3.29.0
    - Added sqlite_get_autocommit private method (GH#52)
    - Addded new db_config constants, notably to prohibit
      double-quoted string literals

1.63_04 2019-05-25
    - Upgraded SQLite to 3.28.0
    - Modified doc for sqlite_db_filename which actually returns undef
      or an empty string (GH#50)
    - Fixed ->quote($blob, SQL_BLOB) to quote correctly (GH#51, pali++)

1.63_03 2019-02-15
    - Applied a patch to fix segmentation fault on 32-bit big-endian
      platforms by Niko Tyni (GH#45)

1.63_02 2019-02-14
    - Upgraded SQLite to 3.27.1
    - Let a URI filename test skip if SQLite is compiled with URI filename
      support (GH#47)

1.63_01 2019-01-26
    - Made sure an internal hv is initialized (GH#45)
    - Fixed a number of tests to skip
    - Bumped up Test::More requirement
    - Replaced bundled Test::NoWarnings with Test::FailWarnings
    - Handle 'unknown' op in DBD::SQLite::VirtualTable::PerlData (Corion++)

# $NetBSD: Makefile,v 1.75 2019/09/12 23:59:55 wen Exp $

DISTNAME=	DBD-SQLite-1.64
PKGNAME=	p5-${DISTNAME}
CATEGORIES=	databases perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=DBD/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://metacpan.org/release/DBD-SQLite
COMMENT=	Perl DBI/DBD driver for sqlite databases (self contained)
LICENSE=	${PERL5_LICENSE}

USE_LANGUAGES=	c
PERL5_PACKLIST=	auto/DBD/SQLite/.packlist
MAKE_PARAMS+=	SQLITE_LOCATION=${BUILDLINK_PREFIX.sqlite3}

BUILDLINK_API_DEPENDS.p5-DBI+=	p5-DBI>=1.580
BUILDLINK_API_DEPENDS.sqlite3+=	sqlite3>=3.8.4.1

.include "../../databases/p5-DBI/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"