[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / p5-BerkeleyDB

File: [cvs.NetBSD.org] / pkgsrc / databases / p5-BerkeleyDB / Makefile (download)

Revision 1.7, Mon Nov 15 17:54:49 2004 UTC (19 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.6: +2 -2 lines

Rework the Berkeley DB detection in buildlink3:

  * Add a db1.builtin.mk file that detects whether DB-1.85 functionality
    exists in the base system, and remove the distinction between
    "native" and the other Berkeley DB packages -- we now refer to
    db[1234].  This paves the way for any future databases/db1 package.

  * USE_DB185 shouldn't need to be set by any packages -- its correct
    value is now automatically determined by bdb.buildlink3.mk depending
    on whether we explicitly request db1 or not.  By default, if you
    include bdb.buildlink3.mk, you want DB-1.85 functionality and
    USE_DB185 defaults to "yes", but if you explicitly remove db1 from
    the list of acceptable DBs, then USE_DB185 defaults to "no".

  * Set BDB_LIBS to the library options needed to link against the DB
    library when bdb.buildlink3.mk is included.

  * We only add the DB library to the linker command automatically if
    we want DB-1.85 functionality; otherwise assume that the package
    configure process can figure out how to probe for the correct
    headers and libraries.

Edit package Makefiles to nuke redundant settings of USE_DB185.

# $NetBSD: Makefile,v 1.7 2004/11/15 17:54:49 jlam Exp $
#

DISTNAME=	BerkeleyDB-0.25
PKGNAME=	p5-${DISTNAME}
SVR4_PKGNAME=	p5bdb
CATEGORIES=	databases perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=BerkeleyDB/}

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://search.cpan.org/dist/BerkeleyDB/
COMMENT=	Access Berkeley DB

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_BUILDLINK3=		YES
BDB_ACCEPTED=		db4 db3 db2
PERL5_REQD+=		5.6.0
PERL5_PACKLIST=		${PERL5_SITEARCH}/auto/BerkeleyDB/.packlist

MAKE_ENV+=	BERKELEYDB_INCLUDE="${BDBBASE}/include"
MAKE_ENV+=	BERKELEYDB_LIB="${BDBBASE}/lib"
MAKE_ENV+=	BERKELEYDB_NAME="${BDB_LIBS}"

.include "../../mk/bdb.buildlink3.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"