[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / openldap

File: [cvs.NetBSD.org] / pkgsrc / databases / openldap / Makefile.common (download)

Revision 1.16, Mon Jun 9 09:07:38 2008 UTC (15 years, 9 months ago) by ghen
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper
Changes since 1.15: +2 -2 lines

Update openldap packages to 2.4.9.  Reviewed by tron.

OpenLDAP 2.4.9 Release (2008/05/07)
	Fixed libldap to use unsigned port (ITS#5436)
	Fixed libldap error message for missing close paren (ITS#5458)
	Fixed libldap_r tpool pause checks (ITS#5364, #5407)
	Fixed slapcat error checking (ITS#5387)
	Fixed slapd abstract objectClass inheritance check (ITS#5474)
	Fixed slapd add operations requiring naming attrs (ITS#5412)
	Fixed slapd connection handling (ITS#5469)
	Fixed slapd delta-syncrepl resync (ITS#5378)
	Fixed slapd frontendDB backend selection (ITS#5419)
	Fixed slapd pagedresults stale state (ITS#5409)
	Fixed slapd pointer dereference (ITS#5388)
	Fixed slapd null argument dereference (ITS#5435)
	Fixed slapd REP_ENTRY flags (ITS#5340)
	Fixed slapd sets attribute description parsing (ITS#5402)
	Fixed slapd syncrepl hang on back-config (ITS#5407)
	Fixed slapd syncrepl compare_csns crash (ITS#5413)
	Fixed slapd syncrepl contextCSN update clash (ITS#5426)
	Fixed slapd syncrepl/glue failure (ITS#5430)
	Fixed slapd syncrepl crash on empty CSN (ITS#5432)
	Fixed slapd syncrepl refreshAndPersist (ITS#5454)
	Fixed slapd syncrepl modrdn processing (ITS#5397)
	Fixed slapd syncrepl MMR partial refresh (ITS#5470)
	Fixed slapd value list termination (ITS#5450)
	Fixed slapd/slapo-accesslog rq mutex usage (ITS#5442)
	Fixed slapd-bdb ID_NOCACHE handling (ITS#5439)
	Fixed slapd-bdb entryinfo state if db_lock fails (ITS#5455)
	Fixed slapd-bdb referral rewrite (ITS#5339)
	Fixed slapd-config overlay stacking (ITS#5346)
	Fixed slapd-config attribute publishing (ITS#5383)
	Fixed slapd-ldap connection handler (ITS#5404)
	Fixed slapd-ldif file name handling & multi-suffix/dir catch (ITS#5408)
	Fixed slapd-meta connections on error (ITS#5440)
	Fixed slapd-meta crash on search (ITS#5481)
	Fixed slapo-accesslog null callback stack crash (ITS#5490)
	Fixed slapo-auditlog unnecessary syscall (ITS#5441)
	Added slapo-dynlist mapping to dynamic attrs generation (ITS#5466)
	Fixed slapo-refint dnSubtreeMatch (ITS#5427)
	Fixed slapo-refint global referential integrity (ITS#5428)
	Fixed slapo-syncprov psearch on closed connection (ITS#5401)
	Fixed slapo-syncprov psearch task delay (ITS#5405)
	Fixed slapo-syncprov psearch filter identity (ITS#5418, #5486)
	Fixed slapo-syncprov/glue contextCSN update (ITS#5433)
	Fixed slapo-syncprov/glue search ops (ITS#5434)
	Fixed slapo-syncprov null cookie (ITS#5437,#5444)
	Fixed slapo-syncprov double-free (ITS#5445)
	Fixed slapo-syncprov free syncop correctly (ITS#5484)
	Fixed slapo-syncprov glue deadlock (ITS#5451)
	Build Environment
		Fixed leave function naming for OSF1 (ITS#5411)
	Documentation
		Fixed slapd.access(5) authz-regexp documented behavior (ITS#5400)
		Fixed slapd.meta(5) idassert-* documentation (ITS#5406)
		admin24 delta-syncrepl documentation (ITS#5476)
		admin24 set documentation (ITS#5278,ITS#5279,ITS#5281)
		admin24 slapo-ppolicy documentation (ITS#5479)
		admin24 syncrepl directives update (ITS#5425)

# $NetBSD: Makefile.common,v 1.16 2008/06/09 09:07:38 ghen Exp $

# please stick to the "stable" releases as much as possible!
DISTNAME=		openldap-2.4.9
CATEGORIES=		databases
MASTER_SITES=		ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/
MASTER_SITES+=		http://www.openldap.org/software/download/OpenLDAP/openldap-release/
MASTER_SITES+=		http://www.PlanetMirror.com/pub/openldap/openldap-release/
MASTER_SITES+=		ftp://gd.tuwien.ac.at/infosys/network/OpenLDAP/openldap-release/
MASTER_SITES+=		ftp://ftp.matrix.com.br/pub/openldap/openldap-release/
MASTER_SITES+=		ftp://ftp.ucr.ac.cr/pub/Unix/openldap/openldap-release/
MASTER_SITES+=		ftp://ftp.ntua.gr/mirror/OpenLDAP/openldap-release/
MASTER_SITES+=		ftp://it.openldap.org/pub/OpenLDAP/openldap-release/
MASTER_SITES+=		ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/openldap-release/
MASTER_SITES+=		ftp://ftp.u-aizu.ac.jp/pub/net/openldap/openldap-release/
MASTER_SITES+=		ftp://ftp.holywar.net/pub/OpenLDAP/openldap-release/
MASTER_SITES+=		ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/
MASTER_SITES+=		ftp://ftp.linux.pt/pub/mirrors/OpenLDAP/openldap-release/
MASTER_SITES+=		ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/
MASTER_SITES+=		ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
EXTRACT_SUFX=		.tgz

MAINTAINER=		ghen@NetBSD.org
HOMEPAGE=		http://www.openldap.org/

CONFLICTS+=		ldapsdk-[0-9]*

DISTINFO_FILE=		${.CURDIR}/../../databases/openldap/distinfo
PATCHDIR=		${.CURDIR}/../../databases/openldap/patches
FILESDIR=		${.CURDIR}/../../databases/openldap/files

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes

MAKE_ENV+=		LIBMODE=${LIBMODE:Q}

.include "../../mk/bsd.prefs.mk"

OPENLDAP_ETCDIR?=	${PKG_SYSCONFDIR}/openldap
OPENLDAP_MODULEDIR=	${PREFIX}/lib/openldap
OPENLDAP_VARDIR?=	${VARBASE}/openldap

SLAPD_USER?=		slapd
LDAP_GROUP?=		ldap

PKG_GROUPS_VARS+=	LDAP_GROUP
PKG_USERS_VARS+=	SLAPD_USER

# the internal avl_* prototypes conflict with those in <sys/avl.h> which
# is included by another system header file on Solaris, so subst them.
.if ${OPSYS} == "SunOS"
SUBST_CLASSES+=		conflict
SUBST_STAGE.conflict=	post-patch
SUBST_FILES.conflict=	${WRKSRC}/*/*.h
SUBST_FILES.conflict+=	${WRKSRC}/*/*/*.c ${WRKSRC}/*/*/*/*.c
SUBST_SED.conflict+=	-e 's,avl_free,openldap_avl_free,g'
SUBST_SED.conflict+=	-e 's,avl_insert,openldap_avl_insert,g'
SUBST_SED.conflict+=	-e 's,avl_delete,openldap_avl_delete,g'
SUBST_SED.conflict+=	-e 's,avl_find,openldap_avl_find,g'
SUBST_SED.conflict+=	-e 's,avl_find2,openldap_avl_find2,g'
SUBST_MESSAGE.conflict=	Fixing conflicting function prototypes.
.endif

CPPFLAGS.Darwin+=	-DBIND_8_COMPAT

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--localstatedir=${OPENLDAP_VARDIR:Q}
CONFIGURE_ARGS+=	--enable-dynamic
CONFIGURE_ARGS+=	--with-tls=openssl

EGDIR=			${PREFIX}/share/examples/openldap

CONF_FILES=		# empty
CONF_FILES_PERMS=	# empty
.for FILE in ${CNFS}
CONF_FILES+=		${EGDIR}/${FILE:Q} ${OPENLDAP_ETCDIR}/${FILE:Q}
.endfor
.for FILE in ${CNFS_PERMS}
CONF_FILES_PERMS+=	${EGDIR}/${FILE:Q} ${OPENLDAP_ETCDIR}/${FILE:Q} ${OPENLDAP_FILEPERMS}
.endfor

DB_CONFIG?=		# empty

PTHREAD_OPTS+=		require

.include "../../security/openssl/buildlink3.mk"
.include "../../security/tcp_wrappers/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

.if ${PTHREAD_TYPE} == "native"
CONFIGURE_ARGS+=	--with-threads
.elif ${PTHREAD_TYPE} == "pth"
CONFIGURE_ARGS+=	--with-threads=pth

#
# Don't use a larger FD_SETSIZE than GNU Pth can handle (value taken from
# pth.h header).
#
PTH_FDSETSIZE_cmd=							\
	if ${TEST} -f ${BUILDLINK_PREFIX.pth:Q}/include/pth.h; then	\
		${AWK} '/if FD_SETSIZE >/ { print $$4 }'		\
			${BUILDLINK_PREFIX.pth}/include/pth.h;		\
	else								\
		${ECHO} 0;						\
	fi
CPPFLAGS+=	-DOPENLDAP_FD_SETSIZE=${PTH_FDSETSIZE_cmd:sh:Q}
.endif

MAKE_FLAGS+=		moduledir=${OPENLDAP_MODULEDIR:Q}
INSTALL_MAKE_FLAGS=	${MAKE_FLAGS} sysconfdir=${EGDIR:Q}

# Set the correct file modes for the example config files.
post-install:
.for file in ${CNFS} ${CNFS_PERMS} ${DB_CONFIG}
	${CHMOD} ${SHAREMODE} ${DESTDIR}${EGDIR}/${file:Q}
	${RM} -f ${DESTDIR}${EGDIR}/${file:Q}.default
.endfor