[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / openldap

Annotation of pkgsrc/databases/openldap/Makefile.common, Revision 1.24

1.24    ! ghen        1: # $NetBSD: Makefile.common,v 1.23 2009/10/21 16:25:01 tnn Exp $
1.1       ghen        2:
1.3       ghen        3: # please stick to the "stable" releases as much as possible!
1.24    ! ghen        4: DISTNAME=              openldap-2.4.19
1.1       ghen        5: CATEGORIES=            databases
                      6: MASTER_SITES=          ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/
1.12      dsainty     7: MASTER_SITES+=         http://www.openldap.org/software/download/OpenLDAP/openldap-release/
1.6       ghen        8: MASTER_SITES+=         http://www.PlanetMirror.com/pub/openldap/openldap-release/
                      9: MASTER_SITES+=         ftp://gd.tuwien.ac.at/infosys/network/OpenLDAP/openldap-release/
                     10: MASTER_SITES+=         ftp://ftp.ucr.ac.cr/pub/Unix/openldap/openldap-release/
                     11: MASTER_SITES+=         ftp://ftp.ntua.gr/mirror/OpenLDAP/openldap-release/
                     12: MASTER_SITES+=         ftp://it.openldap.org/pub/OpenLDAP/openldap-release/
                     13: MASTER_SITES+=         ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/openldap-release/
                     14: MASTER_SITES+=         ftp://ftp.u-aizu.ac.jp/pub/net/openldap/openldap-release/
                     15: MASTER_SITES+=         ftp://ftp.holywar.net/pub/OpenLDAP/openldap-release/
                     16: MASTER_SITES+=         ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/
                     17: MASTER_SITES+=         ftp://ftp.linux.pt/pub/mirrors/OpenLDAP/openldap-release/
                     18: MASTER_SITES+=         ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/
                     19: MASTER_SITES+=         ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
1.1       ghen       20: EXTRACT_SUFX=          .tgz
                     21:
                     22: MAINTAINER=            ghen@NetBSD.org
                     23: HOMEPAGE=              http://www.openldap.org/
                     24:
                     25: CONFLICTS+=            ldapsdk-[0-9]*
                     26:
                     27: DISTINFO_FILE=         ${.CURDIR}/../../databases/openldap/distinfo
                     28: PATCHDIR=              ${.CURDIR}/../../databases/openldap/patches
                     29: FILESDIR=              ${.CURDIR}/../../databases/openldap/files
                     30:
                     31: USE_LIBTOOL=           yes
1.23      tnn        32: USE_TOOLS+=            soelim
1.1       ghen       33: GNU_CONFIGURE=         yes
                     34:
                     35: MAKE_ENV+=             LIBMODE=${LIBMODE:Q}
                     36:
                     37: .include "../../mk/bsd.prefs.mk"
                     38:
                     39: OPENLDAP_ETCDIR?=      ${PKG_SYSCONFDIR}/openldap
                     40: OPENLDAP_MODULEDIR=    ${PREFIX}/lib/openldap
                     41: OPENLDAP_VARDIR?=      ${VARBASE}/openldap
                     42:
                     43: SLAPD_USER?=           slapd
                     44: LDAP_GROUP?=           ldap
                     45:
1.9       jlam       46: PKG_GROUPS_VARS+=      LDAP_GROUP
1.14      ghen       47: PKG_USERS_VARS+=       SLAPD_USER
1.9       jlam       48:
1.1       ghen       49: # the internal avl_* prototypes conflict with those in <sys/avl.h> which
                     50: # is included by another system header file on Solaris, so subst them.
                     51: .if ${OPSYS} == "SunOS"
                     52: SUBST_CLASSES+=                conflict
                     53: SUBST_STAGE.conflict=  post-patch
                     54: SUBST_FILES.conflict=  ${WRKSRC}/*/*.h
                     55: SUBST_FILES.conflict+= ${WRKSRC}/*/*/*.c ${WRKSRC}/*/*/*/*.c
                     56: SUBST_SED.conflict+=   -e 's,avl_free,openldap_avl_free,g'
                     57: SUBST_SED.conflict+=   -e 's,avl_insert,openldap_avl_insert,g'
                     58: SUBST_SED.conflict+=   -e 's,avl_delete,openldap_avl_delete,g'
                     59: SUBST_SED.conflict+=   -e 's,avl_find,openldap_avl_find,g'
                     60: SUBST_SED.conflict+=   -e 's,avl_find2,openldap_avl_find2,g'
                     61: SUBST_MESSAGE.conflict=        Fixing conflicting function prototypes.
                     62: .endif
                     63:
                     64: CPPFLAGS.Darwin+=      -DBIND_8_COMPAT
1.22      tnn        65: CPPFLAGS.Linux+=       -D_GNU_SOURCE
1.1       ghen       66:
                     67: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR:Q}
                     68: CONFIGURE_ARGS+=       --localstatedir=${OPENLDAP_VARDIR:Q}
                     69: CONFIGURE_ARGS+=       --enable-dynamic
                     70: CONFIGURE_ARGS+=       --with-tls=openssl
                     71:
                     72: EGDIR=                 ${PREFIX}/share/examples/openldap
                     73:
                     74: CONF_FILES=            # empty
                     75: CONF_FILES_PERMS=      # empty
                     76: .for FILE in ${CNFS}
                     77: CONF_FILES+=           ${EGDIR}/${FILE:Q} ${OPENLDAP_ETCDIR}/${FILE:Q}
                     78: .endfor
                     79: .for FILE in ${CNFS_PERMS}
                     80: CONF_FILES_PERMS+=     ${EGDIR}/${FILE:Q} ${OPENLDAP_ETCDIR}/${FILE:Q} ${OPENLDAP_FILEPERMS}
                     81: .endfor
                     82:
                     83: DB_CONFIG?=            # empty
                     84:
                     85: PTHREAD_OPTS+=         require
                     86:
                     87: .include "../../security/openssl/buildlink3.mk"
                     88: .include "../../security/tcp_wrappers/buildlink3.mk"
                     89: .include "../../mk/pthread.buildlink3.mk"
                     90:
                     91: .if ${PTHREAD_TYPE} == "native"
                     92: CONFIGURE_ARGS+=       --with-threads
                     93: .elif ${PTHREAD_TYPE} == "pth"
                     94: CONFIGURE_ARGS+=       --with-threads=pth
                     95:
                     96: #
                     97: # Don't use a larger FD_SETSIZE than GNU Pth can handle (value taken from
                     98: # pth.h header).
                     99: #
                    100: PTH_FDSETSIZE_cmd=                                                     \
                    101:        if ${TEST} -f ${BUILDLINK_PREFIX.pth:Q}/include/pth.h; then     \
                    102:                ${AWK} '/if FD_SETSIZE >/ { print $$4 }'                \
                    103:                        ${BUILDLINK_PREFIX.pth}/include/pth.h;          \
                    104:        else                                                            \
                    105:                ${ECHO} 0;                                              \
                    106:        fi
                    107: CPPFLAGS+=     -DOPENLDAP_FD_SETSIZE=${PTH_FDSETSIZE_cmd:sh:Q}
                    108: .endif
                    109:
                    110: MAKE_FLAGS+=           moduledir=${OPENLDAP_MODULEDIR:Q}
                    111: INSTALL_MAKE_FLAGS=    ${MAKE_FLAGS} sysconfdir=${EGDIR:Q}
                    112:
                    113: # Set the correct file modes for the example config files.
                    114: post-install:
                    115: .for file in ${CNFS} ${CNFS_PERMS} ${DB_CONFIG}
1.13      ghen      116:        ${CHMOD} ${SHAREMODE} ${DESTDIR}${EGDIR}/${file:Q}
                    117:        ${RM} -f ${DESTDIR}${EGDIR}/${file:Q}.default
1.1       ghen      118: .endfor

CVSweb <webmaster@jp.NetBSD.org>