[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / odbc-postgresql

File: [cvs.NetBSD.org] / pkgsrc / databases / odbc-postgresql / Attic / Makefile.common (download)

Revision 1.11, Sat Mar 4 21:29:09 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.10: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile.common,v 1.11 2006/03/04 21:29:09 jlam Exp $

DISTNAME=		postgresql-${DIST_VERS}
CATEGORIES=		databases
PGSQL_SITES=		http://www.postgresql.org/ftpsite/ \
			ftp://ftp.postgresql.org/pub/ \
			ftp://ftp.de.postgresql.org/pub/ \
			ftp://ch.postgresql.org/mirror/postgresql/ \
			ftp://gd.tuwien.ac.at/db/www.postgresql.org/pub/ \
			ftp://looking-glass.usask.ca/pub/postgresql/ \
			ftp://ftp.sunsite.auc.dk/mirrors/postgresql/ \
			ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/
MASTER_SITES?=		${PGSQL_SITES:=source/v${DIST_VERS}/}

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://odbc.postgresql.org/

CONFLICTS+=		postgresql-[0-6]* postgresql-7.0*
CONFLICTS+=		unixodbc-postgresql-[0-9]* iodbc-postgresql-[0-9]*

DISTINFO_FILE?=		${.CURDIR}/../odbc-postgresql/distinfo
PATCHDIR?=		${.CURDIR}/../odbc-postgresql/patches

# Version numbering scheme:
#
# DIST_VERS		version number on the postgresql distfile
# BASE_VERS		pkgsrc-mangled version number (convert pl -> .)
#
DIST_VERS?=		7.2.3
BASE_VERS?=		${DIST_VERS}

USE_TOOLS+=		gmake
MAKEFILE=		GNUmakefile
GNU_CONFIGURE=		YES

.include "../../mk/bsd.prefs.mk"

# PG_MB_ENCODING may be set to any of:
#
# SQL_ASCII, EUC_JP, EUC_CN, EUC_KR, EUC_TW, UNICODE, MULE_INTERNAL,
# LATIN1, LATIN2, LATIN3, LATIN4, LATIN5, KOI8, WIN, ALT
#
# This variable controls the language encoding on the backend process.

.if defined(PG_MB_ENCODING)
CONFIGURE_ARGS+=	--enable-multibyte=${PG_MB_ENCODING:Q}
.else
CONFIGURE_ARGS+=	--enable-multibyte	# accept default
.endif

CONFIGURE_ARGS+=	--enable-odbc
CONFIGURE_ARGS+=	--without-iodbc
CONFIGURE_ARGS+=	--without-unixodbc

CONFIGURE_ARGS+=	--without-java
CONFIGURE_ARGS+=	--without-perl
CONFIGURE_ARGS+=	--without-python
CONFIGURE_ARGS+=	--without-tcl
CONFIGURE_ARGS+=	--without-tk

CONFIGURE_ARGS+=	--includedir=${PREFIX}/include/pgsql
CONFIGURE_ARGS+=	--with-htmldir=${PREFIX}/share/doc/html/postgresql
CONFIGURE_ARGS+=	--with-openssl=${SSLBASE:Q}

CONFIGURE_ARGS+=	--disable-readline
CONFIGURE_ARGS+=	--enable-locale
CONFIGURE_ARGS+=	--enable-syslog
CONFIGURE_ARGS+=	--with-CXX
CONFIGURE_ARGS+=	--with-template=${LOWER_OPSYS:Q}

BUILD_DIRS=		${WRKSRC}/src/interfaces/odbc

.include "../../security/openssl/buildlink3.mk"