File:  [cvs.NetBSD.org] / pkgsrc / databases / ocaml-sqlite3 / Makefile
Revision 1.4: download - view: text, annotated - select for diffs
Tue Oct 2 21:25:23 2012 UTC (12 years, 2 months ago) by asau
Branches: MAIN
CVS tags: HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.4 2012/10/02 21:25:23 asau Exp $
#

PKGNAME=	ocaml-sqlite3-${VERSION}
DISTNAME=	sqlite3-ocaml-${VERSION}
VERSION=	2.0.2
CATEGORIES=	databases
MASTER_SITES=	https://bitbucket.org/mmottl/sqlite3-ocaml/downloads/
FETCH_USING=	curl

MAINTAINER=	jaapb@NetBSD.org
HOMEPAGE=	https://bitbucket.org/mmottl/sqlite3-ocaml/
COMMENT=	Sqlite bindings for OCaml
LICENSE=	mit

HAS_CONFIGURE=	yes
CONFIGURE_ARGS+=	--destdir "${DESTDIR}" --prefix "${PREFIX}"
USE_TOOLS+=	gmake pkg-config
USE_LANGUAGES=	c

SUBST_CLASSES+=	destdir
SUBST_STAGE.destdir=	post-configure
SUBST_MESSAGE.destdir=	Changing install location to DESTDIR
SUBST_FILES.destdir=	setup.ml
SUBST_SED.destdir=	-e 's,"install" :: findlib_name,"install" :: "-destdir ${DESTDIR}${PREFIX}/lib/ocaml/site-lib" :: "-ldconf /var/null" :: findlib_name,'

PLIST_VARS=	opt
.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
    (${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "x86_64") || \
    (${MACHINE_ARCH} == "arm")
PLIST.opt=	yes
.endif

do-configure:
	cd ${WRKSRC} && ${CONFIGURE_ENV} ocaml setup.ml -configure ${CONFIGURE_ARGS}

do-build:
	cd ${WRKSRC} && ${MAKE_ENV} ocaml setup.ml -build

do-install:
	cd ${WRKSRC} && ${MAKE_ENV} ocaml setup.ml -install

.include "../../lang/ocaml/buildlink3.mk"
.include "../../devel/ocaml-findlib/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>