The NetBSD Project

CVS log for pkgsrc/databases/libpqxx/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / libpqxx

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.42 / (download) - annotate - [select for diffs], Thu Sep 21 09:22:28 2023 UTC (2 months, 1 week ago) by vins
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Changes since 1.41: +2 -1 lines
Diff to previous 1.41 (colored)

databases/libpqxx: force C++17 standard to fix build.

Revision 1.41 / (download) - annotate - [select for diffs], Fri Sep 1 10:49:07 2023 UTC (3 months ago) by nia
Branch: MAIN
Changes since 1.40: +4 -2 lines
Diff to previous 1.40 (colored)

libpqxx: Convert to USE_CXX_FEATURES.

Revision 1.40 / (download) - annotate - [select for diffs], Mon Aug 14 05:23:59 2023 UTC (3 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.39: +2 -1 lines
Diff to previous 1.39 (colored)

*: recursive bump for Python 3.11 as new default

Revision 1.39 / (download) - annotate - [select for diffs], Thu Dec 29 22:24:48 2022 UTC (11 months ago) by prlw1
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

Update libpqx to 7.7.4

You now have three basic ways to query data, all through methods on your transaction object:

 - "query" methods execute the query, load the full result set,
    and then let you iterate the rows. They convert each row to a
   tuple of values of your chosen types.

 - "stream" methods do the same thing, except they run the query
   in a different way that's slower to start up, but starts giving
   you rows right away without waiting for the full result to come
   in. The rows also come in faster.

 - "exec" methods execute the query, load the full result set,
   and return a pqxx::result object. It contains both the result
   data and metadata such as how many rows there are in the result.

Highlights:
 - Build docs in `doc/html/`, no longer in `doc/html/Reference/`.
 - New `result::for_stream()`: simple iteration and conversion of rows.
 - New `transaction_base::for_query()` is similar, but non-streaming. (#580)
 - Query data and iterate directly as client-side types: `query()`. (#580)
 - New ways to query a single row!  `query01()` and `query1()`. (#580)
 - We now have 3 kinds of execution: "exec", "query", and "stream" functions.
 - Use C++23 `std::unreachable()` where available.
 - New class, `connecting` for nonblocking connection to the database.  (#487)
 - New class, `range` for SQL range types.  (#490)
 - Support `result::at(row_num, col_num)`.
 - Support `result[row_num, col_num]` if the compiler allows it.
 - `result::iter()` return value now keeps its `result` alive.
 - Add C++20 concepts: `binary`, `char_string`, `char_strings`.
 - New helper: `pqxx::value_type<CONTAINER>`.
 - New helper: `pqxx::binary_cast`. (#450)
 - Helper for generating parameter placeholders `$1`, `$2`, etc.  (#443)
 - Now requires `std::variant` support!  No longer works with gcc7.
 - New `blob::read()` using `std::span`.  (#429)
 - New, simpler API for large objects: `blob` ("binary large object").

For full changelog, see https://github.com/jtv/libpqxx/blob/7.7.4/NEWS

Revision 1.38 / (download) - annotate - [select for diffs], Thu Jan 7 16:29:30 2021 UTC (2 years, 10 months ago) by prlw1
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

Update libpqxx to 7.3.0

7.3.0
 - `stream_to` now quotes and escapes its table name.
 - Removed `transaction_base::classname()`.  Did anyone ever use it?
 - Internal reorg of the `transaction` and `transactionfocus` hierarchies.
 - Removed the only case of virtual inheritance, related to `namedclass`.
 - Internal `concat()` for faster, simpler string concatentation.
 - Fix compile omission in string conversions for `nullptr_t`.
 - `pqxx::size_buffer()` can now size multiple values at once.
 - `multi_to_string()` to convert multiple values into one `std::string`.
 - Implicit `zview` constructor from `char const *`. (#389)
 - Many `std::string&` parameters are now `zview` or `std::string_view`.
 - Now checking statement parameter lengths for overflow.
 - `#include <array>` in connection.cxx.  (#394)
7.2.1
 - Fix infinite loop in converting `char *` to string. (#377)
 - Deprecated `namedclass`.
 - Convert an entire row using `row::as<type...>()`.
 - Internal rework of `field::to()` and `field::as()` functions.
 - Some more warning options in maintainer mode.
 - Removed the old, DocBook-based tutorial.
 - Fixed wrong `query` and SQLSTATE params to some exceptions. (#378)

Revision 1.37 / (download) - annotate - [select for diffs], Sat Oct 24 11:35:37 2020 UTC (3 years, 1 month ago) by prlw1
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

Update libpqxx to 7.2.0

7.2.0
 - You can now implicitly convert a `const std::string &` to `zview`.
 - Replaced some overloads for C strings and C++ strings with `zview`.
 - Deprecating `binarystring`.  Use `std::basic_string<std::byte>` instead!
 - Array parser did not recognise escaping in unquoted values.
 - gcc10 test build fix: a result iterator is not the same thing as a `row`.
 - Doc fix: field size does _not_ include terminating zero.  (#356)
 - Fix error message in `demangle_type_name`: printed result, not raw name.
 - Fix compile warning in `demangle_type_name` on GNU systems.
 - Document that string conversions assume non-null values.
 - Start playing with C++20 _concepts._
 - Sketch out concepts-based `PQconnectdbParams` support.  (#343)
 - Add missing link to "datatypes" documentation.  (#346)
 - Supports `to_string`, `stream_to`, etc. for `binarystring`.  (#312)
 - Fixed infinite recursion when using `std::optional` in `stream_to`.  (#364)
 - Home-rolled hex-escaping.  Saves an allocation.
 - Catch floating-point negative overflow in `check_cast`, not underflow.
 - Bit more work on CMake build doc. (#318)
 - Typo in `datatypes.md`: `nullness`, not `nullness_traits`. (#353)
 - Fixed test names map in `tests/runner.cxx`. (#354)
 - Integral `from_string` now accept leading whitespace, as in composite types.
 - Experimental support basics for composite types.  (#355)
 - Use `stream_from` without knowing the number of fields.  (#357)
 - Global `size_buffer` function.
 - `quote()` now works for always-null types without conversions defined.
 - `std::nullopt` now converts to an SQL null.
 - Skip quoting and escaping array/composite fields of "safe" types.
 - New type trait: `is_unquoted_safe`.
 - Forbid invalid specialisations of `query_value`.
 - Fixed `mktemp` invocation that broke on FreeBSD.
 - Avoid unneeded encode/decode step on more binary data.
 - If `__cxa_demangle` fails, fall back on raw type name.  (#361)

Revision 1.36 / (download) - annotate - [select for diffs], Tue Sep 15 09:48:26 2020 UTC (3 years, 2 months ago) by prlw1
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.35: +5 -9 lines
Diff to previous 1.35 (colored)

Update libpqxx to 7.1.2

Now requires c++17.

Headline:

   Easier, faster, neater: the transaction classes now have a stream
   method. You specify a query and the C++ types to which you want
   the fields converted, and you get to iterate over the rows. And
   thanks to C++14 structured bindings, you can read the fields
   straight into separate local variables:

   for (auto const [id, name]:
       tx.stream<int, std::string_view>("SELECT id, name FROM thing"))
   {
       process(id, name);
   }

   For super-fast access to a field's text-format contents, convert
   it to std::string_view. It'll give you an immediate reference
   to the buffer containing the field. Beware though: the buffer
   only holds that text for the one iteration. The next iteration
   will overwrite it.

Full list of changes at:
   https://github.com/jtv/libpqxx/blob/7.1.2/NEWS

Revision 1.35 / (download) - annotate - [select for diffs], Thu Apr 25 07:32:40 2019 UTC (4 years, 7 months ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.34: +2 -1 lines
Diff to previous 1.34 (colored)

PKGREVISION bump for anything using python without a PYPKGPREFIX.

This is a semi-manual PKGREVISION bump.

Revision 1.34 / (download) - annotate - [select for diffs], Thu May 3 12:58:24 2018 UTC (5 years, 7 months ago) by prlw1
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.33: +16 -12 lines
Diff to previous 1.33 (colored)

Update libpqxx to 6.2.2

patch-ab no longer needed just since 15 Jan 2018(!)

5 years worth of changes including:
- C++11 is now required. Your compiler must have shared_ptr, noexcept, etc.
- Removed pqxx::items. Use the new C++11 initialiser syntax.
- Removed maketemporary. We weren't using it.
- Can now be built outside the source tree.
- New, simpler, lambda-friendly transactor framework.
- New, simpler, prepared statements and parameterised statements.
- Result rows can be passed around independently.
- New exec0(): perform query, expect zero rows of data.
- New exec1(): perform query, expect (and return) a single row of data.
- New exec_n(): perform query, expect exactly n rows of data.
- No longer defines Visual Studio's NOMINMAX in headers.
- Much faster configure script.
- Most configuration items are gone.
- Retired all existing capability flags.
- Documentation on readthedocs.org, thanks Tim Sheerman-Chase.
- Expose SQLSTATE error codes in sql_error exceptions.
- Adds a first-generation parser for SQL arrays.

Revision 1.33 / (download) - annotate - [select for diffs], Sun Jan 1 14:43:26 2017 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

Add python-3.6 to incompatible versions.

Revision 1.32 / (download) - annotate - [select for diffs], Sun Oct 9 21:41:56 2016 UTC (7 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.31: +2 -1 lines
Diff to previous 1.31 (colored)

Recursive bump for all users of pgsql now that the default is 95.

Revision 1.31 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:34 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.30 / (download) - annotate - [select for diffs], Sat Dec 5 21:25:31 2015 UTC (7 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.29 / (download) - annotate - [select for diffs], Thu Jan 1 09:43:44 2015 UTC (8 years, 11 months ago) by dholland
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.28: +6 -2 lines
Diff to previous 1.28 (colored)

Remove obsolete restriction based on a.out shared libraries not working.
Even if they still don't (it was noted ten years ago) I don't think we
have any a.out platforms left in pkgsrc. (Do we?)

Revision 1.28 / (download) - annotate - [select for diffs], Fri May 9 07:36:56 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

Revision 1.27 / (download) - annotate - [select for diffs], Sat Jan 25 08:44:28 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.26: +4 -10 lines
Diff to previous 1.26 (colored)

Mark as not ready for python-3.x.
Remove CONFIGURE_ARGS that is not supported any longer by the configure
script.

Revision 1.26 / (download) - annotate - [select for diffs], Tue Feb 12 04:35:24 2013 UTC (10 years, 9 months ago) by hiramatsu
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.25: +5 -2 lines
Diff to previous 1.25 (colored)

Update libpqxx from 2.5.5 to 4.0.1.

Changes from previous
=====================
4.0.1
 - Support for REPEATABLE READ isolation level.
 - Build fix for OS X.
 - Build fixes for clang++ 3.2.
 - Build fixes for clang++ 3.0.
 - Build fix for MinGW.
 - Build fix for BSD (and possibly other grep flavours).
 - Compatibility typedefs: pqxx::result::tuple & pqxx::result::field.
 - Supports C++11.
 - Fixed failure to detect some integer overflows during conversion.
4.0
 - API change: noticers are gone!  Use errorhandlers to capture error output.
 - API change: tablereaders and tablewriters are gone; they weren't safe.
 - API change: prepared statements are now weakly-typed, and much simpler.
 - API change: fields and tuples are now stand-alone classes in ::pqxx.
 - API change: thread-safety field have_strerror_r is now have_safe_strerror.
 - API change: notify_listener has been replaced with notification_receiver.
 - notification_receiver takes a payload parameter.
 - Easier Visual C++ setup.
 - Absolutely requires a libpq version with PQescapeStringConn.
 - Absolutely requires libpq 8.0 or better.
 - Changes for C++0x.
 - Supports clang++.
 - Visual C++ makefiles now support new-style unit tests.
 - Sample headers for more recent Visual Studio versions.
 - Fixes binary-data escaping problems with postgres 9.0.
 - Fixes problems with binary-string handling and escaping.
 - Fixes compatibility problems between 9.x libpq and 7.x backend.
 - quote_name to escape SQL identifiers for use in queries.
 - syntax_error reports error's approximate location in the query.
 - On Windows, now uses ws2_32 instead of wsock32.
 - Various Windows build fixes.
 - Updated for gcc 4.6.0.
 - configure script supports --enable-documentation/--disable-documentation.
 - Streamlined test/release toolchain.
3.1
 - Shared libraries are now versioned by ABI: 3.1 instead of 3.1.0 etc.
 - Threading behaviour is now documented, and can be queried.
 - Version information available at compile time.
 - Supports parameterized statements.
 - Result tuples now support slicing.
 - Configure with --with-tr1=boost to use BOOST shared_ptr.
 - String conversion now has its own header file.
 - Supports read-only transactions.
 - Fixed breakage with Solaris "make".
 - Uses shared_ptr if available.
 - binarystring::str() is no longer cached; no longer returns reference.
 - Fixed problems in Visual C++ Makefile for test suite.
 - Fixed problems with RPM packaging.
 - Fixed build problem on RedHat/CentOS 5.
 - Lets you check whether a prepared statement has been defined.
 - "Varargs" prepared statements.
 - Unnamed prepared statements now supported.
 - Results have iterator as well as const_iterator.
 - Rewrite of robusttransaction logic; may actually do its job now.
 - Connections support async query cancel from signal handler or thread.
 - More documentation for performance features.
3.0
 - Website is now at http://pqxx.org/ (no redirects)
 - Completely replaced cursor classes
 - More helpful error messages on failed connections
 - More detailed hierarchy of constraint-violation exception classes
 - trigger is now called notify_listener, trigger header is now notify-listen
 - New mixin base class pqxx_exception distinguishes libpqxx exception types
 - Quoting is back!  transaction_base::quote() & connection_base::quote()
 - Several build & documentation problems with Visual C++ fixed
 - Compile fixes for gcc 4.2, 4.3
 - Compile fixes for Sun Studio Express 5.9
 - Uses strlcpy() where available, instead of strncpy()
 - Keeps better track of applicable text encodings
 - Fixed bug with prepared statement parameters in separate C++ statements
 - robusttransaction now works for multiple users
 - Pipeline lets you cancel ongoing queries, e.g. because they run for too long
 - Fixed broken escaping of binary values in tablewriter
 - Floating-point types now represented with full precision
 - Proper unit tests for new functionality
 - New traits-based system for adding data types
 - Floating-point infinities now supported
 - Flushing/completing a pipeline now frees up the transaction for other use
 - Completely reworked test suite, builds and runs much faster
 - tablewriter supports writing of raw lines
2.6.9
 - Removed old 1.x API (that means all identifiers with capital letters!)
 - Tested with all current libpq versions and oldest/newest supported backends
 - No longer have old OnCommit()/OnAbort()/OnDoubt() callbacks in transactor!
 - Fixes failure when closing cursors with upper-case letters in their names
 - Fixes bug when adding triggers to connections that aren't open yet
 - Fixes bug when removing triggers
 - Fixes small memory leak when preparing statements
 - Fixes many problems with older backends
 - Fixes bug in result::swap(): protocol versions were not swapped
 - Some errors went undetected when using certain libpq versions
 - Fixes prepared statements on new libpq versions talking to old backends
 - Can estimate server version if libpq does not know how to obtain it
 - Greatly reduced memory usage while escaping strings
 - With Visual C++, creates lib/ directory if not already present
 - Useful error messages when preparing statements
 - Allows prepared statements to be registered explicitly
 - Support for "long long" types; enable with PQXX_ALLOW_LONG_LONG macro
 - Compilation errors for older libpq versions fixed
 - Some new small utility classes for disabling notice processing etc.
 - Result sets remember the queries that yielded them
 - New test script, pqxx-fulltest, tests against all current postgres versions
 - Connections can simulate failure
 - Adds password encryption function
2.6.8
 - Fixes bug: binary parameters to prepared statements truncated at nul bytes
 - New, more specific exception types to distinguish errors from server
 - Resolved serious problems with generated reference documentation
 - Automatically detect Windows socket library with MinGW
 - Windows "make" fixed to run from main directory, not win32
 - Fixes "mktemp" problems on some BSD-based platforms
 - pqxx-config is deprecated; use pkg-config instead
 - On GNU/Linux, uses poll() instead of select() to avoid file descriptor limit
 - Will provide server and protocol version information where available
 - New cursor class, absolute_cursor
2.6.7
 - New escape functions for binary data: transaction_base::esc_raw()
 - Improved detection of socket libraries, especially for MinGW
 - Works around bug in some versions of GNU grep 2.5.1
 - Fixes problem with configuration headers
 - Fixes PQprepare() detection
 - Fixes incomplete Visual C++ Makefile
 - Fixes compile error in workaround for older libpq versions
 - Removes "rpath" link option
2.6.6
 - New, encoding-safe string-escaping functions
 - Upper-case letters now allowed in prepared-statement names
 - Fixes crash in test005
 - More Visual C++ improvements
 - Removed collaboration diagrams from reference docs
 - New templating system for generating Windows Makefiles etc.
2.6.5
 - Visual C++ users: copy win32/common-sample to win32/common before editing it
 - Should fix problems finding socket library on MinGW
 - Even more work on Visual C++ problems
 - Updated documentation for Visual C++ users
 - Fixed bug in prepared statements (mostly visible on Visual C++)
 - Nested transactions work harder to detect backend support
2.6.4
 - Massively improved compatibility with Windows and Visual C++
 - Fixed late initialization of "direct" connection state
 - Fixed problem with initialization of connection capabilities
 - Fixed configuration bug for libpq in nonstandard locations
 - Sample configuration header for libpq found in PostgreSQL 8.1
2.6.3
 - Radical rework of prepared statements; INCOMPATIBLE INTERFACE CHANGE!
 - Dropped support for g++ 2.95
 - Emulate prepared statements support on old libpq or old backend
 - Bug fix: missing tutorial (release script now tests for this)
 - Automatically links in socket library on Windows or Solaris, if needed
 - Bug fix: check for std namespace didn't work
 - Fixes for Cygwin/MSYS/MinGW
2.6.2
 - Bug fix: connection state was not set up properly in some common cases
 - Bug fix: headers were installed in "include" instead of "include/pqxx"
 - Bug fix: sqlesc(string) broke with multibyte or multiple encodings
 - namedclass is now used as a virtual base; affects all subclass constructors
 - Initial implementation of subtransactions
 - Detect more connection capabilities
 - Standard library namespace can be set from configure script's command line
 - Completely reworked connection hierarchy, with separate policy objects
 - Clients can now define their own connection policies
 - Paved the way for client-defined thread synchronization
 - Now lives at http://thaiopensource.org/development/libpqxx/
2.6.1
 - Hugely improved recognition of different strerror_r() versions
 - Resolved link problems with gcc 4.0 and shared library
2.6.0
 - New macro PQXX_SHARED defines whether to use/build libpqxx as shared library
 - Robusttransaction compatible with PostgreSQL 8.1
 - Infrastructure for querying connection/backend capabilities at runtime
 - Greatly improved cursor support
 - Connection reactivation can be inhibited explicitly
 - Tries even harder to make sense of conflicting strerror_r() definitions
 - Detects connection failures that libpq glosses over
 - Reference documentation grouped into more coherent sections
 - Assumes strerror() is threadsafe on systems that have no strerror_r()
 - Now allows connection's socket number to be queried
 - New internal_error class for libpqxx-internal errors
 - With Visual C++, doesn't redefine NOMINMAX if it is defined already
 - Several compatibility improvements for Visual C++
 - Fixes and workarounds for HP-UX and HP aCC compiler
 - Phased old cursor interface out of test suite; tests ported to new interface
 - Added documentation on thread safety
 - New thread safety model
 - Large objects have functions to tell current position
 - Minor updates to tutorial (somebody pay me and I'll do more :)
 - No longer needs libpq-fs.h header
 - Meaningful error messages for ambiguous string conversions fixed
2.5.6
 - Support null parameters to prepared statements (use C-style char pointers)

Revision 1.25 / (download) - annotate - [select for diffs], Tue Oct 2 21:25:21 2012 UTC (11 years, 2 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.24: +1 -3 lines
Diff to previous 1.24 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.24 / (download) - annotate - [select for diffs], Sun Aug 5 10:02:09 2012 UTC (11 years, 4 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

Bump PKGREVISION for change of PostgreSQL default version to 9.1.

Revision 1.23 / (download) - annotate - [select for diffs], Wed Feb 10 19:34:05 2010 UTC (13 years, 9 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

Bump revision for change of PostgreSQL default version.

Revision 1.22 / (download) - annotate - [select for diffs], Sat Jan 16 17:57:37 2010 UTC (13 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.21: +1 -4 lines
Diff to previous 1.21 (colored)

Remove workaround for compiler bug in gcc2 on sparc64.

Revision 1.21 / (download) - annotate - [select for diffs], Mon Jul 14 12:56:01 2008 UTC (15 years, 4 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.20: +3 -1 lines
Diff to previous 1.20 (colored)

Mark as destdir ready.

Revision 1.20 / (download) - annotate - [select for diffs], Thu Mar 13 17:38:48 2008 UTC (15 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, cwrapper
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Make PostgreSQL 8.2 the default version. Bump all packages using it.
Remove PostgreSQL 8.0 as choice.

Revision 1.19 / (download) - annotate - [select for diffs], Thu Dec 28 12:12:57 2006 UTC (16 years, 11 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.18: +2 -1 lines
Diff to previous 1.18 (colored)

Change PostgreSQL default version to 8.1 and bump revision of all
packages which have it active by default.

Revision 1.18 / (download) - annotate - [select for diffs], Wed Aug 23 11:45:26 2006 UTC (17 years, 3 months ago) by ghen
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.17: +1 -3 lines
Diff to previous 1.17 (colored)

Update libpqxx to 2.5.5.  Changes:
- Diagnoses connection failure during result transfer
- Fixes invalid -R link option in pqxx-config

Revision 1.17 / (download) - annotate - [select for diffs], Sun Feb 5 23:08:32 2006 UTC (17 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.16: +3 -1 lines
Diff to previous 1.16 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.16 / (download) - annotate - [select for diffs], Mon Dec 5 20:49:57 2005 UTC (18 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Fixed pkglint warnings. The warnings are mostly quoting issues, for
example MAKE_ENV+=FOO=${BAR} is changed to MAKE_ENV+=FOO=${BAR:Q}. Some
other changes are outlined in

    http://mail-index.netbsd.org/tech-pkg/2005/12/02/0034.html

Revision 1.15 / (download) - annotate - [select for diffs], Mon Jun 27 01:57:26 2005 UTC (18 years, 5 months ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.14: +8 -8 lines
Diff to previous 1.14 (colored)

Update libpqxx{,-doc} to version 2.5.4

Changes: Lots of bugfixes and compatibility issues addressed.

Revision 1.14 / (download) - annotate - [select for diffs], Mon Apr 11 21:45:12 2005 UTC (18 years, 7 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.13: +1 -2 lines
Diff to previous 1.13 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Oct 3 00:13:18 2004 UTC (19 years, 2 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.12 / (download) - annotate - [select for diffs], Fri Aug 13 09:03:40 2004 UTC (19 years, 3 months ago) by recht
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.11: +3 -1 lines
Diff to previous 1.11 (colored)

Also set PGSQL_VERSION_REQD to 73 for these until issues with PostgreSQL
7.4 are sorted out.

Revision 1.11 / (download) - annotate - [select for diffs], Sat Jul 24 22:45:15 2004 UTC (19 years, 4 months ago) by recht
Branch: MAIN
Changes since 1.10: +4 -5 lines
Diff to previous 1.10 (colored)

Use the new mk/pgsql.buildlink3.mk to select the correct PostgreSQL
version.

Revision 1.10 / (download) - annotate - [select for diffs], Sat May 8 05:25:12 2004 UTC (19 years, 7 months ago) by snj
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.9: +3 -3 lines
Diff to previous 1.9 (colored)

Convert to buildlink3.

Revision 1.9 / (download) - annotate - [select for diffs], Fri Mar 26 02:27:36 2004 UTC (19 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.8: +2 -1 lines
Diff to previous 1.8 (colored)

PKGREVISION bump after openssl-security-fix-update to 0.9.6m.
Buildlink files: RECOMMENDED version changed to current version.

Revision 1.8 / (download) - annotate - [select for diffs], Mon Mar 22 23:29:12 2004 UTC (19 years, 8 months ago) by snj
Branch: MAIN
Changes since 1.7: +4 -1 lines
Diff to previous 1.7 (colored)

Fix build with gcc2 on sparc64.

Revision 1.7 / (download) - annotate - [select for diffs], Sat Feb 14 18:26:27 2004 UTC (19 years, 9 months ago) by jmmv
Branch: MAIN
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

PKGCONFIG_OVERRIDE is relative to WRKSRC.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Feb 14 17:21:35 2004 UTC (19 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.5: +2 -4 lines
Diff to previous 1.5 (colored)

LIBTOOL_OVERRIDE and SHLIBTOOL_OVERRIDE are now lists of shell globs
relative to ${WRKSRC}.  Remove redundant LIBTOOL_OVERRIDE settings that
are automatically handled by the default setting in bsd.pkg.mk.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Feb 5 09:28:59 2004 UTC (19 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Note that this package uses C and C++.

Revision 1.4 / (download) - annotate - [select for diffs], Wed Jan 7 13:32:40 2004 UTC (19 years, 11 months ago) by is
Branch: MAIN
Changes since 1.3: +2 -6 lines
Diff to previous 1.3 (colored)

Split out Makefile.common, for the benefit of the -doc package.

Revision 1.3 / (download) - annotate - [select for diffs], Wed Jan 7 11:22:49 2004 UTC (19 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.2: +2 -1 lines
Diff to previous 1.2 (colored)

Make pkglint quiet.

Revision 1.2 / (download) - annotate - [select for diffs], Wed Jan 7 11:21:16 2004 UTC (19 years, 11 months ago) by is
Branch: MAIN
Changes since 1.1: +3 -2 lines
Diff to previous 1.1 (colored)

Don't build on a.out architectures, where the shared library versioning
of this package is broken.

Revision 1.1 / (download) - annotate - [select for diffs], Wed Jan 7 11:08:53 2004 UTC (19 years, 11 months ago) by is
Branch: MAIN

C++ interface to Postgresql-LIB (only for ELF due to broken versioning).

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>