[BACK]Return to Makefile_drivers CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / libdbi-driver-sqlite3

File: [cvs.NetBSD.org] / pkgsrc / databases / libdbi-driver-sqlite3 / Attic / Makefile_drivers (download)

Revision 1.4, Sun Aug 21 19:16:58 2016 UTC (7 years, 1 month ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.3: +2 -2 lines

Update databases/libdbi-drivers-* to 0.9.0.

- some of the drivers now export client library functions to the
  programmer via the dbi_driver_specific_function() interface
- if necessary, the drivers now support libdbi instances
- a segfault in the oracle driver caused by INSERT statements was
  fixed
- the pgsql driver now supports features specific to PostgreSQL 9
  and later
- drivers now support transactions and savepoints if the
  underlying database engines do
- additional libdbi hint about position in a result set allows
  tremendous speedup of sequential reads from MySQL result sets
- various memory leaks were plugged
- database specific test scripts allow tests without affecting
  existing database clusters
- completely rewritten test kit increases coverage and improves
  error reporting

# $NetBSD: Makefile_drivers,v 1.4 2016/08/21 19:16:58 fhajny Exp $
#

DISTNAME=	libdbi-drivers-0.9.0
PKGNAME=	${DISTNAME:S/libdbi-drivers/libdbi-driver-${DRIVER}/:S/-1/.1/:S/-2/.2/}
CATEGORIES=	databases devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=libdbi-drivers/}

MAINTAINER=	cheusov@NetBSD.org
HOMEPAGE=	http://libdbi-drivers.sourceforge.net/

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes

DISTINFO_FILE=		${.CURDIR}/../../databases/libdbi-driver-sqlite3/distinfo
PATCHDIR=		${.CURDIR}/../../databases/libdbi-driver-sqlite3/patches

INSTALLATION_DIRS+=	lib/dbd

CONFIGURE_ARGS+=	--disable-dependency-tracking
CONFIGURE_ARGS+=	--with-dbi-incdir=${BUILDLINK_PREFIX.libdbi}/include/dbi
CONFIGURE_ARGS+=	--with-dbi-libdir=${BUILDLINK_PREFIX.libdbi}/lib
CONFIGURE_ARGS+=	--disable-docs