The NetBSD Project

CVS log for pkgsrc/databases/leveldb/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / databases / leveldb

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.6: download - view: text, markup, annotated - select for diffs
Fri Aug 5 13:02:02 2022 UTC (2 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, HEAD
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -4 lines
leveldb: updated to 1.23

1.23

Sync MANIFEST before closing in db_impl when creating a new DB. Add logging with debugging information when failing to load a version set.
Optimize leveldb block seeks to utilize the current iterator location. This is beneficial when iterators are reused and seeks are not random but increasing. It is additionally beneficial with larger block sizes and keys with common prefixes.
Documentation fixes
(cmumford/printf-fix) Fixed fprintf of 64-bit value.
(cmumford/benchmark) Added google/benchmark submodule.
Internal test cleanup
Internal cleanup migrating StatusOr.
avoid unnecessary memory copy
Fix accidental double std:: qualifiers.
Add some std:: qualifiers to types and functions.
Switch from C headers to C++ headers.
change const to constexpr
remove unnessary status judge
Remove leveldb::port::kLittleEndian.
Remove Windows workarounds in some tests.
Add Env::Remove{File,Dir} which obsolete Env::Delete{File,Dir}.
Defend against inclusion of windows.h in tests that invoke Env::DeleteFile.
Add WITHOUT ROWID to SQLite benchmark.
Switch testing harness to googletest.
Move CI to Visual Studio 2019.
Allow different C/C++ standards when this is used as a subproject.
Align CMake configuration with related projects.
Remove redundant PROJECT_SOURCE_DIR usage from CMake config.
Fix installed target definition.
Added return in Version::Get::State::Match to quiet warning.
Using CMake's check_cxx_compiler_flag to check support for -Wthread-safety.
Fix tsan problem in env_test.
Simplify unlocking in DeleteObsoleteFiles.
Add "leveldb" subdirectory to public include paths.
Align EnvPosix and EnvWindows.
Disable exceptions and RTTI in CMake configuration.
cache Saver in State object
fix bug(uninitialized options pointer in State)
remove TODO in Version::ForEachOverlapping
use ForEachOverlapping to impl Get
unsigned char -> uint8_t
Add explicit typecasts to avoid compiler warning.
Guard DBImpl::versions_ by mutex_.
Converted two for-loops to while-loops.
Switch to using C++ 11 override specifier.
Added unit test for InternalKey::DecodeFrom with empty string.
Using std::ostringstream in key DebugString.
Fix EnvPosix tests on Travis CI.
Clean up util/coding.{h,cc}.
Initialize Stats::start_ before first use in Stats::Start().
Add argument definition for void c functions.
Consolidate benchmark code to benchmarks/.
Convert missed virtual -> override in db_test.cc.
don't check current key in DBIter::Next()
Add O_CLOEXEC to open calls.
broken db: fix assertion in leveldb::InternalKey::Encode, mark base as corrupt
set const property
reduce lock's range in DeleteObsoleteFiles
block_builder header file dependency fixed

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Oct 26 10:09:21 2021 UTC (3 years, 1 month ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
databases: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

The following distfiles could not be fetched (some may be only fetched
conditionally):

./databases/cstore/distinfo D6.data.ros.gz
./databases/cstore/distinfo cstore0.2.tar.gz
./databases/cstore/distinfo data4.tar.gz

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Oct 7 13:35:12 2021 UTC (3 years, 2 months ago) by nia
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
databases: Remove SHA1 distfile hashes

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Jun 5 13:22:04 2019 UTC (5 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -7 lines
leveldb: updated to 1.22

Release 1.22
Corrected formatting to be compliant with the Google C++ Style Guide.
Specifically export the WriteBatch::Handler inner class for Windows link.
Merge pull request 665 from cheng-chang:coding.
Merge pull request 669 from pavel-pimenov:fix-readme-windows-mkdir.
Merge pull request 472 from zhoudayang:patch-1.
Merge pull request 339 from richcole-at-amazon:master.
Restore soname versioning with CMake build.
Other miscellaneous cleanups, fixes, and improvements.

Release 1.21
Switched to using Copybara for project synchronization.
Minor cleanup in ports.
Silence unused argument warnings in MSVC.
Add tests for empty keys and values.
Switch corruption_test to use InMemEnv.
Replace AtomicPointer with std::atomic.
Make InMemoryEnv more consistent with filesystem based Env's.
Align windows_logger with posix_logger.
Improve CI configuration and added AppVeyor (Windows CI) badge to README.
Added native support for Windows.
Make WriteBatch::ApproximateSize() const.
Fix PosixWritableFile::Sync() on Apple systems.
Fix fdatasync() feature detection in opensource build.
C++11 cleanup for util/mutexlock.h.
Rework threading in env_posix.cc.
Remove InitOnce from the port API.
Expose WriteBatch::Append().
Fix documentation for log file growth.
Add move constructor to Status.
Replace port_posix with port_stdcxx.
Reimplement ConsumeDecimalNumber.
Document the building process.
Replace NULL with nullptr in C++ files.
Remove PLATFORM_IS_LITTLE_ENDIAN from port/posix.h.
Add more thread safety annotations.
Require C++11.
Replace SIZE_MAX with std::numeric_limits.
Add CMake build support.
Enable thread safety annotations.
leveldb::DestroyDB will now delete empty directories.
Replace SSE-optimized CRC32C in POSIX port with external library.
Fix file writing bug in CL 170738066.
Fix use of uninitialized value in LRUHandle.
Fix issue 474: a race between the f*_unlocked() STDIO calls in env_posix.cc and concurrent application calls to fflush(NULL).
Use __APPLE__ instead of OS_MACOS. The former is compiler-provided.
Report missing CURRENT manifest file as database corruption.
LevelDB: Add WriteBatch::ApproximateSize().
Other minor fixes, code cleanup, and documentation improvements.

Revision 1.1.2.1: download - view: text, markup, annotated - select for diffs
Mon May 1 09:40:55 2017 UTC (7 years, 7 months ago) by bsiegert
Branches: pkgsrc-2017Q1
Diff to: previous 1.1: preferred, colored; next MAIN 1.2: preferred, colored
Changes since revision 1.1: +2 -1 lines
Pullup ticket #5383 - requested by sevan
databases/leveldb: build fix for NetBSD

Revisions pulled up:
- databases/leveldb/distinfo                                    1.2
- databases/leveldb/patches/patch-build__detect__platform       1.1

---
   Module Name:    pkgsrc
   Committed By:   joerg
   Date:           Thu Apr 27 17:04:56 UTC 2017

   Modified Files:
           pkgsrc/databases/leveldb: distinfo
   Added Files:
           pkgsrc/databases/leveldb/patches: patch-build__detect__platform

   Log Message:
   Don't hard-code -lgcc_s on NetBSD.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Apr 27 17:04:56 2017 UTC (7 years, 7 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Don't hard-code -lgcc_s on NetBSD.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Mar 14 13:12:28 2017 UTC (7 years, 8 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base
Branch point for: pkgsrc-2017Q1
Import leveldb-1.20 as databases/leveldb.

Packaged for wip by Mike M. Volokhov and myself.

LevelDB is a fast key-value storage library written at Google that
provides an ordered mapping from string keys to string values.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>