[BACK]Return to distinfo CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / elasticsearch

File: [cvs.NetBSD.org] / pkgsrc / databases / elasticsearch / distinfo (download)

Revision 1.15, Thu Dec 31 09:57:31 2015 UTC (8 years, 3 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.14: +6 -6 lines

Update databases/elastisearch to 2.1.1.

elasticsearch 2.1.1
===================

Enhancements

Aggregations
- [Children agg] fix bug that prevented all child docs from being evaluated
Core
- If we can't get a MAC address for the node, use a dummy one
- Simplify shard inactive logging
- Simplify IndexingMemoryController#checkIdle
- IndexingMemoryController should not track shard index states
Index Templates
- Disallow index template pattern to be the same as an alias name
Mapping
- throw exception if a copy_to is within a multi field
- Register field mappers at the node level.

Bug fixes

Index APIs
- Field stats: Index constraints should remove indices in the response
  if the field to evaluate is empty
Internal
- Throw a meaningful error when loading metadata and an alias and index
  have the same name
Mapping
- Multi field names may not contain dots
Search
- Fix NPE when a segment with an empty cache gets closed.
Translog
- Fail and close translog hard if writing to disk fails
- Prevent writing to closed channel if translog is already closed
- Don't delete temp recovered checkpoint file it was renamed
Tribe Node
- Fix tribe node to load config file for internal client nodes

Regressions

Query DSL
- RangeQueryParser should accept _name in inner field


elasticsearch 2.1.0
===================

Breaking changesedit

CRUD
- Default detect_noop to true
Fielddata
- Remove the experimental indices.fielddata.cache.expire
Index APIs
- Add Force Merge API, deprecate Optimize API
Internal
- Forbid changing thread pool types
Java API
- Deprecates defaultRescoreWindowSize
Nested Docs
- If sorting by nested field then the nested_path should always be
  specified
Search
- Limit the size of the result window to a dynamic property
Stats
- The queue_size value should be shown as an integer.

Deprecations

Java API
- Deprecate the count api in favour of search with size 0
Parent/Child
- Deprecate score_type option in favour of the score_mode option
Query DSL
- Deprecate NotQueryBuilder
Search
- Deprecate _search/exists in favour of regular _search with size 0 and
  terminate_after 1
- Deprecate the scan search type.

New features

Aggregations
- Add percentiles_bucket pipeline aggregation
- Add stats_bucket / extended_stats_bucket pipeline aggs
Analysis
- Lithuanian analysis
Geo
- Adds geo_centroid metric aggregator

Enhancements

Allocation
- Add cluster-wide setting for total shard limit
- Early terminate high disk watermark checks on single data node cluster
- Also use PriorityComparator in shard balancer
- Add support for filtering by publish IP address
CAT API
- Add duration field to /_cat/snapshots
- Add cat API for repositories and snapshots
- Adds disk used by indices to _cat/allocation
Core
- Verify Checksum once it has been fully written to fail as soon as
  possible
Exceptions
- Deduplicate cause if already contained in shard failures
- Give a better exception when running from freebsd jail without
  enforce_statfs=1
- Make root_cause of field conflicts more obvious
- Use a dedicated id to serialize EsExceptions instead of it's class name.
- Validate class before cast.
- Improve error message of ClassCastExceptions
Geo
- Refactor geo_point validate* and normalize* for 2.x
Index APIs
- Limit type name length
Index Templates
- Accumulate validation errors when validating index templates
Internal
- Fix dangling comma in ClusterBlock#toString
- Improve some logging around master election and cluster state
- Add workaround for JDK-8014008
- Cleanup IndexMetaData
- More helpful error message on parameter order
- Cleanup InternalClusterInfoService
- Remove and forbid use of com.google.common.base.Throwables
- Remove cyclic dependencies between IndexService and FieldData/BitSet
  caches
- Remove and forbid use of com.google.common.base.Objects
- Remove and forbid use of com.google.common.collect.ImmutableList
- Remove and forbid use of com.google.common.collect.Lists
- Remove unused code from query_string parser and settings
- Consolidate duplicate logic in RoutingTable all*ShardsGrouped
- Turn DestructiveOperations.java into a Guice module.
- Remove CachedDfSource
- Enable indy (invokedynamic) compile flag for Groovy scripts by
  default
Java API
- Prevents users from building a BulkProcessor with a null client
Logging
- Move logging for the amount of free disk to TRACE
Packaging
- Drop ability to execute on Solaris
- Nuke ES_CLASSPATH appending, JarHell fail on empty classpath elements
- improve seccomp syscall filtering
- Block process execution with seccomp on linux/amd64
- Remove JAVA_HOME detection from the debian init script
Plugin Cloud AWS
- Enable S3SignerType
- Remove cloud.account and cloud.key settings
Plugin Cloud GCE
- cloud-gce plugin should check discovery.type
Plugin Discovery EC2
- Adding US-Gov-West
- Improved building of disco nodes
Plugin Repository S3
- Add aws canned acl
Plugins
- Don't be lenient in PluginService#processModule(Module)
- Adds a validation for plugins script to check if java is set
- Plugins: Removed plugin.types
- Improve java version comparison and explicitly enforce a version format
- Output plugin info only in verbose mode
Query DSL
- Internal: simplify filtered query conversion to lucene query
- Remove unsupported rewrite from multi_match query builder
- Remove unsupported rewrite option from match query builder
- Make FunctionScore work on unmapped field with missing parameter
Scripting
- Add property permissions so groovy scripts can serialize json
Scroll
- Optimize sorted scroll when sorting by _doc.
Search
- fix numerical issue in function score query
- Optimize scrolls for constant-score queries.
- Optimize counts on simple queries.
Search Templates
- Adds template support to _msearch resource
Snapshot/Restore
- Simplify the BlobContainer blob writing interface
- Add readonly option for repositories
Stats
- Add os.allocated_processors stats
- Adds stats counter for failed indexing requests

Bug fixes

Aggregations
- Pass extended bounds into HistogramAggregator when creating an
  unmapped aggregator
- Added correct generic type parameter on ScriptedMetricBuilder
- Pipeline Aggregations at the root of the agg tree are now validated
- Estimate HyperLogLog bias via k-NN regression
Allocation
- Fix calculation of next delay for delayed shard allocation
- Take ignored unallocated shards into account when making allocation
  decision
- Only allow rebalance operations to run if all shard store data is
  available
- Delayed allocation can miss a reroute
- Check rebalancing constraints when shards are moved from a node they
  can no longer remain on
CAT API
- Properly set indices and indicesOptions on subrequest made by
  /_cat/indices
CRUD
- Index name expressions should not be broken up
Cluster
- Handle shards assigned to nodes that are not in the cluster state
Core
- Use fresh index settings instead of relying on @IndexSettings
- Fork Lucene PatternTokenizer to apply LUCENE-6814 (closes
- Record all bytes of the checksum in VerifyingIndexOutput
- When shard becomes active again, immediately increase its indexing buffer
- Close TokenStream in finally clause
- LoggingRunnable.run should catch and log all errors, not just Exception?
Exceptions
- Fix ensureNodesAreAvailable's error message
Fielddata
- Don't cache top level field data for fields that don't exist
Geo
- Geo: Allow numeric parameters enclosed in quotes for geohash_grid
  aggregation
- Resync Geopoint hashCode/equals method
- Fix GeoPointFieldMapper to index geohash at correct precision.
Index APIs
- Field stats: Fix NPE for index constraint on empty index
- Field stats: Added format option for index constraints
- Restore previous optimize transport action name for bw comp
- Forbid index name . and ..
Index Templates
- Validate settings specified in index templates at template creation time
Internal
- fix mvn verify on jigsaw with 2.1
- fixup issues with 32-bit jvm
- Failure to update the cluster state with the recovered state should
  make sure it will be recovered later
- Gateway: a race condition can prevent the initial cluster state from
  being recovered
- Verify actually written checksum in VerifyingIndexOutput
- An inactive shard is activated by triggered synced flush
Logging
- Don't log multi-megabyte guice exceptions.
- Moving system property setting to before it can be used
Mapping
- Make _type use doc values
- Mapping: Allows upgrade of indexes with only search_analyzer specified
Packaging
- Handle system policy correctly
- Startup script exit status should catch daemonized startup failures
- Don't let ubuntu try to install its crazy jayatana agent.
Parent/Child
- Remove unnecessary usage of extra index searchers
- Plugin Delete By Query
- Fix Delete-by-Query with Shield
- Delete by query to not wrap the inner query into an additional query
  element
Plugins
- Fix plugin list command error message
- Fix HTML response during redirection
REST
- XContentFactory.xContentType: allow for possible UTF-8 BOM for JSON
  XContentType
- RestUtils.decodeQueryString ignores the URI fragment when parsing
  a query string
Search
- Fix the quotes in the explain message for a script score function
  without parameters
Settings
- ByteSizeValue.equals should normalize units
- Snapshot/Restore
- Snapshot restore and index creates should keep index settings and
  cluster blocks in sync
- Fix blob size in writeBlob() method
Stats
- Add extra validation into cluster/stats
- Omit current* stats for OldShardStats
Translog
- Translog recovery can repeatedly fail if we run out of disk
- Pending operations in the translog prevent shard from being marked
  as inactive

Regressions

Internal
- Deduplicate concrete indices after indices resolution

Upgrades

Core
- Upgrade Lucene to 5.3.1
- Upgrade to lucene-5.3.0.
Geo
- Update to spatial4j 0.5 for correct Multi-Geometry
Internal
- Update to Jackson 2.6.2
Plugin Cloud AWS
- Update AWS SDK version to 1.10.19
Plugin Discovery EC2
- Upgrade to aws 1.10.33

$NetBSD: distinfo,v 1.15 2015/12/31 09:57:31 fhajny Exp $

SHA1 (elasticsearch-2.1.1.tar.gz) = 360ca8e329b8b0c34b1cd6012c452951f8d3e137
RMD160 (elasticsearch-2.1.1.tar.gz) = 7f6f6f6d642178e5c1d6b666d135fa32f37f1c89
SHA512 (elasticsearch-2.1.1.tar.gz) = eff12cd7342dc0036dc88f03ced9c7cc90d284222efeca86adfd9e4cf254cb8f96105c58673b239cfc9eb9764a2a669d2cd171ca73eb43b1ec1470a13c5e1776
Size (elasticsearch-2.1.1.tar.gz) = 29007342 bytes
SHA1 (patch-bin_elasticsearch.in.sh) = 984c9fe74383f724932a6c1b9d88b1158fe4bbde
SHA1 (patch-bin_plugin) = 5ddd9b55797305c2c1e77b174ae410c00ecb7b89
SHA1 (patch-config_elasticsearch.yml) = 7729dfb1ed106f0a34e6daaf7a46d0352d42f1f1