[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / databases / db4

Annotation of pkgsrc/databases/db4/Makefile, Revision 1.33

1.33    ! martti      1: # $NetBSD: Makefile,v 1.32 2004/12/30 21:51:30 minskim Exp $
1.1       uebayasi    2:
1.33    ! martti      3: DISTNAME=              db-4.3.27
1.8       epg         4: PKGNAME=               ${DISTNAME:S/db/db4/}
1.33    ! martti      5: #PKGREVISION=          1
1.8       epg         6: CATEGORIES=            databases
1.33    ! martti      7: MASTER_SITES=          ftp://ftp.sleepycat.com/releases/
1.7       wiz         8:
1.8       epg         9: MAINTAINER=            tech-pkg@NetBSD.org
                     10: HOMEPAGE=              http://www.sleepycat.com/
                     11: COMMENT=               Berkeley DB version 4 from Sleepycat Software
                     12:
1.10      jlam       13: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     14:
1.14      jlam       15: USE_BUILDLINK3=                yes
1.12      jlam       16: USE_LANGUAGES=         c c++
1.14      jlam       17: USE_LIBTOOL=           yes
                     18: GNU_CONFIGURE=         yes
1.25      jlam       19: CONFIGURE_DIRS=                ${WRKSRC}/build_unix
                     20: BUILD_DIRS=            ${CONFIGURE_DIRS}
1.1       uebayasi   21: CONFIGURE_SCRIPT=      ../dist/configure
                     22:
1.8       epg        23: CONFIGURE_ARGS+=       --enable-cxx
1.1       uebayasi   24: CONFIGURE_ARGS+=       --enable-rpc
                     25: CONFIGURE_ARGS+=       --enable-shared
1.14      jlam       26: CONFIGURE_ARGS+=       --enable-compat185
1.8       epg        27: CONFIGURE_ARGS+=       --includedir=${PREFIX}/include/db4
                     28: CONFIGURE_ARGS+=       --program-transform-name=s,db_,db4_,
1.9       seb        29:
1.27      jlam       30: .include "../../mk/bsd.prefs.mk"
1.31      jlam       31: .include "options.mk"
1.27      jlam       32:
1.9       seb        33: # NetBSD-sparc64-1.6*'s f77 makes configure failing and as f77 is not
                     34: # needed for this package the following does no harm on other platform.
1.16      snj        35: CONFIGURE_ENV+=                F77=${FALSE}
1.4       jlam       36:
1.19      grant      37: OPSYSVARS+=            LIBSO_LIBS
                     38: LIBSO_LIBS.SunOS+=     -lnsl
                     39: CONFIGURE_ENV+=                LIBSO_LIBS="${LIBSO_LIBS}"
                     40:
1.28      jlam       41: # DB4 only want pthreads because it's really after POSIX 1003.1
                     42: # inter-process mutexes.  In this case, we only care to use the native
1.29      jlam       43: # threads.  We also only care if we're using a non-GCC compiler since
                     44: # we have code to use GCC assembly for mutexes instead of 1003.1
                     45: # mutexes.
1.28      jlam       46: #
1.29      jlam       47: .include "../../mk/compiler.mk"
1.30      jlam       48: .if !empty(PKGSRC_COMPILER:Mgcc)
                     49: CONFIGURE_ENV+=                ac_cv_lib_pthread_main=no
                     50: .else
1.28      jlam       51: PTHREAD_OPTS+=         native
1.29      jlam       52: .  include "../../mk/pthread.buildlink3.mk"
                     53: .endif
1.27      jlam       54:
1.1       uebayasi   55: post-install:
1.31      jlam       56:        ${CHOWN} -R ${DOCOWN}:${DOCGRP} ${PREFIX}/share/doc/db4
1.1       uebayasi   57:
                     58: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>