[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cross / mingw-w64-x86_64-gcc-bootstrap

File: [cvs.NetBSD.org] / pkgsrc / cross / mingw-w64-x86_64-gcc-bootstrap / Makefile.common (download)

Revision 1.11, Sun Oct 9 02:37:03 2022 UTC (5 months, 3 weeks ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.10: +4 -2 lines

mingw-w64*: Update to 10.0.0

* Update GCC and binutils to the latest too.

Changelog:
v10.0.0: 2022-04-04

Notable changes:

  * New msvcrt10, 20, 40, 70 and 71 import libraries.
  * Drop x86_64 64bit crtdll.dll
  * Updated wine imports
  * Fix intrin.h compatibility with GCC-11
  * _(v)scprintf optimization
  * optimize __ms_vsnprintf for LTO

# $NetBSD: Makefile.common,v 1.11 2022/10/09 02:37:03 ryoon Exp $
#
# used by cross/mingw-w64-x86_64-gcc-bootstrap/Makefile
# used by cross/mingw-w64-i686-gcc-bootstrap/Makefile
# used by cross/mingw-w64-i686-gcc-bootstrap/Makefile.common
# used by cross/mingw-w64-x86_64-gcc-bootstrap/Makefile.common

DISTNAME=		gcc-12.2.0
CATEGORIES=		cross
MASTER_SITES=		${MASTER_SITE_GNU:=gcc/gcc-${PKGVERSION_NOREV}/}
EXTRACT_SUFX=		.tar.xz

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://mingw-w64.org/

PATCHDIR=		${.CURDIR}/../../cross/mingw-w64-x86_64-gcc/patches
DISTINFO_FILE=		${.CURDIR}/../../cross/mingw-w64-x86_64-gcc/distinfo

USE_LANGUAGES=		c c++
USE_TOOLS+=		gmake
TOOLS_BROKEN+=		perl
GNU_CONFIGURE=		yes
GNU_CONFIGURE_STRICT=	no # has sub-configures
GNU_CONFIGURE_PREFIX=	${PREFIX}/cross/${MINGW_TARGET}-bootstrap
OBJDIR=			../build
CONFIGURE_DIRS=		${OBJDIR}
CONFIGURE_SCRIPT=	../${DISTNAME}/configure
CONFIGURE_ARGS+=	--target=${MINGW_TARGET}
CONFIGURE_ARGS+=	--with-sysroot=${PREFIX}/cross/${MINGW_TARGET}
CONFIGURE_ARGS+=	--with-ld=${PREFIX}/cross/${MINGW_TARGET}/${MINGW_TARGET}/bin/ld
CONFIGURE_ARGS+=	--with-as=${PREFIX}/cross/${MINGW_TARGET}/${MINGW_TARGET}/bin/as
CONFIGURE_ARGS+=	--disable-nls
CONFIGURE_ARGS+=	--enable-languages=c,lto
CONFIGURE_ARGS+=	--enable-static
CONFIGURE_ARGS+=	--enable-lto
CONFIGURE_ARGS+=	--disable-dw2-exceptions
CONFIGURE_ARGS+=	--enable-version-specific-runtime-libs
CONFIGURE_ARGS+=	--disable-multilib
CONFIGURE_ARGS+=	--disable-gcov

CHECK_PORTABILITY_SKIP+=	contrib/*
CHECK_PORTABILITY_SKIP+=	gcc/config/nvptx/gen-opt.sh

INFO_FILES=		yes

BUILD_TARGET=		all-gcc
INSTALL_TARGET=		install-gcc

pre-configure:
	${RUN} cd ${WRKSRC} && ${MKDIR} ${OBJDIR}

.include "../../cross/mingw-w64/Makefile.common"
.include "../../devel/gmp/buildlink3.mk"
.include "../../math/mpfr/buildlink3.mk"
.include "../../math/mpcomplex/buildlink3.mk"