[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cross / mingw-w64-x86_64-binutils

File: [cvs.NetBSD.org] / pkgsrc / cross / mingw-w64-x86_64-binutils / Makefile.common (download)

Revision 1.8, Fri Oct 2 16:49:36 2020 UTC (3 years, 5 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.7: +4 -2 lines

mingw-w64-*: Update to mingw-w64 to 8.0.0

* Update GCC to 10.2.0.
* Update Binutils to 2.35.1

Changelog:
v8.0.0: 2020-09-18

Notable changes:

    New Hyper-V headers and libraries by Biswapriyo Nath
    Many headers updated from Wine by Jacek Caban.
    ARM math improvements by Martin Storsjo
    floating point fixes by Liu Hao
    many *printf compatibility fixes by Liu Hao and Martin Storsjo
    massive Windows App Store API updates by Steve Lhomme
    winstorecompat library updates by Martin Storsjo
    __USE_MINGW_ANSI_STDIO now automatically enabled in C99 and C11 mode when not using UCRT by Pali Rohar
    wdm and ddk updates by Zebediah Figura
    UCRT for Windows Store Apps (-lucrtapp) by Martin Storsjo
    Audioclient and ActivateAudioInterfaceAsync API updates by Liu Hao
    DirectX SDKs are now always installed

# $NetBSD: Makefile.common,v 1.8 2020/10/02 16:49:36 ryoon Exp $
#
# used by cross/mingw-w64-x86_64-binutils/Makefile
# used by cross/mingw-w64-i686-binutils/Makefile

DISTNAME=	binutils-2.35.1
CATEGORIES=	cross
MASTER_SITES=	${MASTER_SITE_GNU:=binutils/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://mingw-w64.org/

PATCHDIR=	${.CURDIR}/../../cross/mingw-w64-x86_64-binutils/patches
DISTINFO_FILE=	${.CURDIR}/../../cross/mingw-w64-x86_64-binutils/distinfo

USE_TOOLS+=		gmake

GNU_CONFIGURE=		yes
GNU_CONFIGURE_STRICT=	no # several sub-configures know --enable-nls
GNU_CONFIGURE_PREFIX=	${PREFIX}/cross/${MINGW_TARGET}
CONFIGURE_ARGS+=	--target=${MINGW_TARGET}
CONFIGURE_ARGS+=	--disable-nls
INFO_FILES=		yes

BUILDLINK_TRANSFORM+=	rm:-Werror

.include "../../cross/mingw-w64/Makefile.common"