[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cross / mingw-w64-x86_64-binutils

File: [cvs.NetBSD.org] / pkgsrc / cross / mingw-w64-x86_64-binutils / Makefile.common (download)

Revision 1.11, Sun Oct 9 02:37:03 2022 UTC (5 months, 3 weeks ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.10: +5 -2 lines

mingw-w64*: Update to 10.0.0

* Update GCC and binutils to the latest too.

Changelog:
v10.0.0: 2022-04-04

Notable changes:

  * New msvcrt10, 20, 40, 70 and 71 import libraries.
  * Drop x86_64 64bit crtdll.dll
  * Updated wine imports
  * Fix intrin.h compatibility with GCC-11
  * _(v)scprintf optimization
  * optimize __ms_vsnprintf for LTO

# $NetBSD: Makefile.common,v 1.11 2022/10/09 02:37:03 ryoon Exp $
#
# used by cross/mingw-w64-x86_64-binutils/Makefile
# used by cross/mingw-w64-i686-binutils/Makefile

DISTNAME=	binutils-2.39
CATEGORIES=	cross
MASTER_SITES=	${MASTER_SITE_GNU:=binutils/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://mingw-w64.org/

PATCHDIR=	${.CURDIR}/../../cross/mingw-w64-x86_64-binutils/patches
DISTINFO_FILE=	${.CURDIR}/../../cross/mingw-w64-x86_64-binutils/distinfo

USE_TOOLS+=		gmake

GNU_CONFIGURE=		yes
GNU_CONFIGURE_STRICT=	no # several sub-configures know --enable-nls
GNU_CONFIGURE_PREFIX=	${PREFIX}/cross/${MINGW_TARGET}
CONFIGURE_ARGS+=	--target=${MINGW_TARGET}
CONFIGURE_ARGS+=	--disable-nls
CONFIGURE_ARGS+=	--enable-lto
CONFIGURE_ARGS+=	--enable-plugins
CONFIGURE_ARGS+=	--enable-deterministic-archives
INFO_FILES=		yes

BUILDLINK_TRANSFORM+=	rm:-Werror

.include "../../cross/mingw-w64/Makefile.common"