File:
[cvs.NetBSD.org] /
pkgsrc /
cross /
cross-libtool-base /
Makefile
Revision
1.3:
download - view:
text,
annotated -
select for diffs
Sat Jul 9 06:37:58 2016 UTC (8 years, 4 months ago) by
wiz
Branches:
MAIN
CVS tags:
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
HEAD
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.
# $NetBSD: Makefile,v 1.3 2016/07/09 06:37:58 wiz Exp $
# XXX This is kludgerific copypasta of devel/libtool-base/Makefile for
# cross-compilation. Please make it go away!
###########################################################################
###########################################################################
#
# HEADS UP! DO NOT CHANGE THE VERSION OR PKGREVISION WITHOUT READING THIS:
#
###########################################################################
###########################################################################
#
# This package is maintained specially in order to preserve pkgsrc
# specific OS changes that diverge from the "out of the box" libtool.
# In order to keep this package in a maintainable condition, the .m4 files
# must be manipulated in order to generate the patch-* files.
#
# See devel/libtool/patches/manual.README for instructions on how to make
# these patch files properly; otherwise your changes WILL be lost on the
# next libtool update.
#
# DO NOT MAKE CHANGES TO patch-ab OR patch-ad WITHOUT FOLLOWING THESE
# INSTRUCTIONS. There are no exceptions to this rule.
#
###########################################################################
###########################################################################
.include "../../devel/libtool/Makefile.common"
# XXX Tweaked for cross-compilation.
#PKGNAME= ${DISTNAME:S/-/-base-/}
PKGNAME= ${DISTNAME:S/^libtool-/cross-libtool-base-${MACHINE_ARCH}-/}
PKGREVISION= 4
COMMENT= Generic shared library support script (the script itself)
CONFLICTS+= libtool<=1.3.5nb11
TEST_TARGET= check
OVERRIDE_DIRDEPTH.install-sh= 1
# Always build libraries and executables that use the runtime linker.
# in addition, disable libtool locking, as the test is broken on AIX,
# and results in files being locked indefinitely.
LDFLAGS.AIX+= -Wl,-brtl
CONFIGURE_ARGS.AIX+= --disable-libtool-lock
# The MIPSpro compiler doesn't support -c with -o, but the locking
# workaround is itself broken. Disable it unconditionally.
CONFIGURE_ARGS.IRIX+= --disable-libtool-lock
CFLAGS.SunOS+= ${_COMPILER_ABI_FLAG.${ABI}}
# We are going to want libtool to find the same versions of the C, C++,
# and Fortran compilers.
#
USE_LANGUAGES= c c++
GNU_CONFIGURE_PREFIX= ${PREFIX}/cross
CONFIGURE_ARGS+= --disable-ltdl-install
USE_TOOLS+= echo
# XXX Added for cross-compilation.
FILESDIR= ../../devel/libtool-base/files
.PHONY: fix-libtool
fix-libtool:
cd ${WRKSRC}; for f in libtool; do \
${SED} -e "s,-L${BUILDLINK_DIR}/lib,," $$f > $$f.new; \
if [ -x $$f ]; then ${CHMOD} +x $$f.new; fi; \
${MV} -f $$f.new $$f; \
done
post-build: fix-libtool
post-build:
@${SED} -e "s|@PREFIX@|"${PREFIX:Q}"|g" \
-e "s|@SH@|"${SH:Q}"|g" \
${FILESDIR}/shlibtool.in > ${WRKSRC}/shlibtool
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/shlibtool ${DESTDIR}${PREFIX}/cross/bin/shlibtool
BUILDLINK_DEPMETHOD.dlcompat= build
.include "../../mk/dlopen.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>