The NetBSD Project

CVS log for pkgsrc/cross/cc65/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / cross / cc65

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.18: download - view: text, markup, annotated - select for diffs
Tue Dec 8 11:32:00 2020 UTC (4 years ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, HEAD
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +4 -3 lines
cc65: Update to 2.19

Björn Esser (5):
      Replace GIT_SHA with a more versatile BUILD_ID definition.
      test/ref/otccex: Fix ramdomly occurring segfault.
      util/zlib/deflater: Fix several compiler warnings.
      zlib: Use correct (un)signedness of char in prototypes and functions.
      src/Makefile: Simplify BUILD_ID logic.

Chris Cacciatore (2):
      Added support for --large-alignment in ld65.
      Removed invalid link to ca65 document.

Curt J. Sampson (2):
      libsrc/*/kplot.s: Use cbm_kernal.inc symbols, not hardcoded addrs
      vic20/cputc: Fix incorrect CRAM_PTR at startup when using conio

Daniel Serpell (1):
      Fixes Atari OS devhdl_t, init field needs an JMP byte.

Dirk Jagdmann (2):
      fix whitespace
      fix the clean: target to remove any disk images.

Fabrizio Caruso (23):
      Fix Gamate RVS
      Hello world example for the Supervision
      Move screen init into crt0.s
      Improve init code readability
      Improve helloworld example for Supervision
      Add supervisionhello in samples/Makefile
      Use decimal for lcd size initialization
      Comments
      Improve comments
      Init is no longer in crt0.s
      Fix char 35 38 42 47 52
      Fix 4
      M N fixed
      Fix left arrow (char 77=13+64)
      Fix 127 (second left arrow)
      small m and n fixed
      Tentative solution for cgetc in Lynx
      Remove useless tax
      remove bra
      Second tentative fix
      stz
      kbhit checks KBEDG and getc resets KBEDG
      Optimizations

Greg King (38):
      Made the ld65 configure file's segment offset attribute accept zero as a value.
      Changed empty parameter lists into (void) lists on functions with asm() statements.
      Allowed old-style (K and R) function declarations to be fastcall.
      Added a charmap header that converts no character encodings.
      Added a .ORG keyword to ca65 structs/unions.
      Created a target and a library for the Commander X16 prototype computer.
      Updated the cx16 start-up to the emulator's release 32.
      Put the C64 code into cx16/_scrsize.s.
      Fixed a typo in the cx16 document.
      Added character codes to change between the two CBM fonts.
      Fixed cgetc().
      Made the "none" CPU allow all address sizes.
      Added new program descriptions to the list.
      Fixed problems with the Atari Lynx's TGI driver.
      Fixed error handling for missing names in ld65 configure files.
      Added the GIF switch to the X16 emulator's control port.
      Added VERA peek() and poke() to the cx16 library.
      Made assert() send SIGABRT when an assertion fails.
      Changed a "See also" link in the abort() and assert() descriptions from raise() to signal().
      Updated cx16 to match the Commander X16 ROMs and emulator, release 34.
      Added a standard mouse driver to the cx16 library.
      Added <cx16.h> to the function reference document.
      Changed sim65's internal error codes from 9-bit values to 7-bit values.
      Added the missing BANK_RAM array to the Commander X16's header.
      Updated the cx16 library to the Commander X16 Kernal's prerelease 35.
      Made the program-chaining exec() handle the X16 emulator's file-system.
      Added real-time clock functions to the cx16 library.
      Fixed the target guards around the usage messages.
      Made ca65 give error messages when it sees duplicate .define commands.
      Updated the cx16 library to the ROM's prerelease 36.
      Made cc65 detect a possibly missing argument at the end of a function argument list.
      Fixed a typo in commit 2e5fbe89cd3f67b06b292936dfdf4fdb104b7112.
      Fixed an error message printer.
      Added missing <tag> and <itemize> Linuxdoc tags to some ctype.h function descriptions.
      Updated the cx16 library to the Commander X16's ROM prerelease 37.
      Fixed some typos in the "large alignment" support.
      Added a JOY_FIRE() macro to the Atmos and Telestrat C headers.
      Put the Telestrat static drivers names together.

IrgendwerA8 (3):
      ctype size optimization
      Changes resulting from code review.
      Changes resulting from 2nd code review

Jeff Tranter (1):
      New OSI input routine based on disassembly of ROM code.

Jeremy Chadwick (3):
      doc: clarify need for .IMPORT on some special symbols
      Grammatical modifications
      Use the word 'macros' universally (not macroes)

Jeremy Rand (1):
      Update get_ostype.s

LRFLEW (3):
      Significantly faster rand() implementation
      Update comments in rand.s
      [cx16] Update ROM banks to new mapping

Lauri Kasanen (3):
      cc65: Add support for binary literals
      binlit: Add a few random leading zeros
      Document binary literals

Oliver Schmidt (15):
      Reduced shadow for h2 to improve readability.
      Minor URL update.
      Use MACHID to check for realtime clock.
      Expanded Sim65 zero page.
      Minor cleanup.
      Normalized Atari naming.
      Made use of 65C02 opcode (thx to polluks).
      Adjusted comments due to recent change.
      Matched comment to the one in the C header file.
      Some style adjustments.
      Adjusted tolower() and toupper() to https://github.com/cc65/cc65/pull/997
      Fixed tolower() and toupper() to save high byte.
      Shortened names and adjusted style.
      Disable potentially enabled double-width graphics.
      Removed --lib option from cl65.

Piotr Fusik (4):
      Optimize a negation in signed division.
      Don't set carry when already set.
      Swap the positive/negative paths to save a branch.
      Optimize sign extension.

Richard Halkyard (1):
      Reformat comments to style guide rules

Stefan (23):
      Fix colors for #948
      Fixed typos
      Fixed exit code #974
      Fixed C16 #978
      Update c16.sgml
      Update c128.sgml
      Update c64.sgml
      Update cbm510.sgml
      Update cx16.sgml
      Update funcref.sgml
      Update nes.sgml
      Update pce.sgml
      Update plus4.sgml
      Update vic20.sgml
      Update color.s
      Update conio.s
      Update cputc.s
      Update fast.s
      Update isfast.s
      Update revers.s
      Update slow.s
      Update status.s
      Preserve the accu

Stephan Mühlstrasser (5):
      Restructured according to review
      Remove obsolete comment
      Remove source file that was only used for testing
      Address review comments
      Removed redundant LDA

acqn (4):
      Corrected check in OptTransfers2 for register usage. Fixed Issue 992.
      Always insert a LDA after the removed PLA during the optimization in OptPushPop. Fixed Issue 971.
      Quick fix for the OptPushPop bug reported in Issue #337.
      Just disable OptPushPop if N/Z is used after the PLA. This is a more conservative way to fix Issue #971.

bbbradsmith (4):
      sim65 common define for paravirt hooks base location allows the loaded binary to take up as much space as possible restored some documentation of the hooks but without reference to specific location
      Fix silent crash failure on warning from linker command line define import size mismatch
      make linker generated export warning conistent with the import warning
      SEGMENT start of 0 should be valid

greg-king5 (1):
      Aligned comment.

itaych (1):
      PMG_SIZE_QUAD is 3, not 2.

jede (28):
      Add page 0 variables from Telemon 2.4
      Add XSCROH & XSCROB value
      Fix bug : gotoxy does not working because Y does not update the adress on the screen
      Add textcolor and bgcolor.s
      Fix gotoy changecolor
      fix typo
      fix import
      Fix typo and optimize
      Fix label, optimize code
      Fix bug with bgcolor and textcolor
      jmp instead of jsr
      Fix bgcolor and textcolor must return last color, jmp remove.
      Optimize Clrscr
      Cleaning import variables
      Fix comment and gotox force colour change
      Fix bug $FF
      Add cclear and cclearxy
      Cleaning
      Fix bug in tgi_line : HRS(X) parameters are 16 bits.
      Fix 16 bits values
      Telestrat joystick management
      Fix typo
      Fix typo
      Fix typo
      Fix bug
      Change name of the driver (telestrat-joy.s renamed to telestrat.s
      Fix eor bug
      Fixed the name of the driver

laubzega (2):
      Fix for #928.
      Minor formatting changes after review.

marko.lauke (2):
      +cc65 inline asm stp mnemonic support
      +code style

mc78 (11):
      Replaced plain 0's and 1's in exit statements with EXIT_SUCCESS or EXIT_FAILURE
      Added enum for cc65 exit codes. replaced stdlib exit code names constants in libsrc with cc65 exit code named constants
      Added comment to debugger exit with error
      Replaced enum in cc65.h by defines. added comment that cc65 exit constants should not redefine 0 and 1 as they are reserved for exit_success and exit_failure
      Removed CC65_ prefixes from exit statements in abort and assert code as well from definition
      Removed additional exit constants definitions from cc65.h to stdlih.h. Guarded the definitions by #ifdef. Removed cc65.h includes from abort and assert implementations.
      added additional empty line after header guard in cc65.h to conform to other headers
      Removed unnecessary #include <cc65.h> from convert.c Adjusted block comments to predominant style
      Changes in INSTALL routine from emd/c128-vdc.s. tmp1 was used at two places resulting in the bug that VDC_CSET was set to garbage on 16k VDC. pagecount and curpage were not reset on INSTALL resulting in non-reentrant code on static linkage of emd driver.
      Added reservation of second byte for pagecount
      Changed the order in which lo/hi bytes of vdc addr are set according to willimanilys ((z64k) suggestions. Changed offset for vdc ramsize detection from 000 to 000.

mrdudz (2):
      added regression test related to bug #1001
      store y first, then a. fix by willymanilly

Revision 1.17: download - view: text, markup, annotated - select for diffs
Sun May 10 13:51:34 2020 UTC (4 years, 7 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -8 lines
cross/cc65: remove unnecessary dependency on Perl

Revision 1.16: download - view: text, markup, annotated - select for diffs
Sat Mar 14 11:13:20 2020 UTC (4 years, 8 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -3 lines
(cross/cc65) Updated to 2.18

V2.18: Rearranged paravirt function vector.
May 30, 2019 156 commits to master since this release

- exit right below 6502 vectors.
- keep exit addr stable as it may be called from asm.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun Aug 11 13:18:17 2019 UTC (5 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -1 lines
Bump PKGREVISIONs for perl 5.30.0

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun May 19 03:41:30 2019 UTC (5 years, 6 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +10 -12 lines
Update to 2.17

* It seems that it is MAKE_JOBS_SAFE=yes
* Set LICENSE
* Set new HOMEPAGE and MASTER_SITES

Changelog:
V2.17: Switched Apple II output format to AppleSingle.

Although the primary target OS for the Apple II for sure isn't DOS 3.3 but ProDOS 8 the Apple II binary files contained a DOS 3.3 4-byte header. Recently I was made aware of the AppleSingle file format. That format is a much better way to transport Apple II meta data from the cc65 toolchain to the ProDOS 8 file system. Therefore I asked AppleCommander to support the AppleSingle file format. Now that there's an AppleCommander BETA with AppleSingle support it's the right time for this change.

I bumped version to 2.17 because of this from the perspective of Apple II users of course incompatible change.

V2.14 to V2.16:
Not available

Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Aug 22 09:43:10 2018 UTC (6 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Recursive bump for perl5-5.28.0

Revision 1.12: download - view: text, markup, annotated - select for diffs
Wed Jul 4 13:40:12 2018 UTC (6 years, 5 months ago) by jperkin
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
*: Move SUBST_STAGE from post-patch to pre-configure

Performing substitutions during post-patch breaks tools such as mkpatches,
making it very difficult to regenerate correct patches after making changes,
and often leading to substituted string replacements being committed.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sat Jul 9 06:37:58 2016 UTC (8 years, 5 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Fri Jun 12 10:48:35 2015 UTC (9 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu May 29 23:35:24 2014 UTC (10 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Fri May 31 12:39:46 2013 UTC (11 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Dec 3 14:36:39 2012 UTC (12 years ago) by wen
Branches: MAIN
CVS tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +8 -3 lines
Update to 2.13.3

Upstream changes:
(only for release 2.13.3)
This version is a bugfix release against 2.13.2. It includes about 40 bug
and documentation fixes and some minor improvements:

  * Fixed some macro issues (cc65).

  * Static const local data goes into RODATA, not DATA (cc65).

  * Fix error handling in .LEFT (ca65)

  * Fixed problems with 80 column mode (C128 library).

  * Fix problem when converting function to void pointer (cc65).

  * Fix register info for several runtime functions. Result was invalid code
    (cc65).

  * Fix smbx and rmbx instructions (da65).

  * Fix problem with .REPEAT (ca65).

  * Fix an error in the runtime division routine (cc65).

  * Fix problem with alignments >= 256 bytes (ca65).

  * The LINE function mistakenly enabled the BASIC ROM (TGI driver for C64).

  * Fix internal error caused by error recovery (or lack of) (cc65).

  * Fix invalid handling of signed int types in some cases (cc65).

  * Fix some issues with conio scrolling (C128 library).

  * Fix and improve the code for compares (cc65).

  * Fix some macro issues (ca65).

  * Fixed/improved several error messages (all tools).

  * Disallow __asm__ on global level (cc65).

  * Remove final jump to RESTOR for all CBM platforms (cc65 libraries).

  * Add missing export for CBM510 platform (cbm510 library).

  * Fix problem with access to structs returned by functions (cc65).

  * Fix an internal error in the code generator (cc65).

  * Merge back POSIX directory routines for the Atari (atari library).

  * Merge back Olivers C interrupt handling code (cc65 libraries).

  * Several documentation changes.

  * Several documentation fixes and improvements.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Oct 3 21:54:11 2012 UTC (12 years, 2 months ago) by wiz
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Oct 3 00:10:29 2012 UTC (12 years, 2 months ago) by asau
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +1 -3 lines
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Mar 8 11:33:35 2011 UTC (13 years, 9 months ago) by obache
Branches: MAIN
CVS tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +5 -1 lines
user-dest installation support.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Tue Jun 30 00:07:12 2009 UTC (15 years, 5 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -1 lines
Mark packages as MAKE_JOBS_SAFE=no that failed in a bulk build with
MAKE_JOBS=2 and worked without.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Mar 23 17:43:15 2009 UTC (15 years, 8 months ago) by darcy
Branches: MAIN
CVS tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Drop MAINTAINER as per request from old MAINTAINER.

Revision 1.1.1.1 (vendor branch): download - view: text, markup, annotated - select for diffs
Wed Oct 8 19:53:47 2008 UTC (16 years, 2 months ago) by wiz
Branches: TNF
CVS tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-20081008
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +0 -0 lines
Initial import of cc65-2.12.0, packaged for pkgsrc-wip by Tim Larson:

cc65 is a complete cross development package for 65(C)02 systems, including
a powerful macro assembler, a C compiler, linker, librarian and several
other tools.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Oct 8 19:53:47 2008 UTC (16 years, 2 months ago) by wiz
Branches: MAIN
Initial revision

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>