Up to [cvs.NetBSD.org] / pkgsrc / cross / avrdude
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.17 / (download) - annotate - [select for diffs], Wed Dec 29 23:03:21 2021 UTC (20 months, 3 weeks ago) by dsainty
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
HEAD
Changes since 1.16: +5 -5
lines
Diff to previous 1.16 (colored)
Update to avrdude 6.4 Version 6.4: * Major changes compared to the previous version: - libhidapi support (part of patch #8717) - use libhidapi as (optional) transport for CMSIS-DAP compliant debuggers (JTAGICE3 with firmware 3+, AtmelICE, EDBG, mEDBG) - UPDI support added (AVR8X family) - TPI support for USBtinyISP - TPI support for ft245r - TPI support for linuxgpio - AVR Doper uses libhidapi rather than raw libusb (patch #9033) - -P net:host:port can use IPv6 now (Posix systems only) - New configure option: -disable-libusb_1_0 - extended UPDI device context (> 64 Ki flash) - major overhaul of ft245r driver (patch #9327/#9328) - some improvements in linuxspi driver - Use -B <bitclock> rather than -b <baudrate> for linuxspi driver - unused lock byte bits are not masked on read anymore - parport support disabled by default; configure with --enable-parport to explicitly enable it * New devices supported: - ATmega328PB - AVR8X family, ATtiny1617, ATtiny817, ATtiny202, ATtiny204, ATtiny402, ATtiny404, ATtiny406, ATtiny804, ATtiny806, ATtiny807, ATtiny1604, ATtiny1606, ATtiny1607, ATtiny212, ATtiny214, ATtiny412, ATTiny414, ATtiny416, ATtiny417, ATtiny814, ATtiny816, ATtiny1614, ATtiny1616, ATtiny3214, ATtiny3216, ATtiny3217, ATmega3208, ATmega3209, ATmega4808, ATmega4809 - ATtiny841, ATtiny441 - ATmega64M1 - ATmega324A - ATmega808, ATmega809, ATmega1608, ATmega1609, AVR DA, AVR DB - LGT8FX88P, LGT8FX168P, LGT8FX328P - ATmega324PB - ATmega8A * New programmers supported: - ehajo-isp (commercial version of USBtiny) - XplainedPro in UPDI mode - XplainedMini in UPDI mode - JTAGICE3 in UPDI mode - Atmel Powerdebugger in all modes (JTAG, PDI, UPDI, debugWIRE, ISP) - linuxspi (direct SPI bus e.g. on Raspberry Pi devices) - PICkit4, Snap, PKoB - iseavrprog - XBeeBoot * Bugfixes: bug #47550: Linux GPIO broken bug #47718: "lfuse reads as" not displayed in verbose mode - SOLUTION bug #48084: Avoid compiled-in timestamp for reproducible release builds bug #47376: ATtiny841 description missing in configuration file bug #49455: support for tiny441 bug #57428: document when 'arduino' or 'wiring' should be used, and -D requirement of latter bug #58095: error setting efuse on atmega328pb variant bug #51409: Can't program EFUSE on ATmega32M1 bug #60753: Patch #1436 breaks multiple programmer/device combinations on MacOS BigSur bug #59525: Bogus error message because Copy/Paste typo in stk500.c bug #58078: [PATCH] buspirate: remove compound literals (fixes GCC>=9) bug #57453: [PATCH] fix reference to nonexistant -m option by changing to -U bug #59227: Add new part. How does one get a part added to the CONF file? bug #55009: no efuses for m164a/pa bug #55734: USBtiny programming of ATmega328p broken by Patch #9278 bug #58495: Add atmega324pb support to avrdude.conf.in bug #60863: avrftdi programming error probably caused by multiple, consecutive empty pages bug #50517: Reading fails if "immediate mode" for output file format is selected - fileio: invalid operation=1 bug #50630: Erase Cycle Counter options ( -y -Y n ) should be removed from usage Message bug #48767: ser_drain() for TCP on Windows doesn't work bug #46759: avrdude 6.1 -> 6.2 regression: lock byte verification error bug #58440: linuxgpio PIN limit too low bug #55462: wrong programmer id check in jtag3_getsync() and jtag3_close() bug #58994: VPP PWM still enabled at the end of programming process bug #57338: if safemode has to change fuses avrdude should exit with non-zero exit code bug #60575: Permission denied on macOS Big Sur * Patches: patch #9482: Add support for UPDI and AVR8X patch #9508: Add PowerDebugger and XPlained Mini in UPDI mode patch #9507: Fix UPDI chip erase patch #9506: Script to create device configuration stub from Atmel ATDF files patch #9423: Support ATtiny841 and ATtiny441 patch #9530: Update URL to Ladyada's USBtinyISP page. patch #9317: Support atmega64m1 as part patch #9222: Enable silent build patch #8924: Enable TPI for usbtiny patch #9033: avrdoper backend uses libhidapi instead of libusb patch #8580: FT245r support to select device by serial number patch #8910: ATxmega32c4 and ATxmega16c4 have wrong signatures patch #8219: Fix boot_start for xmega devices on jtagmkII patch #9185: Add extended_param to usbasp.c - erasing patch #8311: Add IPv6 support to the -Pnet:host:port option patch #9542: Correct "usersig" on avr8x devices patch #8128: Added new option to configure.ac script patch #8444: Proposal for modifications in -B and -U command options managment (partially) patch #9735: spelling error fix: psuedo -> pseudo patch #9893: [PATCH] Reader reads ftdi handle after main thread close it patch #9819: Address several leaks in SVN rev 1429 patch #9820: Fix some out-of-bounds/uninitialized issues patch #9818: correct typos in SVN rev 1429 patch #9732: usbtiny_paged_load overflows buffer e.g. when reading EEPROM patch #9966: Add JTAGICE3 in UPDI mode patch #9963: UsbAsp 3 MHz patch for UsbAsp-flash firmware patch #9816: Implement new programmer type: linuxspi patch #9811: ATmega328pb has efuse bit 3 patch #9744: Patch for ATMega324A support patch #10000: Add support for extended UPDI device context patch #9697: Add iseavrprog support patch #10017: uspasp / tpi: Automatically clear configuration byte (fuse) before writing it patch #8957: Allow reading prodsig memory from stk500v2 on xmega devices patch #9110: Let reserved fuse bits to be read as *don't care* patch #9253: Fix for giving terminal_mode commands more than 20 arguments patch #9320: fix TPI RESET in bitbang.c patch #9079: Fix ftdi_syncbb teardown (supersedes #9893, superseded by #9328) patch #9122: Fixed MISO sampling in ftdi_syncbb patch #9123: ftdi_syncbb: use FT245R_CYCLES in ft245r_set_bitclock() patch #8719: Support Over-the-Air bootloading with XBeeBoot patch #9757: Fix ATtiny817 Xplained Mini programmer patch #9327: ft245r.c: add TPI support (patches 1-4) patch #9328: ft245r.c: add TPI support (patches 5-7) patch #10027: linuxspi: Add reset pulse, according to AVR programming algorithm patch #10028: linuxspi: close() only when necessary patch #10029: linuxspi: Report GPIO_GET_LINEHANDLE_IOCTL errors patch #10030: linuxspi: Support inverted GPIO pin patch #10031: linuxspi: Support GPIO uAPI v2 (no-id): Improve documentation of linuxspi driver, provide portname default (no-id): Use -B <bitclock> rather than -b <baudrate> for linuxspi driver patch #9304: [Bug #48767] Implemented WinSock variation of "ser_drain(...)" functionality patch #8996: Remove lock byte read mask (bug#21954, bug#46759) patch #8923: Enable TPI for linuxgpio patch #10153: linuxspi: Support "-E reset" and "-E noreset" * Internals: - New avrdude.conf keyword "family_id", used to verify SIB attributes on AVR8X architecture if device is locked.
Revision 1.16 / (download) - annotate - [select for diffs], Tue Oct 26 10:07:51 2021 UTC (22 months, 3 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.15: +2 -2
lines
Diff to previous 1.15 (colored)
cross: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes The following distfiles could not be fetched (some may be fetched conditionally): ./cross/avr-gcc/distinfo isl-0.24.tar.bz2
Revision 1.15 / (download) - annotate - [select for diffs], Thu Oct 7 13:30:22 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.14: +1 -2
lines
Diff to previous 1.14 (colored)
cross: Remove SHA1 hashes for distfiles
Revision 1.14 / (download) - annotate - [select for diffs], Sun Jan 29 02:24:54 2017 UTC (6 years, 7 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.13: +6 -6
lines
Diff to previous 1.13 (colored)
Updated cross/avrdude to 6.3
Revision 1.13 / (download) - annotate - [select for diffs], Tue Nov 3 00:47:43 2015 UTC (7 years, 10 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.12: +2 -1
lines
Diff to previous 1.12 (colored)
Add SHA512 digests for distfiles for cross category Existing SHA1 digests verified, all found to be the same on the machine holding the existing distfiles (morden). Existing SHA1 digests retained for now as an audit trail.
Revision 1.12 / (download) - annotate - [select for diffs], Tue Oct 7 15:10:29 2014 UTC (8 years, 11 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4
Changes since 1.11: +5 -6
lines
Diff to previous 1.11 (colored)
Update avrdude 6.0.1 to 6.1 ---------------------------------------------------------------------- * Major changes compared to the previous version: - Atmel EDBG protocol support added (JTAGICE3, XplainedPro, Atmel-ICE) * New programmers supported: - Atmel DFU, using FLIP protocol version 1 (AT90USB and ATmega*U* devices), or version 2 (Xmega devices) - Atmel-ICE (ARM/AVR), JTAG, PDI, debugWIRE, ISP modi * Bugfixes - bug #40055: AVRDUDE segfaults when writing eeprom - bug #40085: Typo fix in fuses report (for 6.1-svn-20130917) - bug #40782: Verify errors for object size > 16 k on x32e5 due to typo in avrdude.conf - bug #40817: Elf file support (possibly) not working on 6.0.1 windows build - bug #40897: AT Mega2560 not correctly programmed with stk500(v1) ISP (solution patch) - bug #41357: OS X: Avrdude messes with the usb stack? - bug #41402: dfu.c missing include <stdint.h> - patch #7896: DFU FLIPv2 programming support - patch #XXXX: xxx * Internals: - (Some) programmers can take a list of USB PIDs now.
Revision 1.11 / (download) - annotate - [select for diffs], Fri Dec 6 07:27:15 2013 UTC (9 years, 9 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2,
pkgsrc-2014Q1-base,
pkgsrc-2014Q1,
pkgsrc-2013Q4-base,
pkgsrc-2013Q4
Changes since 1.10: +10 -9
lines
Diff to previous 1.10 (colored)
(Upstream) - Bump version 5.11 to 6.0.1 (See cvs log for Makefile for changes). (pkgsrc) - Add patches/patch-fileio_c to avoid following problem: fileio.c:957:3: warning: implicit declaration of function 'elf_getshdrstrndx'
Revision 1.10 / (download) - annotate - [select for diffs], Sat Jan 26 22:10:13 2013 UTC (10 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
Fix for automake-1.13.
Revision 1.9 / (download) - annotate - [select for diffs], Tue Feb 7 00:21:48 2012 UTC (11 years, 7 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base,
pkgsrc-2012Q4,
pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1
Changes since 1.8: +6 -6
lines
Diff to previous 1.8 (colored)
PR/45924 --- update to 5.11 with minor changes (1) update 5.10 to 5.11 (2) Trying to remove pkglint -Wall warning (3) Update HOMEPAGE URL ----- ----- ----- AVRDUDE 5.11 relesed (2011/8/27 By joerg_wunsch) Finally, more than 1.5 years after the previous release, AVRDUDE 5.11 is finally done. This is mostly a bugfix release, but also includes a few enhancements. The two most important enhancements are: - TPI (i.e. ATtiny4/5/9/10) programming support for bitbang programmers. - FTDI MPSSE (FT2232 etc.) bitbang support. ----- ----- -----
Revision 1.8 / (download) - annotate - [select for diffs], Mon Feb 8 01:47:14 2010 UTC (13 years, 7 months ago) by jakllsch
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base,
pkgsrc-2011Q4,
pkgsrc-2011Q3-base,
pkgsrc-2011Q3,
pkgsrc-2011Q2-base,
pkgsrc-2011Q2,
pkgsrc-2011Q1-base,
pkgsrc-2011Q1,
pkgsrc-2010Q4-base,
pkgsrc-2010Q4,
pkgsrc-2010Q3-base,
pkgsrc-2010Q3,
pkgsrc-2010Q2-base,
pkgsrc-2010Q2,
pkgsrc-2010Q1-base,
pkgsrc-2010Q1
Changes since 1.7: +8 -8
lines
Diff to previous 1.7 (colored)
Update to avrdude-5.10. pkgsrc changes: Rework AVRISP mkII stall workaround. summary of upstream changes since 5.8: - Fix problem with loading intel hex rom files that exceed 0x10000 bytes. - Fix FreeBSD default serial port name. - jtagmkII.c: If entering JTAG mode fails with a bad JTAG ID message, retry with external reset applied (in case the target is in sleep mode or has asserted the JTD bit). - Fix build for GNU/kFreeBSD.
Revision 1.7 / (download) - annotate - [select for diffs], Tue Jan 26 02:01:47 2010 UTC (13 years, 7 months ago) by jakllsch
Branch: MAIN
Changes since 1.6: +8 -7
lines
Diff to previous 1.6 (colored)
Work around AVRISP mkII sync timeout/retry on NetBSD. I'm guessing this is really a oddity of NetBSD's USB stack, but this seems to work too. Also, hello nb2 and set LICENSE. (This commit bumps most of the patch files only because of pkgdiff timestamp formatting differences. Sigh.)
Revision 1.6 / (download) - annotate - [select for diffs], Thu Aug 27 15:34:48 2009 UTC (14 years ago) by hasso
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base,
pkgsrc-2009Q4,
pkgsrc-2009Q3-base,
pkgsrc-2009Q3
Changes since 1.5: +10 -8
lines
Diff to previous 1.5 (colored)
Update to 5.8. Upstream changelog is obviously too massive to paste it here. All hard update work done by Simon 'corecode' Schubert and minor modifications by me.
Revision 1.5 / (download) - annotate - [select for diffs], Fri Sep 28 21:11:49 2007 UTC (15 years, 11 months ago) by dmcmahill
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base,
pkgsrc-2009Q2,
pkgsrc-2009Q1-base,
pkgsrc-2009Q1,
pkgsrc-2008Q4-base,
pkgsrc-2008Q4,
pkgsrc-2008Q3-base,
pkgsrc-2008Q3,
pkgsrc-2008Q2-base,
pkgsrc-2008Q2,
pkgsrc-2008Q1-base,
pkgsrc-2008Q1,
pkgsrc-2007Q4-base,
pkgsrc-2007Q4,
pkgsrc-2007Q3-base,
pkgsrc-2007Q3,
cwrapper,
cube-native-xorg-base,
cube-native-xorg
Changes since 1.4: +5 -3
lines
Diff to previous 1.4 (colored)
Repair compilation on sunos and maybe others. Added some missing autoconf tests, fixed a non portable call to the shell builtin test, and use the pkgsrc DEFAULT_SERIAL_DEVICE variable for setting the serial device.
Revision 1.4 / (download) - annotate - [select for diffs], Mon Dec 11 16:26:39 2006 UTC (16 years, 9 months ago) by wennmach
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base,
pkgsrc-2007Q2,
pkgsrc-2007Q1-base,
pkgsrc-2007Q1,
pkgsrc-2006Q4-base,
pkgsrc-2006Q4
Changes since 1.3: +6 -12
lines
Diff to previous 1.3 (colored)
Update avrdude to version 5.2. Significant enhancements in this version are: o Support for JTAGICE MkII device o New devices supported: - AT90CAN128 ... o Support for STK500 Version 2 Protocol (the latter being the principal reason for the update, as the recent firmware on the STK500 development boards requires protocol version 2)
Revision 1.3 / (download) - annotate - [select for diffs], Wed Mar 2 13:20:40 2005 UTC (18 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base,
pkgsrc-2006Q3,
pkgsrc-2006Q2-base,
pkgsrc-2006Q2,
pkgsrc-2006Q1-base,
pkgsrc-2006Q1,
pkgsrc-2005Q4-base,
pkgsrc-2005Q4,
pkgsrc-2005Q3-base,
pkgsrc-2005Q3,
pkgsrc-2005Q2-base,
pkgsrc-2005Q2,
pkgsrc-2005Q1-base,
pkgsrc-2005Q1
Changes since 1.2: +3 -1
lines
Diff to previous 1.2 (colored)
Fix html manual generation with texi2html, and depend on latest version, since it causes PLIST changes. Adapt PLIST. Bump PKGREVISION.
Revision 1.2 / (download) - annotate - [select for diffs], Thu Feb 24 10:16:52 2005 UTC (18 years, 7 months ago) by agc
Branch: MAIN
Changes since 1.1: +2 -1
lines
Diff to previous 1.1 (colored)
Add RMD160 digests
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Thu Jul 17 19:09:23 2003 UTC (20 years, 2 months ago) by wennmach
Branch: TNF
CVS Tags: pkgsrc-base,
pkgsrc-2004Q4-base,
pkgsrc-2004Q4,
pkgsrc-2004Q3-base,
pkgsrc-2004Q3,
pkgsrc-2004Q2-base,
pkgsrc-2004Q2,
pkgsrc-2004Q1-base,
pkgsrc-2004Q1,
pkgsrc-2003Q4-base,
pkgsrc-2003Q4
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
avrdude - Program for programming the on-chip memory of Atmel AVR CPUs Submitted by Karl Janmar <karlj@mdstud.chalmers.se> in PR 22139, with several changes by myself. Original package from FreeBSD.
Revision 1.1 / (download) - annotate - [select for diffs], Thu Jul 17 19:09:23 2003 UTC (20 years, 2 months ago) by wennmach
Branch: MAIN
Initial revision