[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cross / avr-binutils

Annotation of pkgsrc/cross/avr-binutils/Makefile, Revision 1.30

1.30    ! rillig      1: # $NetBSD: Makefile,v 1.29 2018/07/16 12:56:48 mef Exp $
1.1       wennmach    2:
1.29      mef         3: DISTNAME=              binutils-2.30
1.20      mef         4: PKGNAME=               ${DISTNAME:S/^/avr-/}
1.1       wennmach    5: CATEGORIES=            cross
1.7       uebayasi    6: MASTER_SITES=          ${MASTER_SITE_GNU:=binutils/}
1.20      mef         7: EXTRACT_SUFX=          .tar.bz2
1.1       wennmach    8:
1.14      wiz         9: MAINTAINER=            pkgsrc-users@NetBSD.org
1.1       wennmach   10: COMMENT=               GNU binutils for Atmel AVR 8-bit RISC microcontrollers
1.20      mef        11: LICENSE=               gnu-gpl-v3
1.1       wennmach   12:
1.21      dsainty    13: # No need to use makeinfo - this package doesn't install the documentation.
                     14: USE_TOOLS+=            gmake
1.20      mef        15: USE_LIBTOOL=           yes
1.2       seb        16: GNU_CONFIGURE=         yes
1.30    ! rillig     17: GNU_CONFIGURE_STRICT=  no # several sub-configures know --enable-nls
1.1       wennmach   18: USE_PKGLOCALEDIR=      yes
1.15      hasso      19: USE_GNU_CONFIGURE_HOST=        no
1.26      mef        20:
                     21: # follows to devel/binutils
                     22: # PR pkg/48504, ksh is sufficient for NetBSD 5.2 and NetBSD 6.1
                     23: .include "../../mk/bsd.prefs.mk"
                     24: .if !empty(MACHINE_PLATFORM:MNetBSD-[5-6].*-*) && \
                     25:        empty(MACHINE_PLATFORM:MNetBSD-6.99.*-*)
                     26: USE_TOOLS+=            ksh
1.25      mef        27: CONFIG_SHELL=          ksh
1.26      mef        28: .endif
1.2       seb        29:
1.20      mef        30: CONFIGURE_ARGS+=       --disable-werror --target=avr --disable-nls
                     31:
                     32: AUTO_MKDIRS=           yes
1.2       seb        33:
                     34: # Prevent the need to run texi2pod.pl and pod2man hence
                     35: # the need for perl as build dependency.
                     36: post-configure:
1.20      mef        37:        set -e;                                                 \
1.2       seb        38:        cd ${WRKSRC};                                           \
                     39:        for f in ld/ldver.texi ld/ld.1 gas/doc/gasver.texi      \
                     40:          gas/doc/as.1; do                                      \
                     41:                ${TOUCH} $${f};                                 \
                     42:        done
1.1       wennmach   43:
1.20      mef        44: # emulator/simulavr wants libbfd.so or libbfd.a and bfd.h
                     45: #  --with-bfd=path  location of AVR-binutils version of libbfd install
                     46: #  where include/bfd.h and lib/libbfd.a are found (from binutils)
                     47: post-build:
                     48:        set -e;                                                 \
                     49:        (cd ${WRKSRC}/bfd; ${GMAKE} all libbfd.a);
                     50:
                     51: post-install:
                     52:        # Emulator/simulvar needs library files
                     53:        (cd ${WRKSRC}/bfd;                                      \
                     54:        ${GMAKE} install-exec install-data;                     \
                     55:        ${LIBTOOL} --mode install ${INSTALL_DATA} libbfd.la ${DESTDIR}${PREFIX}/avr/lib;        \
                     56:        ${INSTALL_DATA} bfd.h ${DESTDIR}${PREFIX}/avr/include;  \
                     57:        )
                     58:        # emulator/simulavr wants following header files
                     59:        (cd ${WRKSRC}/include;                                  \
                     60:        for f in ansidecl.h symcat.h; do                        \
                     61:          ${INSTALL_DATA} $$f ${DESTDIR}${PREFIX}/avr/include;  \
                     62:        done;   \
                     63:        )
1.1       wennmach   64: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>