[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cross / avr-binutils

Annotation of pkgsrc/cross/avr-binutils/Makefile, Revision 1.21

1.21    ! dsainty     1: # $NetBSD: Makefile,v 1.20 2013/08/07 02:41:30 mef Exp $
1.1       wennmach    2:
1.20      mef         3: DISTNAME=              binutils-2.23.2
                      4: PKGNAME=               ${DISTNAME:S/^/avr-/}
1.1       wennmach    5: CATEGORIES=            cross
1.7       uebayasi    6: MASTER_SITES=          ${MASTER_SITE_GNU:=binutils/}
1.20      mef         7: EXTRACT_SUFX=          .tar.bz2
1.1       wennmach    8:
1.14      wiz         9: MAINTAINER=            pkgsrc-users@NetBSD.org
1.1       wennmach   10: COMMENT=               GNU binutils for Atmel AVR 8-bit RISC microcontrollers
1.20      mef        11: LICENSE=               gnu-gpl-v3
1.1       wennmach   12:
1.21    ! dsainty    13: # No need to use makeinfo - this package doesn't install the documentation.
        !            14: USE_TOOLS+=            gmake
1.20      mef        15: USE_LIBTOOL=           yes
1.2       seb        16: GNU_CONFIGURE=         yes
1.1       wennmach   17: USE_PKGLOCALEDIR=      yes
1.15      hasso      18: USE_GNU_CONFIGURE_HOST=        no
1.2       seb        19:
1.20      mef        20: CONFIGURE_ARGS+=       --disable-werror --target=avr --disable-nls
                     21:
                     22: AUTO_MKDIRS=           yes
1.2       seb        23:
                     24: # Prevent the need to run texi2pod.pl and pod2man hence
                     25: # the need for perl as build dependency.
                     26: post-configure:
1.20      mef        27:        set -e;                                                 \
1.2       seb        28:        cd ${WRKSRC};                                           \
                     29:        for f in ld/ldver.texi ld/ld.1 gas/doc/gasver.texi      \
                     30:          gas/doc/as.1; do                                      \
                     31:                ${TOUCH} $${f};                                 \
                     32:        done
1.1       wennmach   33:
1.20      mef        34: # emulator/simulavr wants libbfd.so or libbfd.a and bfd.h
                     35: #  --with-bfd=path  location of AVR-binutils version of libbfd install
                     36: #  where include/bfd.h and lib/libbfd.a are found (from binutils)
                     37: post-build:
                     38:        set -e;                                                 \
                     39:        (cd ${WRKSRC}/bfd; ${GMAKE} all libbfd.a);
                     40:
                     41: post-install:
                     42:        # Emulator/simulvar needs library files
                     43:        (cd ${WRKSRC}/bfd;                                      \
                     44:        ${GMAKE} install-exec install-data;                     \
                     45:        ${LIBTOOL} --mode install ${INSTALL_DATA} libbfd.la ${DESTDIR}${PREFIX}/avr/lib;        \
                     46:        ${INSTALL_DATA} bfd.h ${DESTDIR}${PREFIX}/avr/include;  \
                     47:        )
                     48:        # Rename to avoid conflict to native and other cross assembler.
                     49:        # and clang differs its path so, (the same as h8300-elf-binutils).
                     50:        (cd ${DESTDIR}${PREFIX};                                \
                     51:        for d in ${MACHINE_ARCH}/libiberty.a libiberty.a;       \
                     52:          do if [ -f lib/$$d ]; then                            \
                     53:                ${MV}   lib/$$d  avr/lib/libiberty.a;           \
                     54:                break;                                          \
                     55:             fi;                                                \
                     56:          done; )
                     57:        # emulator/simulavr wants following header files
                     58:        (cd ${WRKSRC}/include;                                  \
                     59:        for f in ansidecl.h symcat.h; do                        \
                     60:          ${INSTALL_DATA} $$f ${DESTDIR}${PREFIX}/avr/include;  \
                     61:        done;   \
                     62:        )
1.1       wennmach   63: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>