File:  [cvs.NetBSD.org] / pkgsrc / converters / orcus / Makefile
Revision 1.38: download - view: text, annotated - select for diffs
Sat Feb 5 04:14:31 2022 UTC (2 years, 10 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, HEAD
orcus: Update to 0.17.2

Changelog:
orcus 0.17.2

* ods

  * fixed a bug where the state of style:cell-protect="none" was not
    explicitly pushed, thereby having had the same effect as not having this
    attribute.  After the fix, style:cell-protect="none" will explicitly push
    the hidden state to false, locked state to false, and the formula-hidden
    state to false.

orcus 0.17.1

* general

  * addressed a number of coverity issues.

  * removed a variety of compiler warnings.

* ods

  * re-generated sax parser tokens from ODF v1.3.

  * revised the style import code to only push style attributes that are
    actually specified in the XML.

* xls-xml

  * revised the XML structure validation strategy to ignore any mis-placed
    elements and their sub structures rather than aborting the import.

orcus 0.17.0

* general

  * set the baseline C++ version to 17.

  * cleaned up the public API to replace pstring with std::string_view, union
    with std::variant, and boost::optional with std::optional.  With this
    change, the public API no longer has dependency on boost.

* spreadsheet document

  * switched to using ixion::model_iterator for horizontal iteration of cells
    instead of using mdds::mtv::collection.

  * fixed a bug where exporting a spreadsheet document containing adjacent
    merged cells regions to html incorrectly exported the merged cell areas.

* xlsx

  * cached cell values are now correctly loaded from the file.

* sax parser

  * utf-8 names are now allowed as element and attribute names.

* css parser

  * unquoted utf-8 property values are now allowed.

* orcus-json

  * fixed segmentation fault when using --mode structure with the Windows
    build.

  * added yaml output option.

* xml-map

  * fixed a bug where mapping of an XML document with namespace aliases
    sometimes corrupts the alias values.

* python

  * added orcus.FormulaTokenOp enum type which describes type formula token
    operator types in a more finer grained manner.

* documentation

  * added notes to how to use orcus-xml and orcus-json to map XML and JSON
    documents to spreadsheet documents.

# $NetBSD: Makefile,v 1.38 2022/02/05 04:14:31 ryoon Exp $

DISTNAME=	liborcus-0.17.2
PKGNAME=	${DISTNAME:S/liborcus/orcus/}
CATEGORIES=	converters
MASTER_SITES=	https://kohei.us/files/orcus/src/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://gitlab.com/orcus/orcus
COMMENT=	Import filter library for spreadsheet documents (0.16 branch)
LICENSE=	mpl-2.0

USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_TOOLS+=		gmake pkg-config
GNU_CONFIGURE=		yes
# python detection completely broken
CONFIGURE_ARGS+=	--disable-python
CONFIGURE_ARGS+=	--disable-werror

PKGCONFIG_OVERRIDE+=	liborcus.pc.in
PKGCONFIG_OVERRIDE+=	liborcus-spreadsheet-model.pc.in

PTHREAD_AUTO_VARS=	yes

.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/mdds/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../math/libixion/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>