[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / converters / libiconv

File: [cvs.NetBSD.org] / pkgsrc / converters / libiconv / Makefile (download)

Revision 1.15, Fri Jan 3 12:32:59 2003 UTC (21 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.14: +2 -2 lines

Fix test target: do not use csh syntax (|&). Closes PR 19647.

# $NetBSD: Makefile,v 1.15 2003/01/03 12:32:59 wiz Exp $
#

DISTNAME=		libiconv-1.8
CATEGORIES=		converters
MASTER_SITES=		${MASTER_SITE_GNU:=libiconv/}

MAINTAINER=		rh@netbsd.org
HOMEPAGE=		http://www.gnu.org/software/libiconv/
COMMENT=		character set conversion library

USE_BUILDLINK2=		YES
GNU_CONFIGURE=		YES
USE_LIBTOOL=		YES
LIBTOOL_OVERRIDE+=	${WRKSRC}/libtool
LIBTOOL_OVERRIDE+=	${WRKSRC}/libcharset/libtool

.include "../../mk/bsd.prefs.mk"

.if (${OPSYS} == SunOS)
PLIST_SUBST+=		SUNOS=
.else
PLIST_SUBST+=		SUNOS="@comment "
.endif

# remove any existing charset.alias; if it already exists, libiconv does
# not overwrite it, and older versions of libiconv wrote incorrect
# charset.alias files, which were not removed during deinstall since
# other packages touched them.
pre-install:
	${RM} -f ${PREFIX}/lib/charset.alias

test: build
	cd ${WRKSRC} && ${MAKE_ENV} ${MAKE_PROGRAM} check 2>&1 | tee ${WRKDIR}/check.log

.include "../../mk/bsd.pkg.mk"