[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / converters / bibtex2html

File: [cvs.NetBSD.org] / pkgsrc / converters / bibtex2html / Makefile (download)

Revision 1.22, Fri Mar 2 21:20:14 2007 UTC (17 years, 1 month ago) by tonio
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.21: +2 -2 lines

update converters/bibtex2html to 1.85

Version 1.85, 2/11/2006
=======================
 o fixed HTML output in f_bib.html: <pre> no more enclosed in <p>;
   bibtex fields now typeset in lowercase; added links back to f.html
 o macros \textin (<sub>), \textsu (<sup>), \textsi (<i>),
   and macros \textln, \textos, \textdf, \textsw without translation
 o fixed bug in --quiet under Windows
 o option -t now sets the title of f_bib.html too (and of entries
   files when used with -multiple)

Version 1.84, 19/10/2006
========================
 o improved support for MRNUMBER of AMS styles: only first word used
   in URL link

Version 1.83, 13/09/2006
========================
 o support for DOI links: a field "DOI = {xxx}" will be recognized, if any,
   and a link to http://dx.doi.org/xxx will be displayed;
   option -no-doi turns it off and option -doi-prefix <url> sets a
   different prefix for the DOI urls
 o macro \H (Hungarian umlauts)
 o new option -linebreak to insert a linebreak between an entry and its links
 o new option -use-table to enforce the use of a table (to be used
   _after_ -no-keys if needed)

# $NetBSD: Makefile,v 1.22 2007/03/02 21:20:14 tonio Exp $

DISTNAME=	bibtex2html-1.85
CATEGORIES=	converters
MASTER_SITES=	http://www.lri.fr/~filliatr/ftp/bibtex2html/

MAINTAINER=	minskim@NetBSD.org
HOMEPAGE=	http://www.lri.fr/~filliatr/bibtex2html/
COMMENT=	Collection of tools for translating from BibTeX to HTML

BUILD_DEPENDS+=	hevea-[0-9]*:../../textproc/hevea

GNU_CONFIGURE=	yes
USE_TOOLS+=	perl:run
TEX_ACCEPTED=	teTeX3

SUBST_CLASSES+=		paths
SUBST_MESSAGE.paths=	Fixing hardcoded paths.
SUBST_STAGE.paths=	pre-configure
SUBST_FILES.paths=	aux2bib.1
SUBST_SED.paths=	-e 's,/usr/share,${PREFIX}/share,g'

INSTALLATION_DIRS=	bin ${PKGMANDIR}/man1

post-build:
	cd ${WRKSRC}; ${MAKE} doc

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/aux2bib ${PREFIX}/bin
	${INSTALL_PROGRAM} ${WRKSRC}/bibtex2html ${PREFIX}/bin
	${INSTALL_PROGRAM} ${WRKSRC}/bib2bib ${PREFIX}/bin
	${INSTALL_MAN} ${WRKSRC}/bibtex2html.1 ${PREFIX}/${PKGMANDIR}/man1
	${INSTALL_MAN} ${WRKSRC}/bibtex2html.1 ${PREFIX}/${PKGMANDIR}/man1/bib2bib.1
	${INSTALL_MAN} ${WRKSRC}/aux2bib.1 ${PREFIX}/${PKGMANDIR}/man1/aux2bib.1
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/${PKGBASE}
	${INSTALL_DATA} ${WRKSRC}/manual.html ${PREFIX}/share/doc/${PKGBASE}
	${INSTALL_DATA} ${WRKSRC}/manual.ps ${PREFIX}/share/doc/${PKGBASE}

.include "../../lang/ocaml/buildlink3.mk"
.include "../../mk/tex.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"