[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / comms / ruby-termios

File: [cvs.NetBSD.org] / pkgsrc / comms / ruby-termios / Makefile (download)

Revision 1.17, Sat Aug 18 14:26:59 2007 UTC (16 years, 7 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.16: +3 -4 lines

Update ruby-termios package to 0.9.5.


2007-05-30  akira yamada  <akira@arika.org>

	* extconf.rb: rb_io_t test isn't needed for Ruby 1.6.

	* version 0.9.5.

2007-05-29  Tanaka Akira  <akr@fsij.org>

	* extconf.rb: check rb_io_t.
	  check fd member in OpenFile.

	* termios.c: support Ruby 1.9.
	  use unsigned long for flags bigger than Fixnum such as CRTSCTS.
	  use rb_sys_fail instead of rb_raise(rb_eRuntimeError).
	  (Termios_to_termios): use rb_ary_entry to access cc_ary to avoid SEGV.
	  (termios_tcgetpgrp): use pid_t.
	  (termios_tcsetpgrp): ditto.
	  (Termios::Termios#dup): defined to duplicate cc.
	  (Termios::Termios#clone): ditto.
	  (Termios::POSIX_VDISABLE): defined.
	  (Termios::CCINDEX_NAMES): defined.
	  (Termios::IFLAG_NAMES): defined.
	  (Termios::OFLAG_NAMES): defined.
	  (Termios::OFLAG_CHOICES): defined.
	  (Termios::CFLAG_NAMES): defined.
	  (Termios::CFLAG_CHOICES): defined.
	  (Termios::LFLAG_NAMES): defined.
	  (Termios::BAUD_NAMES): defined.
	  (Termios::IUTF8): defined.
	  (Termios::VDSUSP): defined for 4.4BSD.
	  (Termios::VSTATUS): defined for 4.4BSD.
	  (Termios::MDMBUF): defined for 4.4BSD.

	* lib/termios.rb: new file.  inspect and pretty_print defined.

2005-05-30  akira yamada  <akira@arika.org>

	* termios.c: applied a patch which makes ruby-termios work under
	  both ruby1.8 and ruby1.9.  [ruby-talk:143781]
	  Thanks to: Akr.

# $NetBSD: Makefile,v 1.17 2007/08/18 14:26:59 taca Exp $
#

DISTNAME=	ruby-termios-0.9.5
PKGNAME=	${RUBY_PKGPREFIX}-termios-0.9.5
CATEGORIES=	comms ruby
MASTER_SITES=	http://arika.org/archive/

MAINTAINER=	taca@NetBSD.org
HOMEPAGE=	http://arika.org/ruby/termios
COMMENT=	Ruby extension to termios library

RUBY_HAS_ARCHLIB=	yes
USE_RUBY_EXTCONF=	yes

DOCS=			ChangeLog README TODO.ja
EXAMPLES=		modem_check0.rb modem_check1.rb modem_check2.rb \
			secret_input1.rb secret_input2.rb

post-install:
	${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/termios
.for f in ${DOCS}
	${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/termios
.endfor
	${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/termios
.for f in ${EXAMPLES}
	${INSTALL_DATA} ${WRKSRC}/examples/${f} ${RUBY_EXAMPLESDIR}/termios
.endfor

.include "../../lang/ruby/modules.mk"
.include "../../mk/bsd.pkg.mk"