[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / comms / p5-pilot-link

Annotation of pkgsrc/comms/p5-pilot-link/Makefile, Revision 1.51

1.51    ! wiz         1: # $NetBSD: Makefile,v 1.50 2012/10/03 21:54:06 wiz Exp $
1.17      rh          2: #
1.1       tron        3:
1.17      rh          4: .include "../../comms/pilot-link/Makefile.common"
1.1       tron        5:
1.35      wiz         6: PKGNAME=               p5-${DISTNAME}
1.51    ! wiz         7: PKGREVISION=           6
1.17      rh          8:
1.19      martti      9: COMMENT=               Perl bindings for pilot-link
1.17      rh         10:
1.42      joerg      11: MAKE_JOBS_SAFE=                no
                     12:
1.31      reed       13: BUILDLINK_API_DEPENDS.pilot-link-libs= pilot-link-libs>=${PILOT_LINK_VERS}
1.17      rh         14:
1.24      jlam       15: USE_TOOLS+=            gmake
1.7       jlam       16:
1.47      dholland   17: CONFIGURE_ARGS+=       --enable-conduits
1.29      rillig     18: CONFIGURE_ARGS+=       --with-perl=${PERL5:Q}
1.17      rh         19: PERL5_CONFIGURE=       NO
1.35      wiz        20: PERL5_PACKLIST=                auto/PDA/Pilot/.packlist
1.33      markd      21: PERL5_LDFLAGS=         -lpisock
                     22:
1.47      dholland   23: REPLACE_PERL+=         bindings/Perl/h2xs-pilot-link
                     24: REPLACE_PERL+=         bindings/Perl/dump.pl
                     25: REPLACE_PERL+=         bindings/Perl/blib/lib/PDA/dump.pl
                     26:
                     27: # Cannot use REPLACE_PERL for this because the substitution needs to be
                     28: # done either after build (on src/pilot-ietf2datebook, which is a build
                     29: # product) or not on the first line (on src/pilot-ietf2datebook.pl, which
                     30: # generates the installed script).
                     31: SUBST_CLASSES+=                moreperl
                     32: SUBST_STAGE.moreperl=  post-build
                     33: SUBST_MESSAGE.moreperl=        Fixing Perl interpreter in build products.
                     34: SUBST_FILES.moreperl=  src/pilot-ietf2datebook
                     35: SUBST_SED.moreperl=    -e 1s,/usr/bin/env.perl,${PERL5:Q},
1.17      rh         36:
1.43      wiz        37: INSTALL_DIRS=          bindings
1.36      joerg      38: INSTALLATION_DIRS=     bin
1.43      wiz        39: BUILD_DIRS+=           src
1.17      rh         40: BUILD_DIRS+=           ${INSTALL_DIRS}
                     41:
1.33      markd      42: SUBST_CLASSES+=                progs
                     43: SUBST_STAGE.progs=     post-patch
                     44: SUBST_MESSAGE.progs=   Trim programs to build
                     45: SUBST_FILES.progs=     src/Makefile.in
                     46: SUBST_SED.progs=       -e s:@ENABLE_CONDUITS_TRUE@bin_PROGRAMS:@ENABLE_CONDUITS_TRUE@bin_PROGRAMSX:
                     47:
1.38      obache     48: post-extract:
                     49:        rm -f ${WRKSRC}/bindings/Perl/pm_to_blib
                     50:
1.33      markd      51: #post-patch:
                     52: #      cd ${WRKSRC} &&                                                 \
                     53: #      for mf in src/Makefile.in src/*/Makefile.in ; do                \
                     54: #              ${CP} $$mf $$mf.old &&                                  \
                     55: #              ${SED} -e 's|..top_builddir./lib[^/]*/\(lib[^\.]*\.la\)|${PREFIX}/lib/\1|g'     \
                     56: #                      < $$mf.old > $$mf ;                             \
                     57: #      done
1.17      rh         58:
                     59: post-install:
1.37      wiz        60: .for bin in pilot-ietf2datebook pilot-undelete pilot-sync-plan
1.17      rh         61:        cd ${WRKSRC}/src &&                                             \
1.39      joerg      62:        ${INSTALL_SCRIPT} ${bin} ${DESTDIR}${PREFIX}/bin
1.17      rh         63: .endfor
1.1       tron       64:
1.21      snj        65: .include "../../comms/pilot-link-libs/buildlink3.mk"
                     66: .include "../../graphics/png/buildlink3.mk"
1.16      seb        67: .include "../../lang/perl5/module.mk"
1.17      rh         68:
1.1       tron       69: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>