[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / comms / kermit

File: [cvs.NetBSD.org] / pkgsrc / comms / kermit / Makefile (download)

Revision 1.30, Wed Sep 13 02:26:50 2000 UTC (23 years, 7 months ago) by hubertf
Branch: MAIN
CVS Tags: netbsd-1-5-RELEASE, netbsd-1-4-PATCH003
Changes since 1.29: +2 -2 lines

Change license to 'kermit-license', as this pkg has a specific
license that's not covered by a general 'limited-redistribution'
license.

And even if you agree to honour the 'limited-redistribution' for
some other pkg (by putting ACCEPTABLE_LICENSES=... into /etc/mk.conf),
that doesn't mean you also agree to not redistribute kermit.

Modeled after the www/jsdk20 license.

# $NetBSD: Makefile,v 1.30 2000/09/13 02:26:50 hubertf Exp $
# $FreeBSD Id: Makefile,v 1.17 1997/11/26 23:16:51 jseger Exp
#

DISTNAME=	cku196
PKGNAME=        kermit-7.0.196
CATEGORIES=	comms
MASTER_SITES=	ftp://kermit.columbia.edu/kermit/archives/

MAINTAINER=	packages@netbsd.org
HOMEPAGE=	http://www.columbia.edu/kermit/

LICENSE=	kermit-license

ALL_TARGET=	netbsd
BUILD_DEFS+=	KFLAGS LIBS KERMIT_SUID_UUCP
MAKE_ENV+=	KFLAGS="${KFLAGS}" LIBS="${LIBS}"
MAKEFILE=	makefile
NO_WRKSUBDIR=	YES
PLIST_SRC=	${WRKDIR}/PLIST

#KFLAGS+=	-DNODEBUG -DNOOLDMODEMS

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/wermit ${PREFIX}/bin/kermit
	@${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
	for OPT in ${MANINSTALL} broken-solaris-needs-this; do \
	  case $$OPT in \
	    catinstall) \
		nroff -man ${WRKSRC}/ckuker.nr > ${WRKSRC}/kermit.0; \
		${INSTALL_MAN} ${WRKSRC}/kermit.0 ${PREFIX}/man/cat1/kermit.0; \
		${ECHO} man/cat1/kermit.0 >>${PLIST_SRC}; \
		;; \
	    maninstall) \
		${INSTALL_MAN} ${WRKSRC}/ckuker.nr ${PREFIX}/man/man1/kermit.1; \
		${ECHO} man/man1/kermit.1 >>${PLIST_SRC}; \
		;; \
	  esac; \
	done

.include "../../mk/bsd.prefs.mk"

.if defined(KERMIT_SUID_UUCP)
.if ${KERMIT_SUID_UUCP} == "yes" || ${KERMIT_SUID_UUCP} == "YES"
BINOWN=		uucp
BINMODE=	4555
.endif
.endif

.for __tmp__ in NetBSD-1.3*
.if ${MACHINE_PLATFORM:M${__tmp__}} != ""
LIBS+=          -ltermcap
.endif
.endfor

# XXX This needs to be tested. XXX
#
# Include SOCKS firewall support
.if defined(USE_SOCKS)
.if ${USE_SOCKS} == 4
DEPENDS+=	socks4-2.2:../../net/socks4
KFLAGS+=	-DSOCKS
LIBS+=		-L${PREFIX}/lib -Wl,-R${PREFIX}/lib -lsocks
.elif ${USE_SOCKS} == 5
DEPENDS+=	socks5-1.0.2:../../net/socks5
KFLAGS+=	-DSOCKS -DCK_SOCKS5
LIBS+=		-L${PREFIX}/lib -Wl,-R${PREFIX}/lib -lsocks5
.endif
.endif

.include "../../mk/bsd.pkg.mk"