[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / comms / jpilot

File: [cvs.NetBSD.org] / pkgsrc / comms / jpilot / Makefile (download)

Revision 1.4, Mon Jul 10 10:40:39 2000 UTC (23 years, 9 months ago) by agc
Branch: MAIN
Changes since 1.3: +2 -2 lines

Hardcoding X11PREFIX into package Makefiles forces the user to install
xpkgwedge once, before any other packages have been installed, and
never to delete it.  This change finds the prefix of the installed
pre-req package using pkg_info(1), and allows packages to be found in
${X11BASE} and ${LOCALBASE}, not just ${X11PREFIX} - from mail from
Dave Sainty <dave@dtsp.co.nz>, munged slightly by myself.

# $NetBSD: Makefile,v 1.4 2000/07/10 10:40:39 agc Exp $
#

DISTNAME=		jpilot-0.98.1
CATEGORIES=		comms
MASTER_SITES=		http://jpilot.linuxave.net/

MAINTAINER=		rh@netbsd.org
HOMEPAGE=		http://jpilot.linuxave.net/

DEPENDS+=		gtk+>=1.2.0:../../x11/gtk
DEPENDS+=		pilot-link>=0.9.3:../../comms/pilot-link

GNU_CONFIGURE=		YES
USE_LIBTOOL=		YES
USE_X11=		YES

LTCONFIG_OVERRIDE=	${WRKSRC}/ltconfig
CONFIGURE_ARGS+=	--with-gtk-prefix="`${PKG_INFO} -qp gtk+ | ${AWK} '{print $$2}'`"
CONFIGURE_ARGS+=	--with-pilot-prefix=${LOCALBASE}

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/lib/jpilot/plugins

.include "../../mk/bsd.pkg.mk"