[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / comms / jpilot-syncmal

File: [cvs.NetBSD.org] / pkgsrc / comms / jpilot-syncmal / Makefile (download)

Revision 1.32, Wed Aug 10 20:56:13 2005 UTC (18 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.31: +2 -3 lines

Remove the abuse of buildlink that was pkg-config/buildlink3.mk.  That
file's sole purpose was to provide a dependency on pkg-config and set
some environment variables.  Instead, turn pkg-config into a "tool"
in the tools framework, where the pkg-config wrapper automatically
adds PKG_CONFIG_LIBDIR to the environment before invoking the real
pkg-config.

For all package Makefiles that included pkg-config/buildlink3.mk, remove
that inclusion and replace it with USE_TOOLS+=pkg-config.

# $NetBSD: Makefile,v 1.32 2005/08/10 20:56:13 jlam Exp $

DISTNAME=		jpilot-syncmal_0.71.2
PKGNAME=		jpilot-syncmal-0.71.2
PKGREVISION=		5
CATEGORIES=		comms
MASTER_SITES=		http://jasonday.home.att.net/code/syncmal/

MAINTAINER=		tech-pkg@NetBSD.org
HOMEPAGE=		http://jasonday.home.att.net/code/syncmal/syncmal.html
COMMENT=		MAL synchronization plugin for J-Pilot

BUILDLINK_DEPMETHOD.jpilot=	full

USE_TOOLS+=		gmake pkg-config

USE_LIBTOOL=		# defined
SHLIBTOOL_OVERRIDE=	libtool

GNU_CONFIGURE=		# defined
CONFIGURE_ARGS+=	--enable-gtk2
CONFIGURE_ARGS+=	--with-plugin-prefix=${BUILDLINK_PREFIX.jpilot}/include/jpilot
CONFIGURE_ARGS+=	--with-pilot-prefix=${BUILDLINK_PREFIX.pilot-link-libs}
MAKE_ENV+=		PILOT_LINK_DIR=${BUILDLINK_PREFIX.pilot-link-libs}
CFLAGS+=		-D__unix__=1

PLUGINSDIR=		${PREFIX}/lib/jpilot/plugins
PLIST_SUBST+=		PLUGINSDIR=${PLUGINSDIR:S/${PREFIX}\///}

.include "../../comms/jpilot/buildlink3.mk"
.include "../../comms/pilot-link-libs/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"