File:  [cvs.NetBSD.org] / pkgsrc / comms / dfu-util / Makefile
Revision 1.3: download - view: text, annotated - select for diffs
Sun Nov 3 12:04:12 2019 UTC (5 years ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, HEAD
comms: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

Manually adjusted the indentation in asterisk15 and asterisk16 to avoid
too deep indentation.

# $NetBSD: Makefile,v 1.3 2019/11/03 12:04:12 rillig Exp $
#

DISTNAME=		dfu-util-0.9
CATEGORIES=		comms
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=dfu-util/files/}

MAINTAINER=		noud4@users.sourceforge.net
HOMEPAGE=		http://dfu-util.sourceforge.net/
COMMENT=		Host side implementation of the USB DFU protocol
LICENSE=		gnu-gpl-v2

GNU_CONFIGURE=		YES

CPPFLAGS+=		"-I${BUILDLINK_PREFIX.libusb1}/include/libusb-1.0"

CONFIGURE_ARGS+=	-prefix=${PREFIX}
CONFIGURE_ARGS+=	CPPFLAGS="${CPPFLAGS}"

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} != "FreeBSD" && ${OPSYS} != "DragonFly"
BUILDLINK_TRANSFORM+=	l:usb:usb-1.0
.endif

.include "../../devel/libusb1/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>