[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / weechat

File: [cvs.NetBSD.org] / pkgsrc / chat / weechat / Makefile (download)

Revision 1.32, Wed Jun 13 11:33:30 2012 UTC (11 years, 9 months ago) by abs
Branch: MAIN
Changes since 1.31: +3 -4 lines

Updated chat/weechat to 0.3.8 (confirmed via maintainer)

pkgsrc changes: enable gnutls by default, switch to tar.bz2 distfile

Version 0.3.8 (2012-06-03)
--------------------------

* core: support lines of 16 Kb long in configuration files (instead of 1 Kb)
* core: fix crash in focus hook for nicklist (bug #36271)
* core: fix truncated configuration files (zero-length) after system crash
  (bug #36383)
* core: fix display bugs and crashs with small windows (bug #36107)
* core: convert options weechat.look.prefix_align_more and
  weechat.look.prefix_buffer_align_more from boolean to string (task #11197)
* core: fix display bug with prefix when length is greater than max and prefix
  is ending with a wide char (bug #36032)
* core: add option weechat.look.prefix_same_nick (hide or change prefix on
  messages whose nick is the same as previous message) (task #11965)
* core: convert tabs to spaces in text pasted (bug #25028)
* core: add a connection timeout for child process in hook_connect (bug #35966)
* core: follow symbolic links when writing configuration files (.conf)
  (task #11779)
* core: fix lost scroll when switching to a buffer with a pending search
* core: add support of terminal "bracketed paste mode", new options
  weechat.look.paste_bracketed and weechat.look.paste_bracketed_timer_delay
  (task #11316)
* core: fix display of wide chars on last column of chat area (patch #7733)
* doc: add japanese FAQ (patch #7781)
* api: display warning in scripts when invalid pointers (malformed strings) are
  given to plugin API functions (warning displayed if debug for plugin is >= 1)
* api: add list "gui_buffer_last_displayed" in hdata "buffer"
* scripts: fix type of argument "rc" in callback of hook_process (from string to
  integer)
* guile: fix crash on ARM when loading guile plugin (bug #36479)
* guile: add missing function "hook_process_hashtable" in API
* irc: update channel modes by using chanmodes from message 005 (do not send
  extra command "MODE" to server), fix parsing of modes (bug #36215)
* irc: add option "fakerecv" for command /server to simulate a received IRC
  message (not documented, for debug only)
* irc: hide everything after "identify" or "register" in messages to nickserv
  when option irc.look.hide_nickserv_pwd is on (bug #36362)
* irc: add option "-pending" for command /disconnect (cancel auto-reconnection
  on servers currently reconnecting) (task #11985)
* irc: set user modes only if target nick is self nick in message 221
  (patch #7754)
* irc: force the clear of nicklist when joining a channel (nicklist was not sync
  after znc reconnection) (bug #36008)
* irc: allow more than one nick in command /invite
* irc: do not send command "MODE #channel" on manual /names (do it only when
  names are received on join of channel) (bug #35930)
* irc: do not allow the creation of two servers with same name but different
  case (fix error when writing file irc.conf) (bug #35840)
* irc: update away flag for nicks on manual /who
* irc: display privmsg messages to "@#channel" and "+#channel" in channel buffer
  (bug #35331)
* irc: fix redirection of message when message is queued for sending on server
* irc: add signals and tags in messages for irc notify (task #11887)
* irc: check notify immediately when adding a nick to notify list, improve
  first notify message for a nick (bug #35731)
* irc: fix display of color in hostname (join/part/quit messages)
* irc: compute hash to find nick color for nick in server message when nick
  is not in nicklist
* irc: add support of "external" SASL mechanism (task #11864)
* irc: close server buffer when server is deleted
* irc: add search for lower case nicks in option irc.look.nick_color_force
* logger: fix charset of lines displayed in backlog when terminal charset is
  different from UTF-8 (bug #36379)
* logger: add colors for backlog lines and end of backlog, new options:
  logger.color.backlog_line and logger.color.backlog_end (task #11966)
* perl: fix compilation on OS X (bug #30701)
* perl: fix crash on quit on OS X
* relay: keep spaces in beginning of "input" received from client (WeeChat
  protocol)
* relay: add signals "upgrade" and "upgrade_ended" in WeeChat protocol
* relay: fix crash on /upgrade when client is connected using WeeChat protocol
* relay: redirect some irc messages from clients to hide output (messages: mode,
  ison, list, names, topic, who, whois, whowas, time, userhost) (bug #33516)
* relay: add "date_printed" and "highlight" in signal "_buffer_line_added"
  (WeeChat protocol)
* rmodifier: add default rmodifier "quote_pass" to hide password in command
  "/quote pass" (bug #36250)
* rmodifier: add default rmodifier "server" to hide passwords in commands
  /server and /connect (task #11993)
* rmodifier: add option "release" in default rmodifier "nickserv" (used to hide
  passwords in command "/msg nickserv") (bug #35705)
* tcl: add missing function "hdata_char" in API
* tcl: fix pointer sent to function hook_signal_send when type of data is
  a pointer

# $NetBSD: Makefile,v 1.32 2012/06/13 11:33:30 abs Exp $

DISTNAME=	weechat-0.3.8
CATEGORIES=	chat
MASTER_SITES=	http://www.weechat.org/files/src/

MAINTAINER=	tonio@NetBSD.org
HOMEPAGE=	http://www.weechat.org/
COMMENT=	Lightweight and user friendly curses based IRC client
LICENSE=	gnu-gpl-v3
EXTRACT_SUFX=	.tar.bz2

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	user-destdir

USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		msgfmt
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--disable-tcl --disable-guile --disable-aspell
MAKE_ENV+=		INSTALL_DATA_DIR=${INSTALL_DATA_DIR:Q}
MAKE_ENV+=		PREFIX=${DESTDIR:Q}${PREFIX:Q}
LIBS.SunOS+=		-lnsl

.include "options.mk"

.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/libidn/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"