[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / telepathy-gabble

File: [cvs.NetBSD.org] / pkgsrc / chat / telepathy-gabble / Attic / Makefile (download)

Revision 1.9.2.1, Wed Jan 27 16:51:33 2010 UTC (14 years, 2 months ago) by tron
Branch: pkgsrc-2009Q4
Changes since 1.9: +4 -6 lines

Pullup ticket #2975 - requested by wiz
gnome-terminal: build fix
gtk2: build fix
libxcb: build fix
py-xcbgen: build fix
telepathy-gabble: build fix
telepathy-glib: build fix
telepathy-idle: build fix

Revisions pulled up:
- chat/telepathy-gabble/Makefile		1.11
- chat/telepathy-glib/Makefile			1.17
- chat/telepathy-idle/Makefile			1.11
- x11/gnome-terminal/Makefile			1.30
- x11/gtk2/Makefile				1.196
- x11/libxcb/Makefile				1.9
- x11/py-xcbgen/Makefile			1.5
---
Module Name:	pkgsrc
Committed By:	wiz
Date:		Wed Jan 27 08:46:51 UTC 2010

Modified Files:
	pkgsrc/chat/telepathy-gabble: Makefile
	pkgsrc/chat/telepathy-glib: Makefile
	pkgsrc/chat/telepathy-idle: Makefile
	pkgsrc/x11/gnome-terminal: Makefile
	pkgsrc/x11/gtk2: Makefile

Log Message:
Depend on py-expat for all supported python versions, now that
python25 and python26 have been fixed to behave like python24.
---
Module Name:	pkgsrc
Committed By:	wiz
Date:		Wed Jan 27 13:59:47 UTC 2010

Modified Files:
	pkgsrc/x11/py-xcbgen: Makefile

Log Message:
Needs py-expat nowadays. Depend on it and bump PKGREVISION.
---
Module Name:	pkgsrc
Committed By:	wiz
Date:		Wed Jan 27 14:00:33 UTC 2010

Modified Files:
	pkgsrc/x11/libxcb: Makefile

Log Message:
Depend on py-xcbgen that has py-expat dependency.
There are some 1.6 packages (post-python2{5,6} changes) that don't pull
py-expat in and fail.

# $NetBSD: Makefile,v 1.9.2.1 2010/01/27 16:51:33 tron Exp $
#

DISTNAME=	telepathy-gabble-0.9.2
PKGREVISION=	2
CATEGORIES=	chat
MASTER_SITES=	http://telepathy.freedesktop.org/releases/telepathy-gabble/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://telepathy.freedesktop.org/wiki/Components
COMMENT=	Jabber/XMPP connection manager for Telepathy

BUILD_DEPENDS+=		${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat

PKG_DESTDIR_SUPPORT=	user-destdir

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_TOOLS+=	gmake pkg-config

pre-configure: wocky-pkg-config-hack
wocky-pkg-config-hack:
	${LN} -s ${WRKSRC}/lib/ext/wocky/wocky/wocky-uninstalled.pc \
		${BUILDLINK_DIR}/lib/pkgconfig

BUILDLINK_API_DEPENDS.telepathy-glib+=	telepathy-glib>=0.7.37
.include "../../chat/telepathy-glib/buildlink3.mk"
BUILDLINK_API_DEPENDS.glib2+=		glib2>=2.21.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../net/libsoup24/buildlink3.mk"
BUILDLINK_API_DEPENDS.dbus-glib+=	dbus-glib>=0.78
.include "../../sysutils/dbus-glib/buildlink3.mk"
BUILDLINK_API_DEPENDS.dbus+=		dbus>=1.1
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../textproc/libxslt/buildlink3.mk"
.include "../../security/cyrus-sasl/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"