[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / riece

File: [cvs.NetBSD.org] / pkgsrc / chat / riece / Makefile (download)

Revision 1.1, Tue Nov 30 08:18:39 2004 UTC (19 years, 4 months ago) by uebayasi
Branch: MAIN

Initial revision

# $NetBSD: Makefile,v 1.1 2004/11/30 08:18:39 uebayasi Exp $
#

DISTNAME=	riece-1.0.5
CATEGORIES=	chat japanese
MASTER_SITES=	http://wiliki.designflaw.org/riece/

MAINTAINER=	uebayasi@NetBSD.org
HOMEPAGE=	http://www.nongnu.org/riece/
COMMENT=	IRC client for Emacs

USE_NEW_EMACS_MK= \
		YES

EMACS_VERSIONS_ACCEPTED= \
		emacs21 emacs21nox xemacs214

.include "../../mk/emacs.mk"

GNU_CONFIGURE=	YES
.if ${EMACS_FLAVOR} == "emacs"
CONFIGURE_ARGS+=--with-emacs=${EMACS_BIN}
.elif ${EMACS_FLAVOR} == "xemacs"
CONFIGURE_ARGS+=--with-xemacs=${EMACS_BIN}
CONFIGURE_ARGS+=--with-packagedir=${EMACS_LISPPREFIX:C|/lisp\$||}
.elif ${EMACS_FLAVOR} == "xemacs"
.endif
# Riece digs sub directory.
CONFIGURE_ARGS+=--with-lispdir=${EMACS_LISPPREFIX}

INFO_FILES=	riece-ja.info

.include "../../mk/bsd.pkg.mk"