[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / py-mautrix

File: [cvs.NetBSD.org] / pkgsrc / chat / py-mautrix / Makefile (download)

Revision 1.6, Sun Oct 4 11:41:16 2020 UTC (12 months, 3 weeks ago) by js
Branch: MAIN
Changes since 1.5: +3 -3 lines

Update chat/py-mautrix to 0.7.11

0.7.2:
 * Added bridge config option to pass custom arguments to SQLAlchemy's
   create_engine

0.7.3:
 * Added support for telling the user about decryption errors in bridge module

0.7.4:
 * Made sender_device optional in decrypted olm events
 * Added opt_prometheus utility for using prometheus as an optional dependency
 * Added Matrix event time processing metric for bridges when prometheus is
   installed

0.7.5:
 * Added utility for measuring async method time in prometheus

0.7.6:
 * Fixed bug where parsing invite fails if unsigned is not set or null
 * Added trace logs when bridge module ignores messages

0.7.7:
 * Added utility method for waiting for incoming group sessions in OlmMachine
 * Made end-to-bridge encryption helper wait for incoming group sessions for 3
   seconds

0.7.8:
 * Made the UUID type de/serializable by default

0.7.9:
 * Added parameter to change how long EncryptionManager.decrypt() should wait
   for the megolm session to arrive
 * Changed get_displayname and get_avatar_url to ignore M_NOT_FOUND errors
 * Updated type hint of set_reply to allow EventIDs

0.7.10:
 * Fixed deserializing the info object in media msgtypes into dataclasses

0.7.11:
No changes published.

# $NetBSD: Makefile,v 1.6 2020/10/04 11:41:16 js Exp $

DISTNAME=	mautrix-python-0.7.11
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/-python//}
CATEGORIES=	chat python
MASTER_SITES=	${MASTER_SITE_GITHUB:=tulir/}
GITHUB_PROJECT=	mautrix-python
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	js@pkgsrc.org
HOMEPAGE=	https://github.com/tulir/mautrix-python
COMMENT=	Python 3 asyncio Matrix framework
LICENSE=	mpl-2.0

PYTHON_VERSIONS_INCOMPATIBLE=	27

DEPENDS+=	${PYPKGPREFIX}-aiohttp>=3<4:../../www/py-aiohttp
DEPENDS+=	${PYPKGPREFIX}-attrs>=18.1.0:../../devel/py-attrs
DEPENDS+=	${PYPKGPREFIX}-yarl>=1.5.1:../../www/py-yarl

USE_LANGUAGES=	# none
EGG_NAME=	mautrix-${PKGVERSION_NOREV}

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"