[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / mautrix-telegram

File: [cvs.NetBSD.org] / pkgsrc / chat / mautrix-telegram / PLIST (download)

Revision 1.3, Sat Jan 15 20:22:06 2022 UTC (2 years, 3 months ago) by js
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.2: +42 -98 lines

Update chat/mautrix-telegram to 0.11.1


v0.10.2
Deprecation unwarning

While switching away from SQLAlchemy is still planned for v0.11, SQLite is no longer deprecated and will still be supported in the future using aiosqlite.
Added

  * Added extensions when bridging unnamed files from Telegram.
  * Added support for custom bridge bot welcome messages (thanks to @justinbot in #676).

Improved

  * Improved handling authorization errors if the bridge was logged out remotely.
  * Updated room syncer to use existing power levels to find appropriate levels for admins and normal users instead of hardcoding 50 and 0.
  * Updated to Telegram API layer 133 to handle 64-bit user/chat/channel IDs.
  * Stopped logging message contents when message handling failed (thanks to @justinbot in #681).
  * Removed Element iOS compatibility hack from non-sticker files.
  * Made max_initial_member_sync work for non-supergroups too (thanks to @tadzik in #680).
  * SQLite is now supported for the crypto database. Pickle is no longer supported. If you were using pickle, the bridge will create a new e2ee session and store the data in SQLite this time.

Fixed

  * Fixed generating reply fallbacks to encrypted messages.
  * Fixed chat sync failing if the member list contained banned users.


v0.11.0

  * Switched from SQLAlchemy to asyncpg/aiosqlite.
      * The default database is now Postgres. If using SQLite, make sure you install the sqlite optional dependency.
      * Alembic is no longer used, schema migrations happen automatically on startup.
      * The automatic database migration requires you to be on the latest legacy database version. If you were running any v0.10.x version, you should be on the latest version already. Otherwise, update to v0.10.2 first, upgrade the database with alembic, then upgrade to v0.11.0 (or higher).
  * Added support for contact messages.
  * Added support for Telegram sponsored messages in channels.
      * Only applies to broadcast channels with 1000+ members (as per https://t.me/durov/172).
      * Only applies if you're using puppeting with a normal user account, because bots can't get sponsored messages.
  * Fixed non-supergroup member sync incorrectly kicking one user from the Matrix side if there was no limit on the number of members to sync (broke in v0.10.2).
  * Updated animated sticker conversion to support lottieconverter r0.2 (thanks to @sot-tech in #694).
  * Updated Docker image to Alpine 3.15.
  * Formatted all code using black and isort.


v0.11.1

  * Added support for message reactions.
  * Added support for spoiler text.
  * Improved support for voice messages.
  * Improved color of blue text from Telegram to be more readable on dark themes.
  * Fixed syncing contacts throwing an error for new accounts.
  * Fixed migrating pre-v0.11 legacy databases if the database schema had been corrupted (e.g. by using 3rd party tools for SQLite -> Postgres migration).
  * Fixed converting animated stickers to webm with >33 FPS.
  * Fixed a bug in v0.11.0 that broke mentioning users in groups (thanks to @dfuchss in #724).

@comment $NetBSD: PLIST,v 1.3 2022/01/15 20:22:06 js Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/mautrix_telegram/__init__.py
${PYSITELIB}/mautrix_telegram/__init__.pyc
${PYSITELIB}/mautrix_telegram/__init__.pyo
${PYSITELIB}/mautrix_telegram/__main__.py
${PYSITELIB}/mautrix_telegram/__main__.pyc
${PYSITELIB}/mautrix_telegram/__main__.pyo
${PYSITELIB}/mautrix_telegram/abstract_user.py
${PYSITELIB}/mautrix_telegram/abstract_user.pyc
${PYSITELIB}/mautrix_telegram/abstract_user.pyo
${PYSITELIB}/mautrix_telegram/bot.py
${PYSITELIB}/mautrix_telegram/bot.pyc
${PYSITELIB}/mautrix_telegram/bot.pyo
${PYSITELIB}/mautrix_telegram/commands/__init__.py
${PYSITELIB}/mautrix_telegram/commands/__init__.pyc
${PYSITELIB}/mautrix_telegram/commands/__init__.pyo
${PYSITELIB}/mautrix_telegram/commands/handler.py
${PYSITELIB}/mautrix_telegram/commands/handler.pyc
${PYSITELIB}/mautrix_telegram/commands/handler.pyo
${PYSITELIB}/mautrix_telegram/commands/matrix_auth.py
${PYSITELIB}/mautrix_telegram/commands/matrix_auth.pyc
${PYSITELIB}/mautrix_telegram/commands/matrix_auth.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/__init__.py
${PYSITELIB}/mautrix_telegram/commands/portal/__init__.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/__init__.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/admin.py
${PYSITELIB}/mautrix_telegram/commands/portal/admin.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/admin.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/bridge.py
${PYSITELIB}/mautrix_telegram/commands/portal/bridge.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/bridge.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/config.py
${PYSITELIB}/mautrix_telegram/commands/portal/config.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/config.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/create_chat.py
${PYSITELIB}/mautrix_telegram/commands/portal/create_chat.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/create_chat.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/filter.py
${PYSITELIB}/mautrix_telegram/commands/portal/filter.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/filter.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/misc.py
${PYSITELIB}/mautrix_telegram/commands/portal/misc.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/misc.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/unbridge.py
${PYSITELIB}/mautrix_telegram/commands/portal/unbridge.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/unbridge.pyo
${PYSITELIB}/mautrix_telegram/commands/portal/util.py
${PYSITELIB}/mautrix_telegram/commands/portal/util.pyc
${PYSITELIB}/mautrix_telegram/commands/portal/util.pyo
${PYSITELIB}/mautrix_telegram/commands/telegram/__init__.py
${PYSITELIB}/mautrix_telegram/commands/telegram/__init__.pyc
${PYSITELIB}/mautrix_telegram/commands/telegram/__init__.pyo
${PYSITELIB}/mautrix_telegram/commands/telegram/account.py
${PYSITELIB}/mautrix_telegram/commands/telegram/account.pyc
${PYSITELIB}/mautrix_telegram/commands/telegram/account.pyo
${PYSITELIB}/mautrix_telegram/commands/telegram/auth.py
${PYSITELIB}/mautrix_telegram/commands/telegram/auth.pyc
${PYSITELIB}/mautrix_telegram/commands/telegram/auth.pyo
${PYSITELIB}/mautrix_telegram/commands/telegram/misc.py
${PYSITELIB}/mautrix_telegram/commands/telegram/misc.pyc
${PYSITELIB}/mautrix_telegram/commands/telegram/misc.pyo
${PYSITELIB}/mautrix_telegram/config.py
${PYSITELIB}/mautrix_telegram/config.pyc
${PYSITELIB}/mautrix_telegram/config.pyo
${PYSITELIB}/mautrix_telegram/db/__init__.py
${PYSITELIB}/mautrix_telegram/db/__init__.pyc
${PYSITELIB}/mautrix_telegram/db/__init__.pyo
${PYSITELIB}/mautrix_telegram/db/bot_chat.py
${PYSITELIB}/mautrix_telegram/db/bot_chat.pyc
${PYSITELIB}/mautrix_telegram/db/bot_chat.pyo
${PYSITELIB}/mautrix_telegram/db/message.py
${PYSITELIB}/mautrix_telegram/db/message.pyc
${PYSITELIB}/mautrix_telegram/db/message.pyo
${PYSITELIB}/mautrix_telegram/db/portal.py
${PYSITELIB}/mautrix_telegram/db/portal.pyc
${PYSITELIB}/mautrix_telegram/db/portal.pyo
${PYSITELIB}/mautrix_telegram/db/puppet.py
${PYSITELIB}/mautrix_telegram/db/puppet.pyc
${PYSITELIB}/mautrix_telegram/db/puppet.pyo
${PYSITELIB}/mautrix_telegram/db/reaction.py
${PYSITELIB}/mautrix_telegram/db/reaction.pyc
${PYSITELIB}/mautrix_telegram/db/reaction.pyo
${PYSITELIB}/mautrix_telegram/db/telegram_file.py
${PYSITELIB}/mautrix_telegram/db/telegram_file.pyc
${PYSITELIB}/mautrix_telegram/db/telegram_file.pyo
${PYSITELIB}/mautrix_telegram/db/telethon_session.py
${PYSITELIB}/mautrix_telegram/db/telethon_session.pyc
${PYSITELIB}/mautrix_telegram/db/telethon_session.pyo
${PYSITELIB}/mautrix_telegram/db/upgrade/__init__.py
${PYSITELIB}/mautrix_telegram/db/upgrade/__init__.pyc
${PYSITELIB}/mautrix_telegram/db/upgrade/__init__.pyo
${PYSITELIB}/mautrix_telegram/db/upgrade/v01_initial_revision.py
${PYSITELIB}/mautrix_telegram/db/upgrade/v01_initial_revision.pyc
${PYSITELIB}/mautrix_telegram/db/upgrade/v01_initial_revision.pyo
${PYSITELIB}/mautrix_telegram/db/upgrade/v02_sponsored_events.py
${PYSITELIB}/mautrix_telegram/db/upgrade/v02_sponsored_events.pyc
${PYSITELIB}/mautrix_telegram/db/upgrade/v02_sponsored_events.pyo
${PYSITELIB}/mautrix_telegram/db/upgrade/v03_reactions.py
${PYSITELIB}/mautrix_telegram/db/upgrade/v03_reactions.pyc
${PYSITELIB}/mautrix_telegram/db/upgrade/v03_reactions.pyo
${PYSITELIB}/mautrix_telegram/db/user.py
${PYSITELIB}/mautrix_telegram/db/user.pyc
${PYSITELIB}/mautrix_telegram/db/user.pyo
${PYSITELIB}/mautrix_telegram/example-config.yaml
${PYSITELIB}/mautrix_telegram/formatter/__init__.py
${PYSITELIB}/mautrix_telegram/formatter/__init__.pyc
${PYSITELIB}/mautrix_telegram/formatter/__init__.pyo
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/__init__.py
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/__init__.pyc
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/__init__.pyo
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/parser.py
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/parser.pyc
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/parser.pyo
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/telegram_message.py
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/telegram_message.pyc
${PYSITELIB}/mautrix_telegram/formatter/from_matrix/telegram_message.pyo
${PYSITELIB}/mautrix_telegram/formatter/from_telegram.py
${PYSITELIB}/mautrix_telegram/formatter/from_telegram.pyc
${PYSITELIB}/mautrix_telegram/formatter/from_telegram.pyo
${PYSITELIB}/mautrix_telegram/get_version.py
${PYSITELIB}/mautrix_telegram/get_version.pyc
${PYSITELIB}/mautrix_telegram/get_version.pyo
${PYSITELIB}/mautrix_telegram/matrix.py
${PYSITELIB}/mautrix_telegram/matrix.pyc
${PYSITELIB}/mautrix_telegram/matrix.pyo
${PYSITELIB}/mautrix_telegram/portal.py
${PYSITELIB}/mautrix_telegram/portal.pyc
${PYSITELIB}/mautrix_telegram/portal.pyo
${PYSITELIB}/mautrix_telegram/portal_util/__init__.py
${PYSITELIB}/mautrix_telegram/portal_util/__init__.pyc
${PYSITELIB}/mautrix_telegram/portal_util/__init__.pyo
${PYSITELIB}/mautrix_telegram/portal_util/deduplication.py
${PYSITELIB}/mautrix_telegram/portal_util/deduplication.pyc
${PYSITELIB}/mautrix_telegram/portal_util/deduplication.pyo
${PYSITELIB}/mautrix_telegram/portal_util/media_fallback.py
${PYSITELIB}/mautrix_telegram/portal_util/media_fallback.pyc
${PYSITELIB}/mautrix_telegram/portal_util/media_fallback.pyo
${PYSITELIB}/mautrix_telegram/portal_util/participants.py
${PYSITELIB}/mautrix_telegram/portal_util/participants.pyc
${PYSITELIB}/mautrix_telegram/portal_util/participants.pyo
${PYSITELIB}/mautrix_telegram/portal_util/power_levels.py
${PYSITELIB}/mautrix_telegram/portal_util/power_levels.pyc
${PYSITELIB}/mautrix_telegram/portal_util/power_levels.pyo
${PYSITELIB}/mautrix_telegram/portal_util/send_lock.py
${PYSITELIB}/mautrix_telegram/portal_util/send_lock.pyc
${PYSITELIB}/mautrix_telegram/portal_util/send_lock.pyo
${PYSITELIB}/mautrix_telegram/portal_util/sponsored_message.py
${PYSITELIB}/mautrix_telegram/portal_util/sponsored_message.pyc
${PYSITELIB}/mautrix_telegram/portal_util/sponsored_message.pyo
${PYSITELIB}/mautrix_telegram/puppet.py
${PYSITELIB}/mautrix_telegram/puppet.pyc
${PYSITELIB}/mautrix_telegram/puppet.pyo
${PYSITELIB}/mautrix_telegram/tgclient.py
${PYSITELIB}/mautrix_telegram/tgclient.pyc
${PYSITELIB}/mautrix_telegram/tgclient.pyo
${PYSITELIB}/mautrix_telegram/types.py
${PYSITELIB}/mautrix_telegram/types.pyc
${PYSITELIB}/mautrix_telegram/types.pyo
${PYSITELIB}/mautrix_telegram/user.py
${PYSITELIB}/mautrix_telegram/user.pyc
${PYSITELIB}/mautrix_telegram/user.pyo
${PYSITELIB}/mautrix_telegram/util/__init__.py
${PYSITELIB}/mautrix_telegram/util/__init__.pyc
${PYSITELIB}/mautrix_telegram/util/__init__.pyo
${PYSITELIB}/mautrix_telegram/util/color_log.py
${PYSITELIB}/mautrix_telegram/util/color_log.pyc
${PYSITELIB}/mautrix_telegram/util/color_log.pyo
${PYSITELIB}/mautrix_telegram/util/file_transfer.py
${PYSITELIB}/mautrix_telegram/util/file_transfer.pyc
${PYSITELIB}/mautrix_telegram/util/file_transfer.pyo
${PYSITELIB}/mautrix_telegram/util/parallel_file_transfer.py
${PYSITELIB}/mautrix_telegram/util/parallel_file_transfer.pyc
${PYSITELIB}/mautrix_telegram/util/parallel_file_transfer.pyo
${PYSITELIB}/mautrix_telegram/util/recursive_dict.py
${PYSITELIB}/mautrix_telegram/util/recursive_dict.pyc
${PYSITELIB}/mautrix_telegram/util/recursive_dict.pyo
${PYSITELIB}/mautrix_telegram/util/sane_mimetypes.py
${PYSITELIB}/mautrix_telegram/util/sane_mimetypes.pyc
${PYSITELIB}/mautrix_telegram/util/sane_mimetypes.pyo
${PYSITELIB}/mautrix_telegram/util/tgs_converter.py
${PYSITELIB}/mautrix_telegram/util/tgs_converter.pyc
${PYSITELIB}/mautrix_telegram/util/tgs_converter.pyo
${PYSITELIB}/mautrix_telegram/version.py
${PYSITELIB}/mautrix_telegram/version.pyc
${PYSITELIB}/mautrix_telegram/version.pyo
${PYSITELIB}/mautrix_telegram/web/__init__.py
${PYSITELIB}/mautrix_telegram/web/__init__.pyc
${PYSITELIB}/mautrix_telegram/web/__init__.pyo
${PYSITELIB}/mautrix_telegram/web/common/__init__.py
${PYSITELIB}/mautrix_telegram/web/common/__init__.pyc
${PYSITELIB}/mautrix_telegram/web/common/__init__.pyo
${PYSITELIB}/mautrix_telegram/web/common/auth_api.py
${PYSITELIB}/mautrix_telegram/web/common/auth_api.pyc
${PYSITELIB}/mautrix_telegram/web/common/auth_api.pyo
${PYSITELIB}/mautrix_telegram/web/provisioning/__init__.py
${PYSITELIB}/mautrix_telegram/web/provisioning/__init__.pyc
${PYSITELIB}/mautrix_telegram/web/provisioning/__init__.pyo
${PYSITELIB}/mautrix_telegram/web/public/__init__.py
${PYSITELIB}/mautrix_telegram/web/public/__init__.pyc
${PYSITELIB}/mautrix_telegram/web/public/__init__.pyo
${PYSITELIB}/mautrix_telegram/web/public/favicon.png
${PYSITELIB}/mautrix_telegram/web/public/login.css
${PYSITELIB}/mautrix_telegram/web/public/login.html.mako
${PYSITELIB}/mautrix_telegram/web/public/matrix-login.html.mako
share/mautrix-telegram/example-config.yaml