[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / irssi-xmpp

File: [cvs.NetBSD.org] / pkgsrc / chat / irssi-xmpp / Attic / Makefile (download)

Revision 1.18, Sat Apr 24 08:32:00 2021 UTC (2 years, 5 months ago) by nia
Branch: MAIN
Changes since 1.17: +2 -2 lines

irssi: update to 1.2.3

v1.2.3 2021-04-11 The Irssi team <staff@irssi.org>
	- Fix the compilation of utf8proc (#1021)
	- Fix wrong call to free. By Zero King (#1076)
	- Fix a colour reset in true colour themes when encountering
          mIRC colours (#1059)
	- Fix memory leak on malformed CAP requests (#1120)
	- Fix an erroneous free of SASL data. Credit to Oss-Fuzz (#1128,
	  #1130)
	- Re-set the TLS flag when reconnecting (#1027, #1134)
	- Fix the scrollback getting stuck after /clear (#1115, #1136)
	- Fix the input of Ctrl+C as the first character (#1153,  #1154)
	- Fix crash on quit during unloading of modules on certain
          platforms (#1167)
	- Fix Irssi freezing input after Ctrl+Space on GLib >2.62 (#1180,
	  #1183)
	- Fix layout of IDCHANs. By Lauri Tirkkonen (#1197)
	- Fix crash when server got reconnected before it was properly
          connected (#1210, #1211)
	- Fix multiple identical active caps (#1249)
	- Minor help corrections (#1156, #1213, #1214, #1255)
	- Remove erroneous colour in the colorless theme. Reported and
          fixed by Nutchanon Wetchasit (#1220, #1221)
	- Fix invalid bounds calculation when editing the text
          entry. Found and fixed by Sergey Valentey (#1269)
	- Fix passing of negative size in buffer writes. Found and
          fixed by Sergey Valentey (#1270)
	- Fix Irssi freezing on slow hardware and fast DCC transfers (#159,
	  #1271)
	- Fix compilation on Solaris (#1291)
	- Fix null pointer dereference when receiving broken JOIN
          record. Credit to Oss-Fuzz (#1292)
	- Fix crash on /connect to some sockets (#1239, #1298)
	- Fix Irssi rendering on Apple ARM. By Misty De Méo (#1267,
	  #1268, #1290)
	- Fix crash on /lastlog with broken lines (#1281, #1299)
	- Fix memory leak when receiving bogus SASL authentication
          data. Found and fixed by Sergey Valentey (#1293)

# $NetBSD: Makefile,v 1.18 2021/04/24 08:32:00 nia Exp $
#

DISTNAME=	irssi-xmpp-0.54
PKGREVISION=	2
CATEGORIES=	chat
MASTER_SITES=	https://cybione.org/~irssi-xmpp/files/
DISTFILES=	${DISTNAME}.tar.gz ${IRSSI_DISTFILE}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://cybione.org/~irssi-xmpp/
COMMENT=	Irssi plugin to connect to the Jabber network
LICENSE=	gnu-gpl-v2

DEPENDS+=	irssi>=${IRSSI_VERSION}:../../chat/irssi

.include "../../mk/bsd.prefs.mk"
.include "../../chat/irssi/Makefile.common"

MAKE_JOBS_SAFE=	no
USE_TOOLS+=	pkg-config
WRKSRC=		${WRKDIR}/${IRSSI_DISTNAME}/${DISTNAME}

MAKE_ENV+=	IRSSI_INCLUDE="${WRKDIR}/${IRSSI_DISTNAME}"

SUBST_CLASSES+=		makefile
SUBST_STAGE.makefile=	pre-build
SUBST_MESSAGE.makefile=	Fixing doc-install Makefile target.
SUBST_FILES.makefile=	Makefile
SUBST_SED.makefile+=	-e '/docs/s/install/install -m 644/'

SUBST_CLASSES.Darwin+=	osxmk
SUBST_STAGE.osxmk=	pre-build
SUBST_FILES.osxmk=	config.mk
SUBST_SED.osxmk=	-e 's,-shared,-dynamiclib -undefined dynamic_lookup,'

CFLAGS.SunOS+=	-D__BEGIN_DECLS= -D__END_DECLS=

post-extract:
	${MV} ${WRKDIR}/${DISTNAME} ${WRKDIR}/${IRSSI_DISTNAME}
	${CP} ${IRSSI_CONFIG_H} ${WRKSRC}/src/config.h

.include "../../chat/loudmouth/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"