[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / ircII

File: [cvs.NetBSD.org] / pkgsrc / chat / ircII / Makefile (download)

Revision 1.81, Thu Jan 17 05:21:24 2019 UTC (5 years, 3 months ago) by mrg
Branch: MAIN
Changes since 1.80: +2 -3 lines

update to ircII 20190116.  changes include:

  o  new /lastlog commands -saveall and -loadall that save and load the
     current window's lastlog, allowing session restoring
  o  new REFRESH_WINDOW_LASTLOG binding that will fully redraw the
     current window, using data from the lastlog, leaving it in a
     scrollable manner
  o  fix run-time errors on macOS
  o  ircII is now cross compileable
  o  add a basic help2html.pl script that converts the help pages into
     (poorly so far) formatted html pages, many help issues pages fixed
  o  restore case-insensitive /lastlog, accidentally broken in 20161207
  o  fix input line scrolling problem where it would not keep any of the
     existing input line.

# $NetBSD: Makefile,v 1.81 2019/01/17 05:21:24 mrg Exp $

DISTNAME=		ircii-${VERS}
PKGNAME=		ircII-${VERS}
CATEGORIES=		chat
MASTER_SITES=		http://ircii.warped.com/
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.eterna.com.au/ircii/
COMMENT=		'Internet Relay Chat' and 'Internet Citizens Band' Client
LICENSE=		modified-bsd

CONFLICTS=		blackened-[0-9]*

VERS=			20190116
PLIST_SUBST+=	VERS=${VERS:Q}

.include "../../mk/bsd.prefs.mk"

# By default, mandir defaults to @datarootdir@/man, and then it gets
# ${DESTDIR} applied already.  However, if you pass --mandir it does
# not provide it, and you have to supply it directly as well.  To do
# this in pkgsrc, we have to set CONFIGURE_HAS_MANDIR=no so that
# we don't pass --mandir=${PREFIX}/man as well, last.
CONFIGURE_HAS_MANDIR=	no
CONFIGURE_ARGS+=	--mandir=${DESTDIR}${PREFIX}/${PKGMANDIR}

WRKSRC=			${WRKDIR}/ircii-${VERS}
GNU_CONFIGURE=		yes
.if defined(DEFAULT_IRC_SERVER)
CONFIGURE_ARGS+=	--with-default-server=${DEFAULT_IRC_SERVER:Q}
.endif
USE_TOOLS+=		chmod	# see post-extract

# This pkg auto-detects IPv6.
BUILD_DEFS+=		IPV6_READY

.include "options.mk"

# Allow customizations from ${MAKECONF}
CONFIGURE_ARGS+=	${IRCII_CONFIGURE_ARGS}
CONFIGURE_ENV+=		${IRCII_CONFIGURE_ENV}

LDFLAGS.SunOS+=	-lsocket -lnsl
LDFLAGS+=	${BUILDLINK_LDADD.iconv}

CONFIGURE_ARGS.Interix+=	--with-non-blocking=none

# Optionally install compressed help files if MANZ is defined.
.if defined(MANZ)
PLIST_SUBST+=		GZSUFFIX=".gz"
DOC_COMPRESS_ARGS=	-z ${DESTDIR}${PREFIX}
.else
PLIST_SUBST+=		GZSUFFIX=
DOC_COMPRESS_ARGS=	${DESTDIR}${PREFIX}
.endif

post-extract:
	chmod -R g-w ${WRKSRC}/help/.

post-install:
	${AWK} '/^share\/irc\/help\// { sub("\\$${GZSUFFIX}$$", ""); print }' \
		${PLIST_SRC} |						\
	${SETENV} PATH=${PATH:Q} PKG_VERBOSE=${PKG_VERBOSE:Q}		\
	${SH} ${PKGSRCDIR}/mk/plist/doc-compress ${DOC_COMPRESS_ARGS}

.include "../../converters/libiconv/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/termcap.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"